Jump to content


Photo

IP problems since upgrade to 4.1.0.26.2 - Synology VPN - Shield TV

IP VPN Shield TV

  • Please log in to reply
4 replies to this topic

#1 Xeuz OFFLINE  

Xeuz

    Newbie

  • Members
  • 4 posts
  • Local time: 02:45 AM

Posted 22 April 2019 - 04:42 AM

Hi,

I run a synology NAS (DS1817+) with an external  VPN Network connection set on the unit and local IP which to date of update has worked flawlessly. 

Nice update otherwise, thank you .NET core update using less CPU time now. 

 

Until upgrade to the recent synology build the local network which uses 10.0.0.0 ect and still does connected to the Emby server on the NAS and used this range of IP.

After upgrade with the VPN on the Emby server picks up the VPN IP which is wrong and fails to connect.

Manual entry of the correct IP in the emby app for the server  does not work.

 

The only solution in my ignorance is to turn off the VPN connection and then emby will connect from the shield TV

 

I will add that the issue does not occur when using a mobile app or Mac or PC which strangely defaults to the VPN ip  and this issue therefore only occurs when using the Nividea Shield TV, it seems the emby app is now looking at the VPN as default rather than the local IP range set on the network and NAS. 

No other related apps have this issue. 

 

It also when the VPN is enabled allows Emby conection as explained and shown in the images via the local Lan using the VPN IP as the server and guess it makes sense other than the shield TV does not now like the setup and refuses connection. 

 

Ideas suggestion and help please as I am now lost and prefer to use the external VPN for other NAS applications if possible but retain use of the shield TV,  is this a bug with the shield TV app?

 

Attached File  Vpn1.png   19.89KB   3 downloads

Attached File  VPN.png   19.98KB   2 downloads

Attached File  Emby 1.png   11.21KB   2 downloads

 

Many thanks. 


Edited by Xeuz, 22 April 2019 - 05:01 AM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134545 posts
  • Local time: 09:45 PM

Posted 22 April 2019 - 05:54 PM

Hi there, does the server dashboard display the correct remote address?



#3 Xeuz OFFLINE  

Xeuz

    Newbie

  • Members
  • 4 posts
  • Local time: 02:45 AM

Posted 24 April 2019 - 05:23 AM

Hi there, does the server dashboard display the correct remote address?

HI thanks for the reply, please see the attached images in the original post, when the (synoogy) VPS is turned on the IP for the emby server changes to the IP of the VPS, resulting in no connetion from the shield TV, other methods, phone, PC, Mac interestingly still work with the changed VPS IP. 

The default should be the local network DHCP address and no the VPS.

 

The emby server should not be changing to use the VPS allocated local IP but retain the DHCP allocated IP when the VPS is connected, much like it did before update.

 

The exception and issue connecting is only relevant to the Shield TV objecting to the new IP allocated by the VPS and used by the Emby server, the code must simply look for the machine IP and not be able to differentiate the VPN against the DHCP allocated real local network IP.

 

Hope this makes it more clear, thanks in advance. 

 

X. 


Edited by Xeuz, 24 April 2019 - 05:27 AM.


#4 Xeuz OFFLINE  

Xeuz

    Newbie

  • Members
  • 4 posts
  • Local time: 02:45 AM

Posted 03 May 2019 - 08:53 AM

SOLUTION:

 

Apply latest Synology build, open emby server settings, go to advanced, set the server (Synology NAS) default local IP.

Shield TV now works as designed. 

VPS in Synology network can now be reconnected without IP change by emby to the live VPS.

 

I thank Luke for his responce, and hope this assets someone in the future. 


Edited by Xeuz, 03 May 2019 - 08:54 AM.

  • FrostByte likes this

#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134545 posts
  • Local time: 09:45 PM

Posted 10 May 2019 - 01:15 AM

@Xeuz thanks for the feedback.







Also tagged with one or more of these keywords: IP, VPN, Shield TV

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users