Jump to content
Guest peteamaro86

Cannot remotely access Emby on phone or web browser

Recommended Posts

Guest peteamaro86

I currently have Plex and wanting to switch over to Emby, but when I installed Emby yesterday and tried to access the server from work or I turned my Wifi off on my phone and used cell service, I keep getting a, "We're unable to connect to the selected server right now. Please ensure it is running and try again." Well, the server is running, can access it while on my network at home, but getting this error on my work computer and iPhone. On Plex, I am using the UPnP and it works great with my router, I have my firewall off, but I do have the inbound rule of port 80 open, so something is blocking this from working, but for the life of me, I can't figure it out since Plex works just fine with UPnP. Can someone help me, please?

 

 

  • Like 1

Share this post


Link to post
Share on other sites
ebr

Hi.  This is undoubtedly going to come down to router or other network configuration.  You aren't trying to use the same external port for both Plex and Emby are you?

 

Connectivity

Share this post


Link to post
Share on other sites
Guest peteamaro86

No I’m not, Plex is using port 32400 and Emby is using 8096 and 8920

Share this post


Link to post
Share on other sites
ebr

No I’m not, Plex is using port 32400 and Emby is using 8096 and 8920

 

Both internally and externally?

 

You said: 

 

but I do have the inbound rule of port 80 open, 

 

Where is port 80 being used?  Where is it routed?

Share this post


Link to post
Share on other sites
Guest peteamaro86

Private 192.168.0.*** : 32400  Public 68.203.140.** : 11903 

 

That is for Plex

 

Ran tasklist | findstr [emby]

 

EmbyServer.exe                3728 Console                    1    119,280 K
embytray.exe                  8432 Console                    1     11,876 K
 
Ran netstat -aon | findstr '[3728]'
 
  TCP    127.0.0.*:8096         127.0.0.*:64968        ESTABLISHED     3728
 TCP    192.168.0.***:8096     192.168.0.***:42510    ESTABLISHED     3728
 TCP    [::]:8096              [::]:0                 LISTENING       3728
  TCP    [::]:8920              [::]:0                 LISTENING       3728
  UDP    0.0.0.0:1900           *:*                                    3728
  UDP    0.0.0.0:7359           *:*                                    3728
UDP    192.168.0.***:53706    *:*                                    3728
 
Ran netstat -aon | findstr [80]
 
and nothing came up with port 80
Edited by peteamaro86

Share this post


Link to post
Share on other sites
arche

Just a quick question, for the user account do you have "Allow remote connections to this Emby Server" enabled? Also under advanced settings in the admin dashboard, do you have "Allow remote connections to this Emby Server" enabled?

Share this post


Link to post
Share on other sites
Guest peteamaro86

Yes I do for both of those questions.

Share this post


Link to post
Share on other sites
ReeceEmbyLol

I, too, am having this exact same issue. Came onto these forums to post about it, but found this instead.

 

Basically, Plex works outside of the network, whereas Emby does not. They are using different ports, and are not overlapped. My Vigor 2860 has UPnP. Plex works, Emby does not. The only way I get Emby working is if I disable the VPN route on the router and forward the port to my server's machine. None of this is needed on Plex, and Plex works constantly and consistently with or without a VPN and with and without UPnP.

 

Booting my server's machine without the VPN route on, and then turning it on after the fact, I can connect to my PC from outside the network. However, if I restart my server machine and the client machine, I can no longer not.

 

Does this make sense? If you need anything cleared up, let me know, but it's a make or break feature for me. 

Share this post


Link to post
Share on other sites
Guest peteamaro86

Error: I could not see your service on 68.203.140.** on port (8096)

Reason: Connection refused

Edited by peteamaro86

Share this post


Link to post
Share on other sites
Guest peteamaro86

Error: I could not see your service on 68.203.140.** on port (8920)
Reason: Connection refused

Share this post


Link to post
Share on other sites
arche

Error: I could not see your service on 68.203.140.** on port (8096)

Reason: Connection refused

 

Do you have the emby plugin "port mapper" installed?

Share this post


Link to post
Share on other sites
Guest peteamaro86

I don't see it in my plugins or in the plugin catalog.

Share this post


Link to post
Share on other sites
arche

I don't see it in my plugins or in the plugin catalog.

 

Oh, sorry. I'm on beta, not sure when it was switched to a plugin. Do you have Upnp enabled in Emby?

Share this post


Link to post
Share on other sites
Guest peteamaro86

should I try the beta version?

 

and yes I have it enabled.

Share this post


Link to post
Share on other sites
arche

should I try the beta version?

 

and yes I have it enabled.

 

Don't think beta will help a connection issue at the moment. I would first disabled ssl connections if your not actually using it and disable upnp and reboot emby. Then go to canyouseeme.org again and test again. Something is blocking your inbound connections because you have LAN connections working fine, so it most likely is a router configuration issue or windows firewall (but you said that is off). 

Share this post


Link to post
Share on other sites
ebr

 

Private 192.168.0.*** : 32400  Public 68.203.140.** : 11903 

 

That is for Plex

 

Ran tasklist | findstr [emby]

 

EmbyServer.exe                3728 Console                    1    119,280 K
embytray.exe                  8432 Console                    1     11,876 K
 
Ran netstat -aon | findstr '[3728]'
 
  TCP    127.0.0.*:8096         127.0.0.*:64968        ESTABLISHED     3728
 TCP    192.168.0.***:8096     192.168.0.***:42510    ESTABLISHED     3728
 TCP    [::]:8096              [::]:0                 LISTENING       3728
  TCP    [::]:8920              [::]:0                 LISTENING       3728
  UDP    0.0.0.0:1900           *:*                                    3728
  UDP    0.0.0.0:7359           *:*                                    3728
UDP    192.168.0.***:53706    *:*                                    3728
 
Ran netstat -aon | findstr [80]
 
and nothing came up with port 80

 

 

I don't see any port mapping for Emby there...  Did you do that?

Share this post


Link to post
Share on other sites
Guest peteamaro86

That is what I ran to figure out what Emby was using, ran those in CMD.

Share this post


Link to post
Share on other sites
Luke

@, are you still having an issue with this? Have you checked the port forwarding setup in your router?

Share this post


Link to post
Share on other sites
homelabsol
Posted (edited)

Hi, actually im having the same issue using emby server version 4.4.2.0. I will give u an example. 1 of my tester have 3 devices. 1 pc,q android and 1 ios. In his laptop and android its working fine. While accessing my emby server using ios, he cant get in. So what do u think is the problem? I have a post regarding this but no one is looking at it from your developer or admin. Hope you can improve your support.

Edited by homelabsol

Share this post


Link to post
Share on other sites
Luke

Hi, actually im having the same issue using emby server version 4.4.2.0. I will give u an example. 1 of my tester have 3 devices. 1 pc,q android and 1 ios. In his laptop and android its working fine. While accessing my emby server using ios, he cant get in. So what do u think is the problem? I have a post regarding this but no one is looking at it from your developer or admin. Hope you can improve your support.

Re: https://emby.media/community/index.php?/topic/85735-unable-to-connect-to-emby-server-using-android-and-ios-devices/?view=getlastpost

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...