Jump to content

Subtitle transcoding issues - PGS (sup) vs VobSub (idx/sub)


Recommended Posts

bobafett_h

I have recently started ripping my UHD Blu-rays for play back in Emby, and discovered issues with subtitle transcoding.

 

In the past, my 1080p Blu-ray rips have been in HEVC, whatever the main audio track is, as well as only forced/foreign subtitle tracks if there are any. Normally I would extract the PGS (.sup file) and convert to VobSub using BDSup2Sub and that would work fine. This has been a habit that started back when Blu-ray subs weren't supported by the codecs on my old HTPC way back when, but handled DVD subs (VobSub) fine.

 

The first 4K disc I have ripped that requires a forced subtitle track is Avengers: Infinity War for just one line of dialogue in the whole movie. I have tested playing this back using PGS, VobSub and also SRT. PGS and SRT seem to be OK and everything direct plays, however the VobSub version wants to transcode everything just to burn that single line of text onto the video. The HD audio also gets transcoded back to Dolby Digital.

 

To test this further, I went back and tried some 1080p Blu-rays I had ripped previously with VobSub subtitle tracks and found that they too are being transcoded. My main benchmark for testing subtitle playback has been my rip of Avatar which used to play fine, but now the subtitles are being burnt in and the audio is also not coming through as DTS-HD as it should. VobSub maintains the font style and colour from the PGS subs on movies such as this that would be lost if I used SRT.

 

My Emby server doesn't have the processor power for 4K transcoding, so it becomes unwatchable, but is fine with 1080p rips. So for future rips, I will be happy to use PGS as long as it continues to work properly. However, I would definitely prefer to avoid transcoding my older ones with VobSub subtitles so that the audio can be kept in the original HD format. I especially don't want to have to re-mux all of my older movies with different subtitles if it can be avoided either.

 

Current setup consists of Emby app running on an Nvidia Shield connected via HDMI to a Pioneer receiver (supports HDMI 1.4 and HD audio formats) then to a 4K Sony TV.

Link to post
Share on other sites

Hi.  VobSub is not currently supported by the player.  As you found, PGS is as are all the text-based formats.

Link to post
Share on other sites
bobafett_h

That's a shame. I was really hoping that I wouldn't have to do any re-ripping and re-muxing of movies.

 

 

Is there still an issue with zlib compressed subtitles at all?

Link to post
Share on other sites

Is there still an issue with zlib compressed subtitles at all?

 

For what subtitle format, PGS?

Link to post
Share on other sites
bobafett_h

For what subtitle format, PGS?

 

Yes, so I know whether or not I need to worry about it for future rips.

I believe there was an issue with PGS subs that had been muxed with zlib compression.

Edited by bobafett_h
Link to post
Share on other sites

Hi... somewhat new user here.

 

I have some MKVs with embedded styled softsubs that Emby play correctly in my Android phone, but don't play correctly in my Android TV or Emby Theater. VLC and Media Player Classic play them correctly in my Windows 10 PC and Kodi on my Android TV also play them correctly... any settings I should tweak?

Slightly off-topic. I was hoping to replace MiniDLNA running from my Asustor NAS to Emby, but when I browse my libraries using Emby on my Android TV, for some reason all movies show the same thumbnail. All my movies are in a folder, with the thumbnail file named exactly as the movie file. Kinda annoying as when I browse using MiniDLNA, thumbnails show correctly. Any ideas?

Link to post
Share on other sites

Hi... somewhat new user here.

 

I have some MKVs with embedded styled softsubs that Emby play correctly in my Android phone, but don't play correctly in my Android TV or Emby Theater. VLC and Media Player Classic play them correctly in my Windows 10 PC and Kodi on my Android TV also play them correctly... any settings I should tweak?

 

Hi there, what does "don't play correctly" mean? Please see how to report a media playback issue. thanks !

Link to post
Share on other sites

 

 

Slightly off-topic. I was hoping to replace MiniDLNA running from my Asustor NAS to Emby, but when I browse my libraries using Emby on my Android TV, for some reason all movies show the same thumbnail. All my movies are in a folder, with the thumbnail file named exactly as the movie file. Kinda annoying as when I browse using MiniDLNA, thumbnails show correctly. Any ideas?

 

Hi, how does this compare to what you see in the Emby web app?

Link to post
Share on other sites

It depends on what app you're playing from, but all apps support the custom styling at this point. Emby Theater does though.

Link to post
Share on other sites

Hi, how does this compare to what you see in the Emby web app?

In the Emby web app everything shows correctly... each movie has the correct thumbnail, corresponding to the movie.

 

My TV is a Sony Bravia XBR-55X805E, in case that helps anything. I know they are particularly finicky (to put it mildly). I haven't played with the "profiles"... I noticed there are some profiles for Sony TVs but the profiles stop at 2014... this is a 2017 model if I'm not mistaken.

Link to post
Share on other sites

It depends on what app you're playing from, but all apps support the custom styling at this point. Emby Theater does though.

 

There was an update to the Emby app that I just installed, but no joy... would you suggest to uninstall the app and reinstall it?

Link to post
Share on other sites

Hi.  The Android TV app does not currently support the styling in those types of subs (assuming ssa/ass).

Link to post
Share on other sites
  • 2 months later...

Hi.  The Android TV app does not currently support the styling in those types of subs (assuming ssa/ass).

 

Yes, its SSA/ASS styling. Are there plans to support this on the Android TV app soon?

Link to post
Share on other sites

Yes, its SSA/ASS styling. Are there plans to support this on the Android TV app soon?

 

There is an option in the app to use the server to burn these in to preserve the styling.

Link to post
Share on other sites

There is an option in the app to use the server to burn these in to preserve the styling.

 

I can give that a shot in the meantime. However, I'd prefer the app to do the decoding rather than the server to burn in the subs. I'm wondering why is it that the Android app can play SSA/ASS subs with styling and the Android TV app can't?

I'd assume they would be rather similar in terms of features.

Link to post
Share on other sites

I can give that a shot in the meantime. However, I'd prefer the app to do the decoding rather than the server to burn in the subs. I'm wondering why is it that the Android app can play SSA/ASS subs with styling and the Android TV app can't?

I'd assume they would be rather similar in terms of features.

 

Hi.  They use two different players.  The player used by the mobile app doesn't have to worry about supporting things like bitstreaming DTS-HD like the TV app does so we use a player designed specifically for all of those TV-based features (but doesn't yet support all specialized subtitle formats).

 

Thanks.

Link to post
Share on other sites
  • 1 month later...

Hi again,

 

I recently stumbled upon a movie with vobsub subtitles. I realized when the player was stuttering all over the place that it was transcoding due the unsupported subtitle format.

Is it possible to add native subtitle decoding for these image based formats for the Android TV app? And if not too much trouble, possibly native ASS/SSA decoding as well?  ^_^

 

Thanks!

Link to post
Share on other sites

The app supports PGS now just FYI and also it support direct playback of SSA if you don't require the formatting.

Link to post
Share on other sites
  • 1 year later...
Everbrave
On 7/26/2019 at 7:41 PM, Luke said:

Hi, yes it is something we plan to add in the future. thanks.

VOSUB still causes transcoding when using the Android TV app on nvidia Shield TV; any progress on this issue?

Edited by Everbrave
  • Like 1
Link to post
Share on other sites
ebr

You could test the beta of the mobile app (posted in the testing section).  If they play without transcoding there, then there is a good chance they will in this app soon.

Link to post
Share on other sites
  • 5 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...