Jump to content

ALBUMARTIST tag field ignored/cleared by emby


advanceratio
 Share

Recommended Posts

advanceratio

After solving one issue where an artist was replacing all albumartist fields of a certain name, I've ended up with a new and confusing problem.

 

emby seems to have decided that a  couple of my albumartist tags simply don't exist.  The two offending albumartist tags I've discovered so far are "KarenT" and "colate".  When emby scans the library, it either does not read those albumartist tags, thus leaving the album artist field blank, or is deleting them for some reason.

For reference, this library has all external metadata sources turned off.

 

This image shows all the tags assigned to one of the affected KarenT tracks (MP3Tag), and what emby sees.  Note the conspicuously blank album artist.

 

5c97e48123529_KarenT.png

 

Here's the same comparison for a colate track:

5c97e48cf32f7_colate.png

 

And, just for completeness, here's a track where everything was fine:

5c97e499948d8_EXITTUNES.png

 

There is no difference in the tags used that could relate to album artist, so why is emby clearing/not reading some seemingly at random?

Link to comment
Share on other sites

Make sure your tagging software is writing to all id3 versions. We use ffprobe to extract media info and it can be a little picky. You can try running your flac file through ffprobe to see what it outputs.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...