Jump to content


Photo

ALBUMARTIST tag field ignored/cleared by emby

music tagging bug albumartist

  • Please log in to reply
1 reply to this topic

#1 advanceratio OFFLINE  

advanceratio

    Newbie

  • Members
  • 7 posts
  • Local time: 10:20 AM

Posted 24 March 2019 - 04:13 PM

After solving one issue where an artist was replacing all albumartist fields of a certain name, I've ended up with a new and confusing problem.

 

emby seems to have decided that a  couple of my albumartist tags simply don't exist.  The two offending albumartist tags I've discovered so far are "KarenT" and "colate".  When emby scans the library, it either does not read those albumartist tags, thus leaving the album artist field blank, or is deleting them for some reason.

For reference, this library has all external metadata sources turned off.

 

This image shows all the tags assigned to one of the affected KarenT tracks (MP3Tag), and what emby sees.  Note the conspicuously blank album artist.

 

5c97e48123529_KarenT.png

 

Here's the same comparison for a colate track:

5c97e48cf32f7_colate.png

 

And, just for completeness, here's a track where everything was fine:

5c97e499948d8_EXITTUNES.png

 

There is no difference in the tags used that could relate to album artist, so why is emby clearing/not reading some seemingly at random?



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124650 posts
  • Local time: 12:20 PM

Posted 27 March 2019 - 12:11 PM

Make sure your tagging software is writing to all id3 versions. We use ffprobe to extract media info and it can be a little picky. You can try running your flac file through ffprobe to see what it outputs.







Also tagged with one or more of these keywords: music, tagging, bug, albumartist

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users