Jump to content


Photo

Music - Emby only reads my first Genre tag

Music Metadata Genre tags

  • Please log in to reply
16 replies to this topic

#1 Twistedcloud OFFLINE  

Twistedcloud

    Member

  • Members
  • 22 posts
  • Local time: 02:43 AM

Posted 22 January 2019 - 05:02 PM

Hello

 

For some reason Emby recently only started reading the first Genre tag in all of my music.

 

My Music folder is setup as Artist > Album > Tracks

 

My Music is tagged using Mp3Tag and Music Bee

Genre1//Genre2//Genre3//Genre4

 

Stone Sour

Come What(ever) May

Heavy Metal//Hard Rock//Alternative Metal//Post-Grunge

 

 

Emby only shows Heavy Metal.

Attached Files


Edited by Twistedcloud, 22 January 2019 - 05:07 PM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 139848 posts
  • Local time: 08:43 PM

Posted 22 January 2019 - 05:06 PM

What are the contents of the album folder? Can you show a screenshot?



#3 Twistedcloud OFFLINE  

Twistedcloud

    Member

  • Members
  • 22 posts
  • Local time: 02:43 AM

Posted 22 January 2019 - 05:10 PM

What are the contents of the album folder? Can you show a screenshot?

 

Just the music files

 

Edit I have tried playing around with it and it seems Emby is not reading my ID3 tags but rather the file details. if go into the file properties to details and update the genre tag there Emby will read it. 

 

My Emby will read a single tag: Heavy Metal//Hard Rock//Alternative Metal//Post-Grunge

My Emby won't read: Genre: Heavy Metal Genre: Hard Rock Genre: Alternative Metal

Attached Files


Edited by Twistedcloud, 22 January 2019 - 05:26 PM.


#4 Twistedcloud OFFLINE  

Twistedcloud

    Member

  • Members
  • 22 posts
  • Local time: 02:43 AM

Posted 22 January 2019 - 09:05 PM

Update,

 

my m4a and FLAC files work it only seems to be my MP3 files that are having an issue.

 

Edit:

 

I figured the issue may be with the ID# tags, Both MusicBrainz Picard and Musicbee have a default setting to save ID3v1 tags along with ID3v2.3 since both tags are saved past posts noted that Emby may not read them correctly I used ID3Remover to remove only the V1 tags and it is still not showing correctly.


Edited by Twistedcloud, 22 January 2019 - 10:06 PM.


#5 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 16076 posts
  • Local time: 05:43 PM
  • LocationWashington State

Posted 22 January 2019 - 09:23 PM

To me it is the delimiter you chose to tag with.  I just tagged a track with using a semi-colon and it displayed without issue after Refreshing the Album.

 

5c47c18daee20_genre.jpg

 

I believe Emby is limited to semi-colon or  single forward slash delimiters, not positive on any others.


Edited by Happy2Play, 22 January 2019 - 09:24 PM.


#6 Twistedcloud OFFLINE  

Twistedcloud

    Member

  • Members
  • 22 posts
  • Local time: 02:43 AM

Posted 22 January 2019 - 10:30 PM

To me it is the delimiter you chose to tag with.  I just tagged a track with using a semi-colon and it displayed without issue after Refreshing the Album.

 

5c47c18daee20_genre.jpg

 

I believe Emby is limited to semi-colon or  single forward slash delimiters, not positive on any others.

 

Odd, so MusicBee uses ; but when it saves it saves as // rather then ; which is causing the issue.



#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 139848 posts
  • Local time: 08:43 PM

Posted 23 January 2019 - 01:35 AM

Update,

 

my m4a and FLAC files work it only seems to be my MP3 files that are having an issue.

 

Edit:

 

I figured the issue may be with the ID# tags, Both MusicBrainz Picard and Musicbee have a default setting to save ID3v1 tags along with ID3v2.3 since both tags are saved past posts noted that Emby may not read them correctly I used ID3Remover to remove only the V1 tags and it is still not showing correctly.

 

Correct, we use ffprobe. Make sure your tagging software writes both and then it should work fine.



#8 Twistedcloud OFFLINE  

Twistedcloud

    Member

  • Members
  • 22 posts
  • Local time: 02:43 AM

Posted 23 January 2019 - 09:27 PM

Well MP3 tagging is super annoying

 

I use a combination of Emby, Kodi and MusicBee with Mp3Tagger and music BrainzPicard. 

 

MusicBee Reads the Following Tags:

Genre1; Genre2 or Genre1\\Genre2 

 

Kodi Reads the Following Tags:

Genre1\\Genre2 or Genre1 / Genre2

 

Emby Reads the following Tags:

Genre1; Genre2 or Genre1 / Genre2 and Genre1 \ Genre2

 

These 3 programs will not read the same set of ID3 tag for mulitpule Genre. The only work around I can see for anyone else who is running itno the same issue as me is to use Genre1; Genre2 and edit the kodi advanced system file to read ; rather then / (this may mess up tag reading for other file types)

 

If any one has a suggestion on a better way to tag all my media between these 3 programs that would be great.



#9 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 16076 posts
  • Local time: 05:43 PM
  • LocationWashington State

Posted 23 January 2019 - 09:38 PM

Ultimately Luke would need to see the output of what ffprobe sees.  Then maybe he can add additional delimiters.



#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 139848 posts
  • Local time: 08:43 PM

Posted 24 January 2019 - 02:05 AM

Can you provide sample audio for testing? thanks.



#11 Twistedcloud OFFLINE  

Twistedcloud

    Member

  • Members
  • 22 posts
  • Local time: 02:43 AM

Posted 24 January 2019 - 07:32 PM

Can you provide sample audio for testing? thanks.

 

I uploaded some Mp3 files with tags,

 

it seems Mp3Tags and MusicBee save tags by defult as in in File 1, This is the one Emby can not read. If I change the tags to either 02 or 03 Emby will read them (but that is a lot of work)

 

Attached Files


Edited by Twistedcloud, 24 January 2019 - 07:42 PM.


#12 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 16076 posts
  • Local time: 05:43 PM
  • LocationWashington State

Posted 24 January 2019 - 08:53 PM

1 &4 ffprobe doesn't see additional Genres.  So it looks like a limitation of FFprobe.

5c4a5d901f38d_doubleslash.jpg

5c4a5eba99a69_1.jpg

 

5c4a5dc2d1dd7_02.jpg

 

3

 

5c4a5dd859952_3.jpg


Edited by Happy2Play, 24 January 2019 - 08:56 PM.


#13 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 139848 posts
  • Local time: 08:43 PM

Posted 24 January 2019 - 11:40 PM

Its' probably reading a different version of the id3 tags. that's why if you make sure your tagging software writes all of them, then you should be fine.



#14 Twistedcloud OFFLINE  

Twistedcloud

    Member

  • Members
  • 22 posts
  • Local time: 02:43 AM

Posted 26 January 2019 - 03:28 PM

what do you use to tag and sort music before adding it into Emby? It seems both Mp3Tag and MusicBee save genre tags that FFprobe can't read



#15 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 139848 posts
  • Local time: 08:43 PM

Posted 26 January 2019 - 04:08 PM

Many people here use Mp3tag successfully. Picard is also popular.

 

@ginjaninja and @Vicpa may have some tips. Thanks.



#16 PenkethBoy OFFLINE  

PenkethBoy

    Advanced Member

  • Members
  • 3409 posts
  • Local time: 01:43 AM
  • LocationWarrington,UK

Posted 26 January 2019 - 04:37 PM

Use Picard to update and correct your metadata (uses data from MusicBrianz)

 

and solves 99% of peoples problems

 

Try it on a few albums you are having problems with



#17 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 16076 posts
  • Local time: 05:43 PM
  • LocationWashington State

Posted 26 January 2019 - 05:35 PM

Not that I understand it the backslash is used for "Quoting and Escaping", so I would suspect it will always be a issue in ffprobe.







Also tagged with one or more of these keywords: Music, Metadata, Genre, tags

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users