Jump to content


Photo
- - - - -

Plugin Catalog Not Allowing Downloads

plugin theme server not working wmc catalog

  • Please log in to reply
59 replies to this topic

#1 throgmorton OFFLINE  

throgmorton

    Advanced Member

  • Members
  • 282 posts
  • Local time: 09:40 AM

Posted 17 January 2019 - 08:01 PM

The Plugin Catalog in the WMC app doesn't seem to properly download files from the server (Testing with EMC 3.0.315.0) .  Basically I simply deleted one of my themes and tried to download it again and it basically hangs at installing the theme.  This was brought to my attention by a user having issues installing the theme.  I tried uploading a new version to the site and all seemed to process well but still it won't seem to download the file and basically just sticks a file with 0 bytes in the \programdata\plugin directory.

 

This is not limited to my themes as I tried to install the backdrop screen saver and the cover screen saver and the same issues occured.


Edited by throgmorton, 17 January 2019 - 08:03 PM.


#2 One2Go OFFLINE  

One2Go

    Advanced Member

  • Members
  • 520 posts
  • Local time: 09:40 AM

Posted 17 January 2019 - 10:34 PM

The Plugin Catalog in the WMC app doesn't seem to properly download files from the server (Testing with EMC 3.0.315.0) .  Basically I simply deleted one of my themes and tried to download it again and it basically hangs at installing the theme.  This was brought to my attention by a user having issues installing the theme.  I tried uploading a new version to the site and all seemed to process well but still it won't seem to download the file and basically just sticks a file with 0 bytes in the \programdata\plugin directory.

 

This is not limited to my themes as I tried to install the backdrop screen saver and the cover screen saver and the same issues occured.

The whole download of themes in the Plug in part is hosed.

 

Just restarted my PC and lost Destiny which it shows is not installed how can that be. Something awefully wrong here

 

@Luke and @ebr can you check what the difficulties are with the EMC Plugin Catalogue.

 

Thanks



#3 One2Go OFFLINE  

One2Go

    Advanced Member

  • Members
  • 520 posts
  • Local time: 09:40 AM

Posted 17 January 2019 - 10:51 PM

My setup is just so totally hosed and have no idea how this happened as I did no changes in the WMC setup. Here is now my present situation. I had gotten all your themes but the WMC plugin catalogue now says.

 

Ascendancy = Not installed

Imperium = Not installed

Destiny = Not installed

Regency = Not installed

Supremacy = Not Installed

 

Didn't expect this kind of trouble and problem. When I restarted the server because Destiny was the theme selected in WMC configuration since it is no longer showing as installed it put in its place Chocolate.

 

The fun with updates.


Edited by One2Go, 17 January 2019 - 11:13 PM.


#4 jachin99 OFFLINE  

jachin99

    Advanced Member

  • Members
  • 639 posts
  • Local time: 09:40 AM

Posted 17 January 2019 - 11:09 PM

Without speaking for Throgmorton I can tell you that once you have them, they are compatible with .316


Edited by jachin99, 17 January 2019 - 11:09 PM.


#5 One2Go OFFLINE  

One2Go

    Advanced Member

  • Members
  • 520 posts
  • Local time: 09:40 AM

Posted 17 January 2019 - 11:13 PM

Well I used to have all of them paid for them. No idea how they got deleted. I still have several of them like Centrality, Maelstrom, Harmony, Kismet and Vanilla.

 

There are a few updates in the plugin catalogue



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138076 posts
  • Local time: 09:40 AM

Posted 18 January 2019 - 12:58 AM

We'll see what @ebr thinks. Thanks for reporting.



#7 throgmorton OFFLINE  

throgmorton

    Advanced Member

  • Members
  • 282 posts
  • Local time: 09:40 AM

Posted 18 January 2019 - 08:57 AM

Well until its resolved I uploaded the DLLs to my dropbox so you guys are welcome to download it from there

 

https://www.dropbox....yfgQlTo-La?dl=0



#8 One2Go OFFLINE  

One2Go

    Advanced Member

  • Members
  • 520 posts
  • Local time: 09:40 AM

Posted 18 January 2019 - 10:46 AM

Thank you very much that was a life saver. Now back to restoring all the different settings. Thanks for your help.



#9 throgmorton OFFLINE  

throgmorton

    Advanced Member

  • Members
  • 282 posts
  • Local time: 09:40 AM

Posted 18 January 2019 - 10:50 AM

Well I used to have all of them paid for them. No idea how they got deleted. I still have several of them like Centrality, Maelstrom, Harmony, Kismet and Vanilla.

 

There are a few updates in the plugin catalogue

 

This is a total guess on my part but what I think happened based on the themes that remain is you probably didn't have the latest versions of my themes and so when you did this upgrade to the newer version of Emby it probably recognized that the plugins were out of date and just tried to download the new versions.  So with the catalog not functioning properly it probably just simply erased the old DLLs without getting the new ones.

 

Again this is a total guess on my part but could be the reason...



#10 One2Go OFFLINE  

One2Go

    Advanced Member

  • Members
  • 520 posts
  • Local time: 09:40 AM

Posted 18 January 2019 - 10:54 AM

No you are spot on with that assessment and if Destiny had an update then that explains why it was deleted and how Chocolate became now the default. Does it automatically check for any updates of the themes and then downloads them in the background?

 

Finally were you able to resolve the weather api issue that exists with Yahoo?

 

Thanks

O2G



#11 throgmorton OFFLINE  

throgmorton

    Advanced Member

  • Members
  • 282 posts
  • Local time: 09:40 AM

Posted 18 January 2019 - 11:07 AM

I think there is an option somewhere in the configuration menu that checks and installs on background if I'm not mistaken.

With regards to weather as I mentioned in the other thread needs some adjustment to core. So this needs to be done on that end. From what I've read is they would need to register the app with yahoo and then request access to the weather. This should still all be free but it's another layer of security yahoo has put in place. Then they will need to update the URL link they are using. Once that is all done I'm hoping there hasn't been any changes to the XML structure they are using so everything should work right away once that is completed.



Sent from my iPhone using Tapatalk

#12 ebr ONLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46991 posts
  • Local time: 09:40 AM

Posted 18 January 2019 - 11:10 AM

If you install the release version of EMC, does the plug-in download work?



#13 jachin99 OFFLINE  

jachin99

    Advanced Member

  • Members
  • 639 posts
  • Local time: 09:40 AM

Posted 18 January 2019 - 12:03 PM

If you install the release version of EMC, does the plug-in download work?

If this is absoluetly vital to figuring out the problem then I can install the release version and test.



#14 ebr ONLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46991 posts
  • Local time: 09:40 AM

Posted 18 January 2019 - 12:05 PM

If this is absoluetly vital to figuring out the problem then I can install the release version and test.

 

It would be very helpful because I don't know of anything that has changed here.  So I'm thinking it may be an external problem.

 

Thanks!



#15 jachin99 OFFLINE  

jachin99

    Advanced Member

  • Members
  • 639 posts
  • Local time: 09:40 AM

Posted 18 January 2019 - 12:14 PM

I tried centrality, and gamebrowser and they each download an assembly that is 0 kb


Edited by jachin99, 18 January 2019 - 12:15 PM.


#16 ebr ONLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46991 posts
  • Local time: 09:40 AM

Posted 18 January 2019 - 12:25 PM

I tried centrality, and gamebrowser and they each download an assembly that is 0 kb

 

This was with the stable version of EMC?



#17 throgmorton OFFLINE  

throgmorton

    Advanced Member

  • Members
  • 282 posts
  • Local time: 09:40 AM

Posted 18 January 2019 - 12:27 PM

This was with the stable version of EMC?

Out of curiosity what version is the stable version? Just so it can be double checked that the stable version is installed.


Sent from my iPhone using Tapatalk

Edited by throgmorton, 18 January 2019 - 12:28 PM.


#18 ebr ONLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46991 posts
  • Local time: 09:40 AM

Posted 18 January 2019 - 12:30 PM

.307



#19 jachin99 OFFLINE  

jachin99

    Advanced Member

  • Members
  • 639 posts
  • Local time: 09:40 AM

Posted 18 January 2019 - 12:40 PM

This was with the stable version of EMC?

Yes.  This PC has never had EMC installed until just now.



#20 One2Go OFFLINE  

One2Go

    Advanced Member

  • Members
  • 520 posts
  • Local time: 09:40 AM

Posted 18 January 2019 - 12:42 PM

The stable version is a none starter for all who have the new version of the server. You need the beta version as none of the Blu-ray or DVD folders will work with the stable version it does not detect that this is a Blu-ray or DVD it detects it as H.264 and H.262 and thus launches the wrong external player.

 

However it may be helpful determining why the download is 0 Bytes.

 

I since updated the DLLs manually sins Throg was so kind and posted a Dropbox link.







Also tagged with one or more of these keywords: plugin, theme, server, not working, wmc, catalog

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users