Jump to content


Photo

Audio metadata display incorrect on Pie

android pie bluetooth metadata audio

  • Please log in to reply
13 replies to this topic

#1 landgazr OFFLINE  

landgazr

    Advanced Member

  • Members
  • 60 posts
  • Local time: 06:30 PM
  • LocationOregon, USA

Posted 07 January 2019 - 04:55 PM

Hello all!

I just moved from Subsonic (using DSub on Android mobile) to Emby for my music as well as my videos. And for the most part it is doing pretty well now.

However, I noticed that an issue that had been reported for DSub is also currently manifesting itself in the Emby Android app in a very similar manner (with properly tagged and permissioned MP3 files). It has to do with BT metadata. It appears that, in Android 9 Pie, metadata display doesn't work like it used to with previous versions of the OS. Specifically, the song title is duplicated in the album name field now.

I am not sure why this is but I think it may be only affecting those with Pie (I have a stock Google Pixel 2). I apologize in advance if this may have been already reported; I tried to find via the forum search but was unsuccessful. I have the most recent version of the Emby Android app as of this post.

Many thanks!

Edited by landgazr, 10 January 2019 - 12:43 PM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124603 posts
  • Local time: 10:30 PM

Posted 07 January 2019 - 05:21 PM

Hi, thanks for the feedback. What do you mean by BT metadata? 



#3 landgazr OFFLINE  

landgazr

    Advanced Member

  • Members
  • 60 posts
  • Local time: 06:30 PM
  • LocationOregon, USA

Posted 08 January 2019 - 02:10 PM

Sorry, was probably using the wrong terminology :(
    
I was just referring to the MP3 audio metadata sent by the Emby app (ID3 data right?) over Bluetooth (BT) to a media player (in this case my Subaru!) and displayed on my dash (currently that data is displaying incorrectly). I'm not sure if that has anything to do with Bluetooth AVRCP profile...?

 

FWIW, I am running server version 3.6.0.81-beta. I can grab logs from my phone if necessary but I wasn't sure if that was relevant here.


Edited by landgazr, 08 January 2019 - 02:42 PM.


#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124603 posts
  • Local time: 10:30 PM

Posted 08 January 2019 - 03:52 PM

So you're playing from our android app to another media player? How do you do that exactly?



#5 landgazr OFFLINE  

landgazr

    Advanced Member

  • Members
  • 60 posts
  • Local time: 06:30 PM
  • LocationOregon, USA

Posted 08 January 2019 - 07:03 PM

What I probably should have said is that my phone (Google Pixel 2) connects to my car audio system for Bluetooth audio and Bluetooth calling. Then I play music with the Emby app to my car audio system :)



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124603 posts
  • Local time: 10:30 PM

Posted 09 January 2019 - 01:05 AM

So you're saying the same audio file will display differently depending on if it was played first or second?



#7 landgazr OFFLINE  

landgazr

    Advanced Member

  • Members
  • 60 posts
  • Local time: 06:30 PM
  • LocationOregon, USA

Posted 09 January 2019 - 02:01 PM

I tried it again this morning. It looks like DSub does this, but not the Emby Android app. In that case, it does it from the first song. In other words, as soon as I start playing music, the first song and all other songs after that display metadata incorrectly when using the Emby Android app.


Edited by landgazr, 09 January 2019 - 06:55 PM.


#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124603 posts
  • Local time: 10:30 PM

Posted 10 January 2019 - 12:03 AM

Is it possible for you to capture an image so that i can visualize this? thanks.



#9 landgazr OFFLINE  

landgazr

    Advanced Member

  • Members
  • 60 posts
  • Local time: 06:30 PM
  • LocationOregon, USA

Posted 10 January 2019 - 12:38 PM

Photo attached! The album name field has the song title in it instead.

Attached Files


Edited by landgazr, 10 January 2019 - 12:39 PM.


#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124603 posts
  • Local time: 10:30 PM

Posted 10 January 2019 - 04:14 PM

Ok thanks, we'll look into this.

Actually over the next few weeks we'll be rewriting the way the app reports playback to the system and that will possibly end up taking care of this.

It's hard to guarantee though because I know we've already been over this several times in terms of making sure all the fields on the system media session are set correctly. Thanks.
  • landgazr likes this

#11 landgazr OFFLINE  

landgazr

    Advanced Member

  • Members
  • 60 posts
  • Local time: 06:30 PM
  • LocationOregon, USA

Posted 10 January 2019 - 08:07 PM

No problem. Sorry for the misunderstandings but thank you for your help and assistance!



#12 Adromir OFFLINE  

Adromir

    Newbie

  • Members
  • 2 posts
  • Local time: 04:30 AM

Posted 15 January 2019 - 11:36 AM

Just registered here to report this Issue. It's not a problem just with Bluetooth, but generally in PIE apparently. I ran into this while Creating a basic Media Control Widget for Emby and was Confused when my Widget didn't show the Correct Media Data. I already thought my Library messed up



#13 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124603 posts
  • Local time: 10:30 PM

Posted 16 January 2019 - 02:27 AM

Thanks, we're looking into this.



#14 Adromir OFFLINE  

Adromir

    Newbie

  • Members
  • 2 posts
  • Local time: 04:30 AM

Posted 16 January 2019 - 09:01 AM

Apparently the Problem is mostly about Audiobooks. With normal Music the Metadata were shown Correctly, but with an Audiobook I tested the Album wasn't shown correctly







Also tagged with one or more of these keywords: android, pie, bluetooth, metadata, audio

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users