Jump to content

New Statistics plugin


reggi

Recommended Posts

DarWun
Posted (edited)
3 hours ago, hackthis02 said:

Before you go remove and added series. Try uninstalling and reinstalling the plugin. If I recall you're on the beta and had to revert to and older version.

Thanks @hackthis02. You are correct. I was sticking with v2.0.20.0 of the plug-in on the beta branch of Emby for the time being. With the new v2.1.x.0 releases the aired episode count doesn't work at all yet on Emby beta (i.e. aired episode count simply equals number of episodes in library for every series). I've been using v2.0.20.0 on the current Beta branch of Emby since it was released. Up until two days ago, the aired episode count on v2.0.20.0 was correct for all series. So it seemed like a no brainer to keep using it.

FYI I did uninstall the plugin and reinstall it. I had done that before posting about the issue. It didn't resolve the issue. I thought there might be a database corruption issue that removing a series and readding it would correct. But I no longer suspect that to be the case, for the reason below.

My primary Emby server is a Synology NAS. On it I allowed the Statistics plug-in to update to one of the new 2.1.x.0 versions. Because of the episode count issue I rolled back to v2.0.20.0 and have been blocking the update to a newer version since. But I also run Emby on Windows for testing purposes. On it I never allowed the update to the 2.1.x.0 version. It has been running 2.0.20.0 exclusively since 2.0.20.0 was released. The aired episode count inconsistencies are identical on both platforms for exactly the same series. On both, the inconsistencies only started showing up a couple of days ago.

Edited by DarWun
Link to comment
Share on other sites

DogBronson
3 hours ago, DarWun said:

Weird. Not sure what could be causing this on my setup "out of the blue". There is nothing in the Emby log that looks out of place, and the downloaded en.zip files look okay. In the screenshot below the aired episode count for Life on Mars is okay, but for Lost, Lovejoy, and Magnum, P.I. they are way off. I'm going to remove one of the problematic series from the library and readd it to see if the count corrects itself.

Screenshot 2022-05-06 144726.jpg

I'm having this same issue but for different shows:Untitled.png.f3119f983f9aca048a872037ddac8fac.png

 

All of a sudden Curb Your Enthusiasm shows 417 possible episodes but there are only 110. It was fine a few days ago but suddenly changed. I tried uninstalling and reinstalling the plugin, no good. I also have Lost in my library but it shows correctly for me, unlike DarWun, so the issue isn't specific to shows.

  • Like 1
Link to comment
Share on other sites

Happy2Play

Okay yes on BETA server with v2.0.20.0 plug I am seeing the same odd results on different shows.  Not much we can do until 4.7 goes stable for plugin dev to update plugin.  As everything currently works on stable release.  But there could have been something in the current beta releases the broke something also.  But do not remember what the last version it did not have this issue, maybe .35?

  • Like 1
Link to comment
Share on other sites

DarWun
10 minutes ago, DogBronson said:

I'm having this same issue but for different shows:

All of a sudden Curb Your Enthusiasm shows 417 possible episodes but there are only 110. It was fine a few days ago but suddenly changed. I tried uninstalling and reinstalling the plugin, no good. I also have Lost in my library but it shows correctly for me, unlike DarWun, so the issue isn't specific to shows.

Thanks for confirming I'm not alone in seeing this. And I just checked...Curb Your Enthusiasm just now showing 417 episodes for me as well. But Lost and a couple of other series that had this issue have now corrected themselves.

Link to comment
Share on other sites

DarWun
43 minutes ago, Happy2Play said:

Okay yes on BETA server with v2.0.20.0 plug I am seeing the same odd results on different shows.  Not much we can do until 4.7 goes stable for plugin dev to update plugin.  As everything currently works on stable release.  But there could have been something in the current beta releases the broke something also.  But do not remember what the last version it did not have this issue, maybe .35?

I think it was around the update to 0.36 when I first noticed something odd with the episode counts. Unfortunately I don't check those stats enough to know with any certainty. Having said that, the oldest backup on my Windows server is from back when 0.35 was installed. So I'll restore that backup and do some testing.

  • Like 1
Link to comment
Share on other sites

DarWun
Posted (edited)
13 hours ago, DarWun said:

I think it was around the update to 0.36 when I first noticed something odd with the episode counts. Unfortunately I don't check those stats enough to know with any certainty. Having said that, the oldest backup on my Windows server is from back when 0.35 was installed. So I'll restore that backup and do some testing.

This morning all episode counts are back to normal. The TVdb plugin was updated last night. Not sure if that is somehow related.

Edited by DarWun
Link to comment
Share on other sites

  • 3 weeks later...
hackthis02

Before anyone asks, I've downloaded 4.7 and am starting work on updated the plug-in. More news soon.

  • Like 4
Link to comment
Share on other sites

  • 3 weeks later...
On 5/23/2022 at 10:37 AM, hackthis02 said:

Before anyone asks, I've downloaded 4.7 and am starting work on updated the plug-in. More news soon.

@hackthis02The plugin just updated to v3.0.0.0, and I can happily report it seems to be working perfectly with the latest stable release of Emby (and with Beta 4.8.0.0 on my test server). The issue I'd reported on previously with incorrect aired episode counts on the 2.1.x versions is fixed. Scans complete much faster than with previous versions as well since it is using data that has already been downloaded. If I notice anything odd over the next couple of days, I'll report back.

Thanks for the update!!!

Edited by DarWun
  • Thanks 1
Link to comment
Share on other sites

ChaoOos
On 11/4/2021 at 3:59 PM, hackthis02 said:

This is on my list. But I'm currently working on implementing TVDB's new API's before the ones I'm currently using get deprecated.

Hi, I do not want to push 🙂
I just wanted to ask what the current status is.
Have you made any progress?

 

The Update for 4.7. is very fast. Nice work.

Link to comment
Share on other sites

hackthis02
1 minute ago, ChaoOos said:

Hi, I do not want to push 🙂
I just wanted to ask what the current status is.
Have you made any progress?

 

The Update for 4.7. is very fast. Nice work.

I'm guessing your referring to the odd resolution sizes? I'm currently working on that 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...