Jump to content

Subtitles can not be turned off


Marci32
 Share

Recommended Posts

musictalks

This is live TV. (morning show HD).

 

If the subs were burnt in, wouldn't the LGTV display them without Emby app?

The LG is not displaying subs (setting on LG=Off)

LG subs displaying (setting-On)

Emby is displaying subs. (Emby CC=English or CC=Off)

Link to comment
Share on other sites

This is live TV. (morning show HD).

 

If the subs were burnt in, wouldn't the LGTV display them without Emby app?

The LG is not displaying subs (setting on LG=Off)

LG subs displaying (setting-On)

Emby is displaying subs. (Emby CC=English or CC=Off)

 

I think I was looking at the wrong log, sorry. So yes it does show dvb_teletext. That's a strange one since we are dropping it from the transcoded output.

Link to comment
Share on other sites

I think I was looking at the wrong log, sorry. So yes it does show dvb_teletext. That's a strange one since we are dropping it from the transcoded output.

The issue is the dvb_teletext appears to be always on when direct playing. Normally turning off closed captions in the tv accessibility menu should disable these, but for some reason it’s not.

Link to comment
Share on other sites

  • 3 months later...
Senorgreg

I am experiencing this same issue with live TV on WebOS 4.71.05. Is there any further information on whether this is fixable or a fix is in the works?

 

Thank you.

Link to comment
Share on other sites

SamES

I am experiencing this same issue with live TV on WebOS 4.71.05. Is there any further information on whether this is fixable or a fix is in the works?

 

Thank you.

 

 

4.71.05 will be the firmware version.   The webOS version should be listed separately.  I expect the TV is webos version 1 or 2

 

http://webostv.developer.lge.com/common-page/faqs/general-how-check-platform-version-my-tv/?&ccm_paging_p=3

Link to comment
Share on other sites

Senorgreg

Thank you. Upon closer inspection it says the following, not sure if I have the correct software version yet:

 

webOS TV Version:

4.7.1-50012 (goldilocks2-gulaga)

Link to comment
Share on other sites

SamES

Thank you. Upon closer inspection it says the following, not sure if I have the correct software version yet:

 

webOS TV Version:

4.7.1-50012 (goldilocks2-gulaga)

 

What's the TV model number?

Link to comment
Share on other sites

SamES

W9 65”

 

OK, then this definitely should not be a problem.  Can you please provide the media info for a file you have issues with?  The media info from the bottom of the details page for the movie on the server will be fine.  Thanks

Edited by SamES
Link to comment
Share on other sites

Senorgreg

OK, then this definitely should not be a problem. Can you please provide the media info for a file you have issues with? The media info from the bottom of the details page for the movie on the server will be fine. Thanks

So, this is happening with live content from my HD HomeRun via Emby. Did you need the details of that live connection?

Link to comment
Share on other sites

SamES

So, this is happening with live content from my HD HomeRun via Emby. Did you need the details of that live connection?

 

Right, then these are probably captions, not subtitles which are different.  Can you make a recording of the channel for a few minutes, then report that info?

Link to comment
Share on other sites

dachouffe

I'm not shure, but i think i have the same problem.

I stream my live tv with tvheadend pass thru. Everything looks fine, but when i'm whatching live dutch tv, i get the dutch teletext subtitles.

Everything what has something to do with subtitle is disabled.

 

 

 

LG 50UM7600PLB 

webOS TV Version 4.7.1-50717 (goldilocks2-gulaga)

 

 

 

 

 

Link to comment
Share on other sites

dachouffe

try turning closed captions off in the tv settings (under accessibility)

 

Already tried that, because it was the most logical thing. Played with the emby subtitle setting, tried every combination i could think of. But with no result. The emby client turns on teletext subs when a ducht spoken program is on.

The problem only exist with my LG TV webOS, not with android, chromecast or a normal webbrowser. Even tried to remove the teletext steam with TVHeadend, but with no luck.

 

I'm stuck... :(

Link to comment
Share on other sites

dachouffe

Have you got forced subs turned on?

@@SamES On emby?

 

Nop, subs are turned of. Even tried choosing different subs, but nothing changed. the're always on... The signal is turned on, when a dutch spoken program on a dutch channel is activated. 

Link to comment
Share on other sites

SamES

If you make a recording of this channel, then play it back, do you have the same problem?  If so, can you please send me the file via PM?

Link to comment
Share on other sites

dachouffe

If you make a recording of this channel, then play it back, do you have the same problem?  If so, can you please send me the file via PM?

I will try this. I will come back as soon as possible with file..

 

Thanks..

Link to comment
Share on other sites

dachouffe

I will try this. I will come back as soon as possible with file..

 

Thanks..

Some problems recording with Emby. Will try to test when i resolve this.. :)

Link to comment
Share on other sites

SamES

Some problems recording with Emby. Will try to test when i resolve this.. :)

 

Can you please send me a PM with a link to this recording that I can download and test (Dropbox, OneDrive, etc)

Link to comment
Share on other sites

dachouffe

Can you please send me a PM with a link to this recording that I can download and test (Dropbox, OneDrive, etc)

That's the problem on this moment. I can't record with emby. I try to figure out why, but i don't know. As soon as I fix this, I will make the recording available to you.

 

Sorry for the delay....

  • Like 1
Link to comment
Share on other sites

  • 3 months later...
Slennox

Hi,

Any updates on this issue? Any workaround we could test?

When playing any Live TV channel whose stream includes subtitles, they are always shown by the LG Web player and can't be disabled. No matter what configuration you select on client or server side.

LG Smart TV (55EG920V-ZA)
webOS TV 2.2.3-1353 (beehive-biscayne)
Emby Theater 1.0.24
Emby Server Versión 4.5.0.13 beta

 

Thank you.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...