Jump to content
Marci32

Subtitles can not be turned off

Recommended Posts

Marci32

Hi guys,

 

I can't turn off subtitles in the Emby App. It says "No subtitles" in the settings and I can select "Off" in the Subtitles while playing a movie but subtitles will not disappear. I tried to reinstall the app (1.09), didn't help.

 

If I stream the same movie from the Web App to the same TV, then I can turn off subtitles in the TV settings (maybe I could say WebOS based settings) but I would like to use the app on the TV only.

 

Do you have any idea?

 

Thanks,

Marci

Share this post


Link to post
Share on other sites
Luke

Hi, what model TV?

Share this post


Link to post
Share on other sites
Luke

Is that WebOS3?

Share this post


Link to post
Share on other sites
Marci32

No, it is webOS 2.0. Isn't it supported maybe?  :(

Share this post


Link to post
Share on other sites
Luke

It's a known issue we are investigating for WebOS 2.0. They are turned off in the Emby app, but the TV is enabling them in a way we can't currently control. We are looking into it. Thanks.

Share this post


Link to post
Share on other sites
Marci32

Thank you, Luke! I am new here, so if you think I could have found the known issues somewhere, please let me know, so I won't bother you next time in a similar situation.

Share this post


Link to post
Share on other sites
Luke

By searching the community, but it's no problem. Thanks.

Share this post


Link to post
Share on other sites
Alex1899

Hi

I got an LG 55LB670V-ZA, WebOS 1.4.0-2529 (afro-ashley), running Emby 4.1.1.0 and have the same issue..

Using P__X  there is no such problem, so I think it's not an LG issue... do you have any update? Thanks!

Share this post


Link to post
Share on other sites
Luke

It actually is an LG issue, that other app you mention has added a workaround to force transcoding to remove subtitles. We have added the same for the next release of our app. Thanks.

Share this post


Link to post
Share on other sites
zyfinity

Hi, my friend is getting this exact issue and he is on the "LG Smart TV (55UF770V-TA)" it seems for him that srt subs can be disabled but other subs such as "subrip" won't go away even if disabled is selected, he even tried going into playback settings and going on the don't show subtitles but they end up playing anyway, he is also on the latest version of emby for lgtv.

Share this post


Link to post
Share on other sites
Luke

Hi, yes the problem is that on Web OS 1.X and Web OS 2.X, the LG video player will always show embedded subtitles even when we tell it not to, so we're going to have to implement a special workaround in the server to convert it and strip the subtitles out on the fly.

Share this post


Link to post
Share on other sites
zyfinity

Yes please that would be great!

Share this post


Link to post
Share on other sites
Allex

@@SamES

I have same issue with Live Tv in webos 4.0 subtitles always showing

Share this post


Link to post
Share on other sites
Joker

#METOO (WebOS 1). Looking forward to a future fix. We're using a FireTV box as a workaround for now.

Thanks for all the continued work Luke and co.

Share this post


Link to post
Share on other sites
SamES

@@SamES

I have same issue with Live Tv in webos 4.0 subtitles always showing

 

 Can you please check that closed captions are turned off in your TV settings?

 

Depending on your model, the instructions are roughly the same as this:

 

- Press the “Home” button.

- Select the gear icon in the top-right corner of the screen. It will take you to the TV settings.

- Choose the “Accessibility” section. It’s in the bottom-left corner.

- From here, enter the “Closed Captions” option.

- In the closed captions settings, besides turning them off or on, you can choose between analog and digital mode, and you can also change some digital mode options.

 

CC.png?w=250&ssl=1

Share this post


Link to post
Share on other sites
zyfinity

I tried this and still didn't work, seems like emby will have to strip the subtitles so it can direct stream the content and hopefully emby devs work on it ASAP.

Share this post


Link to post
Share on other sites
SamES

I tried this and still didn't work, seems like emby will have to strip the subtitles so it can direct stream the content and hopefully emby devs work on it ASAP.

Is this direct streaming or transcoding? Can you please post any remux or transcode logs for some examples. Thanks

Share this post


Link to post
Share on other sites
zyfinity

Its direct play, Luke has notified the issue and it's to do with webos 1.0 and 2.0 TVs automatically playing the subs embedded in movie/TV files and it seems like and issue with Plex aswell, it seems the only way to fix this is to have emby extract the embed sub file and send only the video / audio to the tv through direct streaming.

Share this post


Link to post
Share on other sites
SamES

Its direct play, Luke has notified the issue and it's to do with webos 1.0 and 2.0 TVs automatically playing the subs embedded in movie/TV files and it seems like and issue with Plex aswell, it seems the only way to fix this is to have emby extract the embed sub file and send only the video / audio to the tv through direct streaming.

Sure. My comment re closed captions in settings was specifically for @@Allex ’s issue in webos 4.0

Edited by SamES

Share this post


Link to post
Share on other sites
SamES

Its direct play, Luke has notified the issue and it's to do with webos 1.0 and 2.0 TVs automatically playing the subs embedded in movie/TV files and it seems like and issue with Plex aswell, it seems the only way to fix this is to have emby extract the embed sub file and send only the video / audio to the tv through direct streaming.

 

 

@@zyfinity, can you please confirm for me, and apologies if you have already previously provided this info, do you only see this issue with mkv files, or do you have examples with other formats (ie: mp4)?  

Share this post


Link to post
Share on other sites
musictalks

I have the same problem.

OLED55C9PTA webos 4.5

Share this post


Link to post
Share on other sites
SamES

 

I have the same problem.

OLED55C9PTA webos 4.5

 

 

You shouldn't be experiencing this issue on webos 4.5.  Please make sure you have closed captions turned off in the TV Accessibility Settings.  Let me know if that does not resolve it for you.

Share this post


Link to post
Share on other sites
musictalks

I have toggled the CC setting. That does stop it for a few second before the subtitles reactivate.

This is with live TV.

Sometimes when I activate CC, the screen goes black. Then I turn it off, and the screen returns to the show, but subtitles remain.

Stats for nerds shows that direct play is being used.

Cheers

Edited by musictalks

Share this post


Link to post
Share on other sites
SamES

I have toggled the CC setting. That does stop it for a few second before the subtitles reactivate.

This is with live TV.

Sometimes when I activate CC, the screen goes black. Then I turn it off, and the screen returns to the show, but subtitles remain.

Stats for nerds shows that direct play is being used.

Cheers

 

Can you please drop the quality setting during live playback until it's low enough to start transcoding, then attach a copy of the transcode log from the server.  I'm interested to see what type of subtitles are in the stream.  Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...