Jump to content


Photo

Subtitles can not be turned off

subtitle lg app

  • Please log in to reply
29 replies to this topic

#21 SamES OFFLINE  

SamES

    Advanced Member

  • Members
  • 1103 posts
  • Local time: 02:16 PM

Posted 18 November 2019 - 01:08 PM

Its direct play, Luke has notified the issue and it's to do with webos 1.0 and 2.0 TVs automatically playing the subs embedded in movie/TV files and it seems like and issue with Plex aswell, it seems the only way to fix this is to have emby extract the embed sub file and send only the video / audio to the tv through direct streaming.

 

 

@zyfinity, can you please confirm for me, and apologies if you have already previously provided this info, do you only see this issue with mkv files, or do you have examples with other formats (ie: mp4)?  



#22 musictalks OFFLINE  

musictalks

    Member

  • Members
  • 12 posts
  • Local time: 01:16 PM

Posted 01 December 2019 - 03:37 AM

I have the same problem.

OLED55C9PTA webos 4.5

#23 SamES OFFLINE  

SamES

    Advanced Member

  • Members
  • 1103 posts
  • Local time: 02:16 PM

Posted 01 December 2019 - 04:12 AM

 

I have the same problem.

OLED55C9PTA webos 4.5

 

 

You shouldn't be experiencing this issue on webos 4.5.  Please make sure you have closed captions turned off in the TV Accessibility Settings.  Let me know if that does not resolve it for you.



#24 musictalks OFFLINE  

musictalks

    Member

  • Members
  • 12 posts
  • Local time: 01:16 PM

Posted 01 December 2019 - 09:33 AM

I have toggled the CC setting. That does stop it for a few second before the subtitles reactivate.

This is with live TV.

Sometimes when I activate CC, the screen goes black. Then I turn it off, and the screen returns to the show, but subtitles remain.

Stats for nerds shows that direct play is being used.

Cheers


Edited by musictalks, 01 December 2019 - 10:01 AM.


#25 SamES OFFLINE  

SamES

    Advanced Member

  • Members
  • 1103 posts
  • Local time: 02:16 PM

Posted 01 December 2019 - 04:32 PM

I have toggled the CC setting. That does stop it for a few second before the subtitles reactivate.

This is with live TV.

Sometimes when I activate CC, the screen goes black. Then I turn it off, and the screen returns to the show, but subtitles remain.

Stats for nerds shows that direct play is being used.

Cheers

 

Can you please drop the quality setting during live playback until it's low enough to start transcoding, then attach a copy of the transcode log from the server.  I'm interested to see what type of subtitles are in the stream.  Thanks



#26 musictalks OFFLINE  

musictalks

    Member

  • Members
  • 12 posts
  • Local time: 01:16 PM

Posted 01 December 2019 - 04:47 PM

Hi.

Here is the transcode log.

 
 


#27 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146048 posts
  • Local time: 10:16 PM

Posted 01 December 2019 - 04:49 PM

 

Hi.

Here is the transcode log.

 

 

 

This is a live stream you're playing? Emby Server isn't even aware of any subtitles for this video, which means they're likely burnt into the original video.



#28 musictalks OFFLINE  

musictalks

    Member

  • Members
  • 12 posts
  • Local time: 01:16 PM

Posted 01 December 2019 - 05:24 PM

This is live TV. (morning show HD).

 

If the subs were burnt in, wouldn't the LGTV display them without Emby app?

The LG is not displaying subs (setting on LG=Off)

LG subs displaying (setting-On)

Emby is displaying subs. (Emby CC=English or CC=Off)



#29 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146048 posts
  • Local time: 10:16 PM

Posted 01 December 2019 - 05:56 PM

This is live TV. (morning show HD).

 

If the subs were burnt in, wouldn't the LGTV display them without Emby app?

The LG is not displaying subs (setting on LG=Off)

LG subs displaying (setting-On)

Emby is displaying subs. (Emby CC=English or CC=Off)

 

I think I was looking at the wrong log, sorry. So yes it does show dvb_teletext. That's a strange one since we are dropping it from the transcoded output.



#30 SamES OFFLINE  

SamES

    Advanced Member

  • Members
  • 1103 posts
  • Local time: 02:16 PM

Posted 01 December 2019 - 06:00 PM

I think I was looking at the wrong log, sorry. So yes it does show dvb_teletext. That's a strange one since we are dropping it from the transcoded output.


The issue is the dvb_teletext appears to be always on when direct playing. Normally turning off closed captions in the tv accessibility menu should disable these, but for some reason it’s not.





Also tagged with one or more of these keywords: subtitle, lg, app

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users