Jump to content

Emby Server for Western Digital NAS


Recommended Posts

tafelpoowt

The mksapkg tool calls openssl to create a hash from the app name in apkg.sign.

The firmware then validates this apkg.sign file that should decode to the app name.

 

If the build env has openssl v1.1.x+, the default hash type is sha256... but the wd firmware has openssl 1.0.x which uses default hash type md5.

 

Unfortunately there's no option for mksapkg to enforce md5, it just uses the openssl default.

Link to post
Share on other sites

Many thanks for your har work,

 

i installed your Version ...10. It worked still fine and now i'm awating an update of it or the official Version.

 

thx bkh

Link to post
Share on other sites
Françoise

Hi,

I have added a folder to a server running on a PR2100.

 

The items appear in the metadata manager, but only a few of them show up in the Media view.

 

I have tried several times and several different paths - it is the same three items that show up every time.

Link to post
Share on other sites

Upgraded from tafelpoowt: pkg:(WDMyCloudDL4100_emby-server_3.4.1.10.bin)  to: latest: emby-server-western_digital_pr4100_3.4.1.22_x86_64.bin

 

**update worked perfectly.

 

All previous installations failed for me ();  tafelpoowt .10 pkg install worked perfectly and the update to the latest also worked perfectly.

I was a little nervous; but all is working just well... perfectly.   no errors in log files besides DLNA but I have it disabled so.. no issues for me.

 

special thanks to tafelpoowt, kudos to everybody on the forum and ofcourse the developers recent attention on WD NAS.

 

Note; I was a Plex fan, but currently moving everything over to Emby.  

 

Do have one question; How are you all configured for Hardware decoding??

Nice Work!

 

Logs --snip--

2018-06-27 13:04:10.132 Info MediaEncoder: Running /mnt/HD/HD_a2/Nas_Prog/emby-server/bin/ffmpeg -decoders
2018-06-27 13:04:10.378 Info MediaEncoder: Decoder available: mpeg2video
2018-06-27 13:04:10.383 Info MediaEncoder: Decoder available: h264_cuvid
2018-06-27 13:04:10.383 Info MediaEncoder: Decoder available: hevc_cuvid
2018-06-27 13:04:10.383 Info MediaEncoder: Decoder available: mpeg2_cuvid
2018-06-27 13:04:10.383 Info MediaEncoder: Decoder available: mpeg4_cuvid
2018-06-27 13:04:10.384 Info MediaEncoder: Decoder available: vc1_cuvid
2018-06-27 13:04:10.384 Info MediaEncoder: Decoder available: vp8_cuvid
2018-06-27 13:04:10.385 Info MediaEncoder: Decoder available: vp9_cuvid
2018-06-27 13:04:10.392 Info MediaEncoder: Decoder available: ac3
2018-06-27 13:04:10.393 Info MediaEncoder: Decoder available: aac
2018-06-27 13:04:10.394 Info MediaEncoder: Decoder available: mp3
2018-06-27 13:04:10.394 Info MediaEncoder: Decoder available: h264
2018-06-27 13:04:10.394 Info MediaEncoder: Decoder available: hevc
2018-06-27 13:04:10.404 Info MediaEncoder: Running /mnt/HD/HD_a2/Nas_Prog/emby-server/bin/ffmpeg -encoders
2018-06-27 13:04:10.873 Info MediaEncoder: Encoder available: libx264
2018-06-27 13:04:10.873 Info MediaEncoder: Encoder available: mpeg4
2018-06-27 13:04:10.873 Info MediaEncoder: Encoder available: msmpeg4
2018-06-27 13:04:10.875 Info MediaEncoder: Encoder available: aac
2018-06-27 13:04:10.875 Info MediaEncoder: Encoder available: libmp3lame
2018-06-27 13:04:10.875 Info MediaEncoder: Encoder available: libopus
2018-06-27 13:04:10.876 Info MediaEncoder: Encoder available: libvorbis
2018-06-27 13:04:10.876 Info MediaEncoder: Encoder available: srt
2018-06-27 13:04:10.876 Info MediaEncoder: Encoder available: h264_nvenc
2018-06-27 13:04:10.876 Info MediaEncoder: Encoder available: hevc_nvenc
2018-06-27 13:04:10.879 Info MediaEncoder: Encoder available: h264_vaapi
2018-06-27 13:04:10.879 Info MediaEncoder: Encoder available: hevc_vaapi
2018-06-27 13:04:10.879 Info MediaEncoder: Encoder available: h264_v4l2m2m
2018-06-27 13:04:10.880 Info MediaEncoder: Encoder available: libwebp
2018-06-27 13:04:10.880 Info MediaEncoder: Encoder available: ac3

Link to post
Share on other sites
Françoise

Can you tell us what you added, what you see, and what you expected to see? Thanks.

Sorry about that. It turns out that it did eventually progress. There just wasn't any progress for a very long time.

Link to post
Share on other sites

I've updated the packages for the dl2100, dl4100 and pr2100. This incorporates @@tafelpoowt openssl fixes and should now allow you to install it from scratch. Please try it out. Thanks !

Link to post
Share on other sites

I've updated the packages for the dl2100, dl4100 and pr2100. This incorporates @@tafelpoowt openssl fixes and should now allow you to install it from scratch. Please try it out. Thanks !

I just tried to install on my PR4100 and it failed with the same message. I had deployed it with the work around previously. Is there anything I should have done except for uninstall?

Link to post
Share on other sites
Robert X. Gonzalez

I have the WD PR2100 My Cloud Pro Series NAS.  When I attempt to instgall the WD pr2100 - BETA I get an installation failure:

 

"Failed to install app." 

 

I am using the "install an app manually"

 

This is the only way I know to install an app unless there is a different process for EMBY.  Please advise.  thanks!

 

Link to post
Share on other sites
Robert X. Gonzalez

Luke,

Yes, all it says.  The version is the most current version on your website, just tried about 45 minutes ago; 3.4.1.24_x86_64.bin.  I just put it into service a couple days ago and works great but unable to install Emby.

Link to post
Share on other sites

PR4100: I had stability issues with .23 reverted back to .22.   Not really certain if it was related to adding music and books library; but removed these as well after downgrade..   not certain if related.

Note: Music Album art work never got downloaded and when I did try one song I got nothing but high pitched distorted noise,,, promptly deleted music media library from emby.

Link to post
Share on other sites
Robert X. Gonzalez

Luke,

Any idea?  The PR2100 is brand new, about a week in service with the latest firmware. 

Link to post
Share on other sites

Luke,

Any idea?  The PR2100 is brand new, about a week in service with the latest firmware. 

I had (have) the same problem as you.

 

The app fails to install on my PR2100 which was brand new.

 

I can install the 3.4.1.10 version which was modified (see previous posts) but then I can't access the configuration because the HTTP redirects fail, it doesnt matter which URL I try to go to on it.

 

It doesnt matter which version I try to upgrade to either (I can upgrade without installation failures), but the problem persists.

 

I've given up and am sticking with Plex for the moment until things improve.

Link to post
Share on other sites
  • 2 weeks later...
explor202

Hi, I'm just starting to try out Emby too. Have the Windows version running now, but would like to run it off my WD NAS instead. Will any of these versions work on the EX4100?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...