Jump to content

Emby Server for Western Digital NAS


Recommended Posts

tafelpoowt

@@nyplayer the configure button is a hardcoded webpage redirecting you to port 8096.

Changing the port in the app only applies to the app itself (and its config file).

 

If the config file is readable externally, the port could be fetched during start.sh to patch the redirect url.

Otherwise, do it manually over SSH.

Edited by tafelpoowt
Link to post
Share on other sites
nyplayer

@@nyplayer the configure button is a hardcoded webpage redirecting you to port 8096.

Changing the port in the app only applies to the app itself (and its config file).

 

If the config file is readable externally, the port could be fetched during init.sh to patch the redirect url.

Otherwise, do it manually over SSH.

 

I see I changed it from my Windows pc the ports and it is working fine … I will see how to change the Configure button later on..... I had to change the port in order to allow outside access on my router because I already have my main EMBY Server running on port 8096 until I feel comfortable with the WD Emby and switch over.

 

5b15ba0c92158_Capture.png

Edited by nyplayer
Link to post
Share on other sites
nyplayer

If you want to change the port of a service on the WD OS3 platform, you have to edit the scripts in /shares/Volume_1/Nas_Prog/emby-server via SSH.

In this case, modify the redirect URL in /shares/Volume_1/Nas_Prog/emby-server/web/index.html

 

The same applies to any WD app.

 

Thanks that worked. I am a Linux novice so appreciate everyone's help.

Link to post
Share on other sites

Any help? Runs great so far on my PR2100 but I have one small issue, the anime plugin refuses to get any metadata, only things like TVDB works

Link to post
Share on other sites
Luke

Any help? Runs great so far on my PR2100 but I have one small issue, the anime plugin refuses to get any metadata, only things like TVDB works

 

Thanks for the feedback. Best thing to do about the anime plugin is see how to report a problem. thanks !

Link to post
Share on other sites
Luke

Ok guys, going forward you can get new packages from the download page of our website. Your server dashboard will alert you when an update is available.

 

You're currently on the beta server. If you'd like to switch to the stable channel, you'll have an opportunity to do that after the next stable release. Thanks.

Link to post
Share on other sites
Luke

There's a regression in the latest beta related to downloading data from external sites that we are looking into. Thanks.

Link to post
Share on other sites
nyplayer

There's a regression in the latest beta related to downloading data from external sites that we are looking into. Thanks.

 

No Problem let us know when you have a new build.

Link to post
Share on other sites
Luke

Can you try re-downloading the same beta again, and then attach the emby server log? thanks.

Link to post
Share on other sites
nyplayer

Can you try re-downloading the same beta again, and then attach the emby server log? thanks.

 

I am getting guide data now.

Log.zip

Edited by nyplayer
Link to post
Share on other sites
cwebster

Just tried to install emby-server-western_digital_dl4100_3.4.1.13_x86_64.bin on my DL 4100, but it came back saying, "Failed to install app."

Link to post
Share on other sites
cwebster

I actually tried that version (...12) first. First attempt hung for about 3 minutes and timed out with no errors or messages. Then tried (...13) and it failed in about 10 seconds with error.

 

Just rebooted the DL4100 and tried again, but get the "Failed to install app". The web interface (Firefox) says, "Sending request to (ip)" and then "Waiting for (ip)" and then fails.

Link to post
Share on other sites
cwebster

If there is anything I can do to help make this work, I'm game.

 

'Been setting up Plex for the last week, but really wanted Emby.

Link to post
Share on other sites
nyplayer

Something must be wrong with the package for DL2100 also as I tried it on my DL2100 and it failed.... it is not moving it from the _install folder.

 

root@WDMyCloudDL2100 root #  cd /mnt/HD/HD_a2/Nas_Prog
root@WDMyCloudDL2100 Nas_Prog # ls
_docker    _install   _wdappmgr
root@WDMyCloudDL2100 Nas_Prog # cd _install
root@WDMyCloudDL2100 _install # ls
emby-server    module.tar.gz
root@WDMyCloudDL2100 _install #
 

Edited by nyplayer
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...