Jump to content

Emby Server for Western Digital NAS


Recommended Posts

@@Luke

Here is the same sqlite error on my x64 based My Cloud device.

 

https://transfer.sh/12vWiA/sqlitefail.log

 

Is this post (claiming mono 4.8.1 is latest support mono, not the 5.8 I'm running here) still valid?

https://emby.media/community/index.php?/topic/53967-library-scan-failed-sqlitepclprettysqliteexception/

 

EDIT: I did a few more tests...

 

The Emby 3.6.0 beta mono release seems to work after making these changes:

# only /lib/libsqlite3.so.0 exists, not /lib/libsqlite3.so
ln -sf /usr/local/modules/lib/libsqlite3.so /lib/libsqlite3.so

# borrow ffmpeg from the system (actually this is an old avconv v0.8.13)
ln -sf /usr/local/bin/ffmpeg /usr/local/modules/twonky/cgi-bin/ffmpeg_wrapper

# temporary workaround:
# install my duplicati app via the wd web interface to get mono 5.8
# then create symlinks for ease of use
ln -sf /shares/Volume_1/Nas_Prog/mono/bin/* /usr/local/bin/
mono --version

# setup Emby
cd /shares/Volume_1/Nas_Prog
mkdir -p emby/system && cd emby/system
wget https://github.com/MediaBrowser/Emby.Releases/releases/download/3.6.0.2/embyserver-mono_3.6.0.2.zip
unzip emby*

# start Emby
mono MediaBrowser.Server.Mono.exe

Not tested on My Cloud EX2 ultra yet, but it should work fine.

Edited by tafelpoowt
Link to post
Share on other sites

That's no longer the case. You will need 5.8+. 

 

Also the version of sqlite is ancient - 3.7.17, and doesn't support features the app is trying to use. It really should be bundled inside the package so that we can ship the latest version.

Link to post
Share on other sites

Luke buen día tengo el wd Pr 4100 esta actualizado a la última versión de emby y no puedo transmitir fuera de mi red nada más puedo verlo dentro de mi red local ya cambie el módem de la empresa de Internet y sigue igual todo esta actualizado a la última versión me podrías dar un consejo gracias

Edited by Pablo3559
Link to post
Share on other sites

Luke buen día tengo el wd Pr 4100 esta actualizado a la última versión de emby y no puedo transmitir fuera de mi red nada más puedo verlo dentro de mi red local ya cambie el módem de la empresa de Internet y sigue igual todo esta actualizado a la última versión me podrías dar un consejo gracias

Hola, sugeriría revisar nuestro Solucionador de problemas de conexión:
Por favor, siga los pasos que se enumeran allí y háganos saber cuáles son exitosos y cuáles no. Gracias !
Link to post
Share on other sites

I have crappy internet in this area.... my upstreaming is limited to 1.5mbps.

I thought there was somewhere I could configure this on the server. At one time I thought it was in the DNLA area.

 

Basically, I remotely start to stream a movie and it transcodes to 10 mbps so gets very jerky and buffers.

I must stop the movie change it to 1.5 mbps at which point it transcodes again but now plays normally.

 

I would rather just tell it up front  transcode to the lower speed.

Link to post
Share on other sites

I have crappy internet in this area.... my upstreaming is limited to 1.5mbps.

I thought there was somewhere I could configure this on the server. At one time I thought it was in the DNLA area.

 

Basically, I remotely start to stream a movie and it transcodes to 10 mbps so gets very jerky and buffers.

I must stop the movie change it to 1.5 mbps at which point it transcodes again but now plays normally.

 

I would rather just tell it up front  transcode to the lower speed.

 

Have you explored the Advanced server settings?

Link to post
Share on other sites
  • 2 weeks later...
  • 3 weeks later...
  • 2 weeks later...

Hello, desperate to try emby. I have a NAS WD ex2ultra and I am not very technical. My situation is that plex simply does not work for me and am looking for something that does. My router is also twined with a Google wifi mesh system and I cannot get remote access at all and hoping this is a better system. I have just read someone here has done an install of a NAS emby app on the ex2 but can you tell me which one as at the moment there is no specific install for that NAS model? thanks guys

Link to post
Share on other sites

Hello, desperate to try emby. I have a NAS WD ex2ultra and I am not very technical. My situation is that plex simply does not work for me and am looking for something that does. My router is also twined with a Google wifi mesh system and I cannot get remote access at all and hoping this is a better system. I have just read someone here has done an install of a NAS emby app on the ex2 but can you tell me which one as at the moment there is no specific install for that NAS model? thanks guys

https://emby.media/community/index.php?/topic/70731-mono-version-of-emby-server/

Link to post
Share on other sites
  • 1 month later...
emby cloud

Yes you cannot write to them when I try and extract the subtitles it cannot write the output srt file... to the folder... even though I have the recordings going to a public folder it still creates them read only.

 

5b2013deae4e4_Capture.png

Link to post
Share on other sites

Is there an alpha or beta of Emby for Western Digital PR4100?  Coming from Plex and I stupidly just bought a license assuming there was one already.  (Yeah, I see the bold letters now, 'don't buy unless you already have it installed.)

Is there a current link anywhere?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...