Jump to content
PrincessClevage

Active video has small gap on side and bottom of screen

Recommended Posts

echoxxzz

Still happens on Electron 2.0.4. 

It also only seems to occur when you connect the PC to an HDCP capable display and only after waking the computer from sleep mode.

If I use a really old TV or a computer monitor everything works perfectly.

This seems to be a known problem with Microsoft Windows not resizing the display properly or having other issues after waking the PC when connected to an HDCP display.

 

I just picked up a new VIZIO 32" TV to replace the old LG LCD bedroom TV (which has this problem) and everything works perfectly!!!!

Still have the problem on my Samsung 65" inch living room TV but I think this rules out my theory that it only occurs on displays with HDCP.

Share this post


Link to post
Share on other sites
stettler

I just picked up a new VIZIO 32" TV to replace the old LG LCD bedroom TV (which has this problem) and everything works perfectly!!!!

Still have the problem on my Samsung 65" inch living room TV but I think this rules out my theory that it only occurs on displays with HDCP.

 

 

There is really 2 problems that are somewhat linked:

 

Computer monitors have a chip that advertise the available resolutions and refresh to the computer. It's powered by the graphic card itself so it works even if the monitor is off.

 

Most TV don't have that chip so when they are off, the computer doesn't know what it is connected to and so revert to a "safe" resolution/refresh (ie: something that should be supported by nearly any device on the market).

 

That's why you have that problem with TV and not with computer monitors. Naturally, some TV have that chip so they don't that problem.

 

The other problem is that full screen windowed mode is not the same as exclusive full screen. When using full screen windowed mode (which is what ET is using when playing a video), sometime Windows mess-up things and display things in "nearly" full screen which is why you see that line on the right and bottom part of the screen (It's actually the frame of the window that wasn't removed as it should have been). It is still related to the change of state when you turn off your TV or when Windows want to display something else. Ie: It may happen even if your computer is configured to never go to sleep and never turn off the screen. It probably won't happen with a computer monitor even if you turn it off/on. Something like Windows notifications poping-up may be enough to go out of "full screen windowed" mode and end-up into a nearly full screen window when playing the video. (If you want, it's the difference between telling the OS to play the video at a resolution that take the full screen, whatever it is, or to play it at a resolution of 1920x1080)

Share this post


Link to post
Share on other sites
stettler

By the way, one way to mitigate the border problem is to change your desktop theme so that windows have a solid black border. It won't really fix the problem but you won't notice it anymore.

Share this post


Link to post
Share on other sites
echoxxzz

There is really 2 problems that are somewhat linked:

 

Computer monitors have a chip that advertise the available resolutions and refresh to the computer. It's powered by the graphic card itself so it works even if the monitor is off.

 

Most TV don't have that chip so when they are off, the computer doesn't know what it is connected to and so revert to a "safe" resolution/refresh (ie: something that should be supported by nearly any device on the market).

 

That's why you have that problem with TV and not with computer monitors. Naturally, some TV have that chip so they don't that problem.

 

The other problem is that full screen windowed mode is not the same as exclusive full screen. When using full screen windowed mode (which is what ET is using when playing a video), sometime Windows mess-up things and display things in "nearly" full screen which is why you see that line on the right and bottom part of the screen (It's actually the frame of the window that wasn't removed as it should have been). It is still related to the change of state when you turn off your TV or when Windows want to display something else. Ie: It may happen even if your computer is configured to never go to sleep and never turn off the screen. It probably won't happen with a computer monitor even if you turn it off/on. Something like Windows notifications poping-up may be enough to go out of "full screen windowed" mode and end-up into a nearly full screen window when playing the video. (If you want, it's the difference between telling the OS to play the video at a resolution that take the full screen, whatever it is, or to play it at a resolution of 1920x1080

 

But that doesn't explain why clicking the window/fullscreen button before I turn off the TV fixes the problem.

Even if Emby starts in fullscreen mode the problem exists until I click the button and change to window mode than back to fullscreen, then it never occurs again until I restart Emby.

 

Other apps like KODI don't have this problem.

Edited by echoxxzz

Share this post


Link to post
Share on other sites
PrincessClevage

There is really 2 problems that are somewhat linked:

 

Computer monitors have a chip that advertise the available resolutions and refresh to the computer. It's powered by the graphic card itself so it works even if the monitor is off.

 

Most TV don't have that chip so when they are off, the computer doesn't know what it is connected to and so revert to a "safe" resolution/refresh (ie: something that should be supported by nearly any device on the market).

 

That's why you have that problem with TV and not with computer monitors. Naturally, some TV have that chip so they don't that problem.

 

The other problem is that full screen windowed mode is not the same as exclusive full screen. When using full screen windowed mode (which is what ET is using when playing a video), sometime Windows mess-up things and display things in "nearly" full screen which is why you see that line on the right and bottom part of the screen (It's actually the frame of the window that wasn't removed as it should have been). It is still related to the change of state when you turn off your TV or when Windows want to display something else. Ie: It may happen even if your computer is configured to never go to sleep and never turn off the screen. It probably won't happen with a computer monitor even if you turn it off/on. Something like Windows notifications poping-up may be enough to go out of "full screen windowed" mode and end-up into a nearly full screen window when playing the video. (If you want, it's the difference between telling the OS to play the video at a resolution that take the full screen, whatever it is, or to play it at a resolution of 1920x1080)

On my system this was never an issue until the date that I started this thread and I believe there was an update. Also your thesis does not explain why we all see the line only on the right and bottom of our screens Edited by PrincessClevage

Share this post


Link to post
Share on other sites
stettler

On my system this was never an issue until the date that I started this thread and I believe there was an update. Also your thesis does not explain why we all see the line only on the right and bottom of our screens

 

I have that problem with ET 2.8.8 on Win7. It's a version of ET from last year.

 

As for why the border is only on the right and bottom, it's an OS bug, not a feature. Windows shouldn't display those lines at all. If it was the result of a single factor, it would have been fixed long ago. The problem doesn't (can't) happen with exclusive mode. In windowed mode there is some work-around but it still the result of an OS bug and not of the software so don't expect consistant result.

Share this post


Link to post
Share on other sites
stettler

 

 

Other apps like KODI don't have this problem.

 

 

Seems a tad difficult to compare two softwares that have nothing to do with each others. Is Kodi even using mpv?

I am sure that if you use ET with MadVR, you can avoid this problem with the correct setting. Not because mpv has a bug that MadVR doesn't. But because MadVR can use exclusive mode for example.

 

Perhaps what I am saying is totally stupid but I think that the ET interface isn't in the same window (layer?) as the movie played by mpv. Perhaps the window (layer) used to play the video isn't closed and re-opened in full size mode each time. Doing a minimize/maximize makes the problem go away as it put back the window into a real fullscreen and not in a window that just looks like it's taking the fullscreen.

 

You may think that ET is in fullscreen mode when it really isn't. It just looks like it is. It may also be the result of external factors: Some kind of OS or other software notification may make an application to go out of real fullscreen. Hidding/showing the taskbar may do it. If a window has a maximize button, it isn't in fullscreen even if it looks like it is.

Share this post


Link to post
Share on other sites
echoxxzz

Seems a tad difficult to compare two softwares that have nothing to do with each others. Is Kodi even using mpv?

I am sure that if you use ET with MadVR, you can avoid this problem with the correct setting. Not because mpv has a bug that MadVR doesn't. But because MadVR can use exclusive mode for example.

 

Perhaps what I am saying is totally stupid but I think that the ET interface isn't in the same window (layer?) as the movie played by mpv. Perhaps the window (layer) used to play the video isn't closed and re-opened in full size mode each time. Doing a minimize/maximize makes the problem go away as it put back the window into a real fullscreen and not in a window that just looks like it's taking the fullscreen.

 

You may think that ET is in fullscreen mode when it really isn't. It just looks like it is. It may also be the result of external factors: Some kind of OS or other software notification may make an application to go out of real fullscreen. Hidding/showing the taskbar may do it. If a window has a maximize button, it isn't in fullscreen even if it looks like it is.

 

Well no KODI is not using MPV but it does run at full screen and when you wake up the PC it doesn't have problems redrawing the screen.

Secondly, I don't think this is an MPV problem at all since the one temporary fix is to downgrade Electron from version 2.x  to a 1.x version.

Clearly, this is a problem with Electron 2.x since the other temporary fix is to just toggle the screen from window to full screen before putting your PC to sleep.

Share this post


Link to post
Share on other sites
snapwing

Does anyone happen to know the location in the registry to set the "dummy" screen resolution when the TV is off?

 

This seems like a promising work around in my case. This issue appeared for me at the same time as the OP. I leave my htpc on all the time, no standby, but now see the gaps after turning the TV back on.

 

Sent from my Pixel using Tapatalk

Share this post


Link to post
Share on other sites
echoxxzz

Does anyone happen to know the location in the registry to set the "dummy" screen resolution when the TV is off?

 

This seems like a promising work around in my case. This issue appeared for me at the same time as the OP. I leave my htpc on all the time, no standby, but now see the gaps after turning the TV back on.

 

Sent from my Pixel using Tapatalk

 

Goto HKLM\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration

 

Then you'll see a bunch of sub-keys.

One of those keys is for your existing monitor. It should be obvious.

One of the keys will have the text NOEDID in it, This is the default monitor key.

Open that key and replace the following values in the two 00 sub-keys from your actual monitor:

 

 

ActiveSize.cx

ActiveSize.cy

PrimSurfSize.cx

PrimSurfSize.cy

DwmClipBox.bottom

DwmClipBox.right

Stride

 

Reboot 

 

The existing values will be 400 (hex) and 300 (hex). Just remember to enter the news values as decimals as they default to hex.

Edited by echoxxzz
  • Like 2

Share this post


Link to post
Share on other sites
echoxxzz

.

Edited by echoxxzz

Share this post


Link to post
Share on other sites
AdrianW

I put back the older version of electron back (1.8.7) at the end of May. This prevents the gaps at the bottom and RHS.

 

BUT, I'm still occasionally getting the split-second audio drop outs - I watched two episodes of a show today and it must have dropped out 6 or 7 times. (I'm bitstreaming everything).

 

Is there a fix for this audio problem? Or do we have to wait for an electron version that no longer has the video gap issue?

Share this post


Link to post
Share on other sites
Guest asrequested

I put back the older version of electron back (1.8.7) at the end of May. This prevents the gaps at the bottom and RHS.

 

BUT, I'm still occasionally getting the split-second audio drop outs - I watched two episodes of a show today and it must have dropped out 6 or 7 times. (I'm bitstreaming everything).

 

Is there a fix for this audio problem? Or do we have to wait for an electron version that no longer has the video gap issue?

If you turn off bitstreaming and let MPV do the decoding, does the audio still drop out?

Share this post


Link to post
Share on other sites
stettler

Well no KODI is not using MPV but it does run at full screen and when you wake up the PC it doesn't have problems redrawing the screen.

Secondly, I don't think this is an MPV problem at all since the one temporary fix is to downgrade Electron from version 2.x  to a 1.x version.

Clearly, this is a problem with Electron 2.x since the other temporary fix is to just toggle the screen from window to full screen before putting your PC to sleep.

 

As I explained there is several different mode of "full screen". So you don't even know if Kodi is using the same one. Anyway, it's not Kodi, ET, or whatever that is redrawing the screen when waking-up the PC: It's the OS. Again, as I said, the bug is in the OS even if there is work around to avoid it.

 

As I wrote, at least under Windows 7, I have the problem with an old version of ET that I am pretty sure is using mpv with Electron 1.x. And I don't even put that PC to sleep.

 

How can you toggle from window to full screen before putting your PC to sleep? I would say that if it wasn't already in full screen then there is a problem...

Share this post


Link to post
Share on other sites
ShoutingMan

Yes. This is a bug related to newer Electron release. I’ve mnaually reverted to an earlier electron version as advised. Now I’m waiting for the problem to be fixed so I can return to standard ET installation.

Share this post


Link to post
Share on other sites
echoxxzz

As I explained there is several different mode of "full screen". So you don't even know if Kodi is using the same one. Anyway, it's not Kodi, ET, or whatever that is redrawing the screen when waking-up the PC: It's the OS. Again, as I said, the bug is in the OS even if there is work around to avoid it.

 

As I wrote, at least under Windows 7, I have the problem with an old version of ET that I am pretty sure is using mpv with Electron 1.x. And I don't even put that PC to sleep.

 

How can you toggle from window to full screen before putting your PC to sleep? I would say that if it wasn't already in full screen then there is a problem...

All I do is click the square box in the upper right corner twice. Once to put into window mode then again to put it back into fullscreen. After that whenever I put my PC to sleep and wake it up I never have any redraw issues in ET. 

 

I do agree you with that this is clearly a O/S problem because it doesn't seem to happen under Linux running emby-theater-electron.

Share this post


Link to post
Share on other sites
PrincessClevage

For the moment my rig no longer displays these symptoms. Some of the recent changes and observations are:

Got new 4K tv and tested at 3140x2160 and banding was still occurring

Uninstalled ET (selecting delete all configuration records)

Reinstalled ET from the website and although no installer popped up in the user interface I could see ET installer running in task manager and assumed it was downloading and let it run until ET autolaunched (took ages)

Setup my config (did not select change refresh rate to match video)

Now for the moment I have no visible banding but I’m guessing if I enable change refresh rate to match video the issue will reoccur again.

I have notice the odd random occurrence where video will just stop playing or freeze on one section but resume will pickup at the point video playback was interrupted.

I can only assume that these bugs are related to the application layer (most likely mpv or electron) as other these symptoms can not be reproduced in other media players playing the same content on the same system

Share this post


Link to post
Share on other sites
Luke

Is it possible to tell which of these situations is occurring: the video window width/height are slightly smaller than before. or it's the same size but is shifted up and to the left by a few pixels. If we know the answer to that, then maybe i can figure out a temporary hack.

Share this post


Link to post
Share on other sites
AdrianW

If you turn off bitstreaming and let MPV do the decoding, does the audio still drop out?

 

I was having problems with EAC3, when I de-selected audio-passthrough, I only got 3 channel PCM. I noticed that "Enable exclusive audio mode" was off, so I turned that on and re-selected EAC3. I played a 45 minute EAC3 episode and there were no dropouts - it may be coincidence, but we'll see over the next few days.

Share this post


Link to post
Share on other sites
Guest asrequested

I was having problems with EAC3, when I de-selected audio-passthrough, I only got 3 channel PCM. I noticed that "Enable exclusive audio mode" was off, so I turned that on and re-selected EAC3. I played a 45 minute EAC3 episode and there were no dropouts - it may be coincidence, but we'll see over the next few days.

That's odd. Can you start a new thread and post the MPV log?

Share this post


Link to post
Share on other sites
snapwing

Goto HKLM\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration

 

Then you'll see a bunch of sub-keys.

One of those keys is for your existing monitor. It should be obvious.

One of the keys will have the text NOEDID in it, This is the default monitor key.

Open that key and replace the following values in the two 00 sub-keys from your actual monitor:

 

 

ActiveSize.cx

ActiveSize.cy

PrimSurfSize.cx

PrimSurfSize.cy

DwmClipBox.bottom

DwmClipBox.right

Stride

 

Reboot

 

The existing values will be 400 (hex) and 300 (hex). Just remember to enter the news values as decimals as they default to hex.

Thanks a lot for this!

 

Sent from my Pixel using Tapatalk

Share this post


Link to post
Share on other sites
stettler

Is it possible to tell which of these situations is occurring: the video window width/height are slightly smaller than before. or it's the same size but is shifted up and to the left by a few pixels. If we know the answer to that, then maybe i can figure out a temporary hack.

 

 

If most window size problems can be solved by clicking on the maximize button, can't you force a maximize of the _ET_ window, programmatically, at one point or another? Just before starting playing a video for example? (and make sure that video is also played in a window that is maximized)

Share this post


Link to post
Share on other sites
daedalus

so every playback start will maximize the window ?

how would you decide if it's intentionally in window mode?

Edited by daedalus

Share this post


Link to post
Share on other sites
stettler

so every playback start will maximize the window ?

how would you decide if it's intentionally in window mode?

 

Isn't there/wasn't there an option to start ET in full screen? If that's the case, rename it into "run ET in full screen"... (or add a new option)

Share this post


Link to post
Share on other sites
daedalus

Isn't there/wasn't there an option to start ET in full screen? If that's the case, rename it into "run ET in full screen"... (or add a new option)

 

better finally find & fix the real problem

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...