Jump to content


Photo

Streaming settings seem to be ignored

streaming remote access buffering

  • Please log in to reply
3 replies to this topic

#1 onemoredave OFFLINE  

onemoredave

    Newbie

  • Members
  • 6 posts
  • Local time: 05:44 AM
  • LocationPerth, Australia

Posted 26 March 2014 - 04:46 AM

Hi MediaBrowser Community!

 

First post, but I've been using the mediabrowser standalone and apps pretty much since their release - I've been a long time Win MC user and  I'm loving the direction things are headed with MB (I'm almost ready to ditch MC entirely!)

 

The issue I'm having is::

When streaming media to the windows store app remotely via wifi or 3G, playback is stopped frequently with the buffering message.  This occurs on both a surface tablet and a Toshiba encore tablet.

 

I have the transcode quality settings in the app set to low however changing this setting does not seem to affect either the picture quality or the frequency of buffering delays.

 

Edit: The window 8.1 store app is the latest version as is the server is running the latest Version 3.0.5192.19560

 

Troubleshooting:

 

In order to test whether the settings were actually changing anything, I tried to play the same (low bitrate) file on the same device with the streaming settings to max and then on min..  Both resulted in an excellent picture quality but constant buffering. 

 

I have included both ffmpeg log files below marked max and min.

 

Incidentally, when I play the same file via the MB web client (chrome), I can dial down the quality and play the file without any buffering and noticeably poorer picture quality.

 

Am I missing a setting or something which is preventing the server from recognising the streaming quality flag from the app?

 

Thanks in advance,

Dave

 

Attached File  ffmpeg-Archer streaming set to min.txt   6.33KB   2 downloads Attached File  ffmpeg-Archer streaming set to max.txt   6.15KB   1 downloads


Edited by onemoredave, 26 March 2014 - 07:12 AM.


#2 7illusions OFFLINE  

7illusions

    Advanced Member

  • Developers
  • 2065 posts
  • Local time: 11:44 PM
  • LocationGothenburg, Sweden

Posted 26 March 2014 - 05:57 AM

Hi Dave and welcome!

 

Thanks for reporting this.

I just tested to lower the quality and, as you reported, it still went with the Copy option.

I was planning on doing a rewrite of the logic for this, but it just went from "planning" to "Doing" in a hurry. :)

Will have a fix out asap.


  • onemoredave likes this

#3 onemoredave OFFLINE  

onemoredave

    Newbie

  • Members
  • 6 posts
  • Local time: 05:44 AM
  • LocationPerth, Australia

Posted 26 March 2014 - 06:31 AM

Awesome, thanks for the quick reply.

 

Much appreciated!



#4 onemoredave OFFLINE  

onemoredave

    Newbie

  • Members
  • 6 posts
  • Local time: 05:44 AM
  • LocationPerth, Australia

Posted 02 April 2014 - 09:51 PM

Hi 7

 

Happy to report that this seems to be working really well now.  Nice work!

 

Dave


  • 7illusions likes this





Also tagged with one or more of these keywords: streaming, remote access, buffering

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users