Jump to content
s.zoli89

Raspberry PI 3 crashes (not transcoding-performance issue)

Recommended Posts

s.zoli89

i would love to use emby server, if it working properly...

I cant use Emby, because it crashing all the time. When i start a movie-after stop, then start other, the server is crashing.
I tried playing this movies whit Plex and worked, but i dont like Plex.

 

PLZ help me to use this awsome server!!

 

My system:

DietPi distribution on Raspberry pi 3,

Distributor ID: Raspbian
Description:    Raspbian GNU/Linux 9.4 (stretch)
Release:        9.4
Codename:       stretch

Emby Version: Version 3.3.1.0
ffmpeg version: 
ffmpeg version 3.2.10-1~deb9u1+rpt1
Mono runtime version: Mono JIT compiler version 5.10.1.20

I see this on ssh session terminal, when crash is coming:
 
Message from syslogd@DietPi-Kodi at Apr 17 11:31:28 ...
 kernel:[ 2226.036759] Internal error: Oops: 17 [#10] SMP ARM
 
Message from syslogd@DietPi-Kodi at Apr 17 11:31:28 ...
 kernel:[ 2226.107391] Process Threadpool work (pid: 7323, stack limit = 0xb5f72210)
 
Message from syslogd@DietPi-Kodi at Apr 17 11:31:28 ...
 kernel:[ 2226.111531] Stack: (0xb5f73d98 to 0xb5f74000)
 
Message from syslogd@DietPi-Kodi at Apr 17 11:31:28 ...
 kernel:[ 2226.115609] 3d80:                                                       00007f38 806d1600
 
Message from syslogd@DietPi-Kodi at Apr 17 11:31:28 ...
 kernel:[ 2226.119741] 3da0: 00082dcf b5f73ec0 b25757c0 00082dcf b5f73e54 b5f73dc0 806d1620 806ce01c
 
Message from syslogd@DietPi-Kodi at Apr 17 11:31:28 ...
 kernel:[ 2226.123787] 3dc0: 00007f38 801ed940 b3f06a6c b6fc814c 80c069c4 80d0a08c 80c049c0 b5f72000
 
Message from syslogd@DietPi-Kodi at Apr 17 11:31:28 ...
 kernel:[ 2226.127845] 3de0: 00000000 90a5e05c 00000001 00000000 00000001 00000000 00010000 00000000
 
Message from syslogd@DietPi-Kodi at Apr 17 11:31:28 ...
 kernel:[ 2226.131922] 3e00: 00000001 b2575910 0000054d 00000000 00000121 00007f38 7fffffff b5f73e28
 
Message from syslogd@DietPi-Kodi at Apr 17 11:31:28 ...
 kernel:[ 2226.135949] 3e20: 801235c4 801e0000 b25757c0 b25757c0 00202436 b5f73ec0 00000121 80108224
 
Message from syslogd@DietPi-Kodi at Apr 17 11:31:28 ...
 kernel:[ 2226.139882] 3e40: b5f72000 00000000 b5f73e74 b5f73e58 806d214c 806d1324 806d2114 b25757c0
 
Message from syslogd@DietPi-Kodi at Apr 17 11:31:28 ...
 kernel:[ 2226.143890] 3e60: 00000000 931c4fc0 b5f73e94 b5f73e78 806fe240 806d2120 802aa224 802aa178
 
Message from syslogd@DietPi-Kodi at Apr 17 11:31:28 ...
 kernel:[ 2226.147846] 3e80: 00000000 00000000 b5f73ea4 b5f73e98 80657950 806fe204 b5f73f8c b5f73ea8
 
Message from syslogd@DietPi-Kodi at Apr 17 11:31:28 ...
 kernel:[ 2226.151730] 3ea0: 80658aa0 80657938 b5f73ec8 80c82021 fffffff7 00000001 6de206f2 00202436
 
Message from syslogd@DietPi-Kodi at Apr 17 11:31:28 ...
 kernel:[ 2226.155590] 3ec0: 00000000 00000000 00000001 00082dcf 0017f667 b5f73eb8 00000001 801ee188
 
Message from syslogd@DietPi-Kodi at Apr 17 11:31:28 ...
 kernel:[ 2226.159462] 3ee0: 00000000 00000000 00000000 b5f73ef8 80101850 80123188 b5f73f00 b6802e00
 
Message from syslogd@DietPi-Kodi at Apr 17 11:31:28 ...
 kernel:[ 2226.163284] 3f00: 00000001 00400040 80c02d00 0002f04e 0000000a 80c918c0 80c823f0 80c03d68
 
Message from syslogd@DietPi-Kodi at Apr 17 11:31:28 ...
 kernel:[ 2226.167115] 3f20: 80b84378 80c02080 b5f73ef8 00000000 8017a470 80b8c92c 00000000 00000000
 
Message from syslogd@DietPi-Kodi at Apr 17 11:31:28 ...
 kernel:[ 2226.170902] 3f40: 00000001 b6804180 00202436 8012377c b5f73f6c b5f73f60 8012377c 80184560
 
Message from syslogd@DietPi-Kodi at Apr 17 11:31:28 ...
 kernel:[ 2226.174608] 3f60: b5f73f94 b5f73f70 801754d8 801236e0 b5f73fb0 76412d80 00000000 6de206f2
 
Message from syslogd@DietPi-Kodi at Apr 17 11:31:28 ...
 kernel:[ 2226.178380] 3f80: b5f73fa4 b5f73f90 80658af0 806589e4 00000000 00000000 00000000 b5f73fa8
 
Message from syslogd@DietPi-Kodi at Apr 17 11:31:28 ...
 kernel:[ 2226.182084] 3fa0: 80108080 80658ad4 76412d80 00000000 00000021 6de206f2 00202436 00000000
 
Message from syslogd@DietPi-Kodi at Apr 17 11:31:28 ...
 kernel:[ 2226.185758] 3fc0: 76412d80 00000000 6de206f2 00000121 00000000 01feac80 00380ee0 6f12a820
 
Message from syslogd@DietPi-Kodi at Apr 17 11:31:28 ...
 kernel:[ 2226.189398] 3fe0: 00000000 6f12a7a8 00000000 76e2b984 80000010 00000021 00000000 00000000
 
Message from syslogd@DietPi-Kodi at Apr 17 11:31:28 ...
 kernel:[ 2226.218091] Code: e155000c 03a05000 e2117902 1a000039 (e5d50028)


AND when i check emby status, after crash:
 
● emby-server.service - Emby Media Server
   Loaded: loaded (/lib/systemd/system/emby-server.service; disabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2018-04-17 11:29:23 CEST; 7s ago
  Process: 6922 ExecStopPost=/usr/bin/emby-server clear (code=exited, status=0/SUCCESS)
  Process: 6673 ExecStart=/usr/bin/emby-server start (code=exited, status=134)
 Main PID: 6673 (code=exited, status=134)
 
Apr 17 11:29:23 DietPi-Kodi emby-server[6673]: Native stacktrace:
Apr 17 11:29:23 DietPi-Kodi emby-server[6673]: Debug info from gdb:
Apr 17 11:29:23 DietPi-Kodi emby-server[6673]: mono_gdb_render_native_backtraces not supported on this platform, unable to find gdb or lldb
Apr 17 11:29:23 DietPi-Kodi emby-server[6673]: =================================================================
Apr 17 11:29:23 DietPi-Kodi emby-server[6673]: Got a SIGABRT while executing native code. This usually indicates
Apr 17 11:29:23 DietPi-Kodi emby-server[6673]: a fatal error in the mono runtime or one of the native libraries
Apr 17 11:29:23 DietPi-Kodi emby-server[6673]: used by your application.
Apr 17 11:29:23 DietPi-Kodi emby-server[6673]: =================================================================
Apr 17 11:29:23 DietPi-Kodi systemd[1]: emby-server.service: Unit entered failed state.
Apr 17 11:29:23 DietPi-Kodi systemd[1]: emby-server.service: Failed with result 'exit-code'.
 

THX!

ServerLog.txt

FFmpegLog.txt

reinstalled_ffmpegLog.txt

reinstalled_serverLog.txt

MorningServerLog_2018_04_18.txt

Edited by s.zoli89

Share this post


Link to post
Share on other sites
Luke

Hi, what you could do is try uninstalling and then reinstall using our newer installation package that is on our website. Please let us know if this helps. Thanks.

Share this post


Link to post
Share on other sites
s.zoli89

Hi, what you could do is try uninstalling and then reinstall using our newer installation package that is on our website. Please let us know if this helps. Thanks.

 

 

Thank you for reply! 

I tried reinstall with offical installation package, but i got same result. It most stable, but i can to cause crash.

I upload the server log to the first post...

 

How to restart Emby with this package? 

Edited by s.zoli89

Share this post


Link to post
Share on other sites
Luke

ffmpeg is exiting with status code 255. I haven't heard that one before so I'll try to research what that means, as these things are unfortunately poorly documented.

Share this post


Link to post
Share on other sites
s.zoli89

ffmpeg is exiting with status code 255. I haven't heard that one before so I'll try to research what that means, as these things are unfortunately poorly documented.

 

i think that cause my kill command.... after the emby crash, ffmpeg process was still worked

Share this post


Link to post
Share on other sites
Luke

Does the rest of the server appear to be operating normally?

Share this post


Link to post
Share on other sites
s.zoli89

It seems the rest of the server is working fine, but last night i got a new error (i not used server):
I upload new serverlog...

 

emby-server.service - Emby Server is a personal media server with apps on just about every device.
   Loaded: loaded (/usr/lib/systemd/system/emby-server.service; enabled; vendor preset: enabled)
   Active: failed (Result: signal) since Wed 2018-04-18 06:05:27 CEST; 4h 11min ago
  Process: 13729 ExecStart=/opt/emby-server/bin/emby-server (code=killed, signal=ABRT)
 Main PID: 13729 (code=killed, signal=ABRT)
 
Apr 17 22:52:47 DietPi-Kodi emby-server[13729]: Info App: Default journal_mode for /var/lib/emby/data/sync14.db is wal
Apr 17 22:52:47 DietPi-Kodi emby-server[13729]: Info App: PRAGMA synchronous=1
Apr 17 22:52:47 DietPi-Kodi emby-server[13729]: Info App: Entry point completed: Emby.Server.Sync.SyncManagerEntryPoint. Duration: 0.0800602 seconds
Apr 17 22:52:47 DietPi-Kodi emby-server[13729]: Info App: Starting entry point Emby.Server.Sync.SyncNotificationEntryPoint
Apr 17 22:52:47 DietPi-Kodi emby-server[13729]: Info App: Entry point completed: Emby.Server.Sync.SyncNotificationEntryPoint. Duration: 0.0054907 seconds
Apr 17 22:52:47 DietPi-Kodi emby-server[13729]: Info App: All entry points have started
Apr 18 06:05:27 DietPi-Kodi emby-server[13729]: *** Error in `/opt/emby-server/system/EmbyServer': double free or corruption (fasttop): 0x6e8b5f58 ***
Apr 18 06:05:27 DietPi-Kodi systemd[1]: emby-server.service: Main process exited, code=killed, status=6/ABRT
Apr 18 06:05:27 DietPi-Kodi systemd[1]: emby-server.service: Unit entered failed state.
Apr 18 06:05:27 DietPi-Kodi systemd[1]: emby-server.service: Failed with result 'signal'.


 
Edited by s.zoli89

Share this post


Link to post
Share on other sites
bokiroki

Hi, i have the same problem like op.. I installed emby yesterday on dietpi system on raspberry pi 3 trough dietpi-software menu
i saw in terminal before emby was installed, ffmpeg was installed first.. in transcode menu i put /usr/bin/ffmpeg because it didn't let me save transcode settings..
emby version is 3.3.1.0..mono version is 5.10.1.20
in some threads you posted that mono is the issue, in this thread you did't mentioned mono
I get this when i type ffmpeg -version

 
ffmpeg version git-2017-04-18-6108805 Copyright © 2000-2017 the FFmpeg developers
built with gcc 4.9.2 (Raspbian 4.9.2-10)
configuration: --prefix=/usr --enable-static --enable-gpl --enable-libx264 --enable-pthreads --enable-nonfree --enable-omx --enable-omx-rpi --enable-libfdk-aac --enable-libmp3lame
libavutil      55. 61.100 / 55. 61.100
libavcodec     57. 93.100 / 57. 93.100
libavformat    57. 72.101 / 57. 72.101
libavdevice    57.  7.100 / 57.  7.100
libavfilter     6. 84.101 /  6. 84.101
libswscale      4.  7.101 /  4.  7.101
libswresample   2.  8.100 /  2.  8.100
libpostproc    54.  6.100 / 54.  6.100
 
So when i start movie, and exit and start another i get spinning circle (in htop i don't see emby anymore), or when i start  movie and jump to another scene i get spinning circe also (emby is missing again in htop)
all movies i played were direct play or direct stream.. here are logs before crash and after
 

Log.txt

Log (1).txt

Share this post


Link to post
Share on other sites
s.zoli89

 

Hi, i have the same problem like op.. I installed emby yesterday on dietpi system on raspberry pi 3 trough dietpi-software menu

i saw in terminal before emby was installed, ffmpeg was installed first.. in transcode menu i put /usr/bin/ffmpeg because it didn't let me save transcode settings..

emby version is 3.3.1.0..mono version is 5.10.1.20

in some threads you posted that mono is the issue, in this thread you did't mentioned mono

I get this when i type ffmpeg -version

 
ffmpeg version git-2017-04-18-6108805 Copyright © 2000-2017 the FFmpeg developers
built with gcc 4.9.2 (Raspbian 4.9.2-10)
configuration: --prefix=/usr --enable-static --enable-gpl --enable-libx264 --enable-pthreads --enable-nonfree --enable-omx --enable-omx-rpi --enable-libfdk-aac --enable-libmp3lame
libavutil      55. 61.100 / 55. 61.100
libavcodec     57. 93.100 / 57. 93.100
libavformat    57. 72.101 / 57. 72.101
libavdevice    57.  7.100 / 57.  7.100
libavfilter     6. 84.101 /  6. 84.101
libswscale      4.  7.101 /  4.  7.101
libswresample   2.  8.100 /  2.  8.100
libpostproc    54.  6.100 / 54.  6.100
 
So when i start movie, and exit and start another i get spinning circle (in htop i don't see emby anymore), or when i start  movie and jump to another scene i get spinning circe also (emby is missing again in htop)

all movies i played were direct play or direct stream.. here are logs before crash and after

 

 

Hi,

dont use dietpi-software installer for install emby, because this is older installer package from dietpi server.....

Use instead official emby installer package from emby site.

 

https://emby.media/linux-server.html

 

Share this post


Link to post
Share on other sites
Luke

Yes that is very important, thanks !

Share this post


Link to post
Share on other sites
bokiroki

Thanks guys everything works well now..

Deleted emby and ffmpeg with dietpi uninstall option, and installed emby trough website..

 

How emby update itself? do i need to do something trough time, or it will update itself?

Edited by bokiroki

Share this post


Link to post
Share on other sites
Luke

You would just do the same process again on top of your existing install.

Share this post


Link to post
Share on other sites
s.zoli89

My Emby installation is also seems to be working a day ago.

Edited by s.zoli89

Share this post


Link to post
Share on other sites
Luke

Thanks for the feedback.

Share this post


Link to post
Share on other sites
tdiguy

A couple of things got my attention on this, first the emby version Version 3.3.1.0 that is the current stable emby version i believe. But then i also noticed these: Apr 17 11:29:23 DietPi-Kodi emby-server[6673]: Got a SIGABRT while executing native code. This usually indicates

Apr 17 11:29:23 DietPi-Kodi emby-server[6673]: a fatal error in the mono runtime or one of the native libraries
Apr 17 11:29:23 DietPi-Kodi emby-server[6673]: used by your application.

 

Which seems like an issue with mono and i will say from my own experience that mono can be a pita. I dont know why mono is on your system personally but after i uninstalled mono from my ubuntu system ( its not a pi either ) emby was much more stable. Unless you are using mono for something else it might be worth considering uninstalling mono.

Share this post


Link to post
Share on other sites
s.zoli89

A couple of things got my attention on this, first the emby version Version 3.3.1.0 that is the current stable emby version i believe. But then i also noticed these: Apr 17 11:29:23 DietPi-Kodi emby-server[6673]: Got a SIGABRT while executing native code. This usually indicates

Apr 17 11:29:23 DietPi-Kodi emby-server[6673]: a fatal error in the mono runtime or one of the native libraries

Apr 17 11:29:23 DietPi-Kodi emby-server[6673]: used by your application.

 

Which seems like an issue with mono and i will say from my own experience that mono can be a pita. I dont know why mono is on your system personally but after i uninstalled mono from my ubuntu system ( its not a pi either ) emby was much more stable. Unless you are using mono for something else it might be worth considering uninstalling mono.

 

Thank you. i will try uninstall mono; i dont use mono runtime. test it a few days and lets see what happens.

Still with installed mono-runtime, today morning the emby server is stopped. emby-service status is:

 

emby-server.service - Emby Server is a personal media server with apps on just about every device.

   Loaded: loaded (/usr/lib/systemd/system/emby-server.service; enabled; vendor preset: enabled)

   Active: failed (Result: signal) since Sat 2018-04-21 16:44:05 CEST; 16h ago

  Process: 12257 ExecStart=/opt/emby-server/bin/emby-server (code=killed, signal=SEGV)

 Main PID: 12257 (code=killed, signal=SEGV)

 

Apr 21 09:25:27 DietPi-Kodi emby-server[12257]: Info App: Sqlite compiler options: COMPILER=gcc-6.4.1 20170707,ENABLE_COLUMN_METADATA,ENABLE_DBSTAT_VTAB,ENABLE_FTS3,ENABLE_FTS3_PARENTHESIS,ENABLE_FTS3_TOKENIZER,ENABLE_FTS5,ENABLE_JSON1,ENABLE_PREUPDATE_HOOK,ENABLE_RTREE,ENABLE_SESSION,ENABLE_UNLOCK_NOTIFY,ENABLE_UP

DATE_DELETE_LIMIT,LIKE_DOESNT_MATCH_BLOBS,MAX_SCHEMA_RETRY=25,MAX_VARIABLE_NUMBER=250000,OMIT_LOOKASIDE,SECURE_DELETE,THREADSAFE=1

Apr 21 09:25:27 DietPi-Kodi emby-server[12257]: Info App: Default journal_mode for /var/lib/emby/data/sync14.db is wal

Apr 21 09:25:27 DietPi-Kodi emby-server[12257]: Info App: PRAGMA synchronous=1

Apr 21 09:25:27 DietPi-Kodi emby-server[12257]: Info App: Entry point completed: Emby.Server.Sync.SyncManagerEntryPoint. Duration: 0.0776036 seconds

Apr 21 09:25:27 DietPi-Kodi emby-server[12257]: Info App: Starting entry point Emby.Server.Sync.SyncNotificationEntryPoint

Apr 21 09:25:27 DietPi-Kodi emby-server[12257]: Info App: Entry point completed: Emby.Server.Sync.SyncNotificationEntryPoint. Duration: 0.0069298 seconds

Apr 21 09:25:27 DietPi-Kodi emby-server[12257]: Info App: All entry points have started

Apr 21 16:44:05 DietPi-Kodi systemd[1]: emby-server.service: Main process exited, code=killed, status=11/SEGV

Apr 21 16:44:05 DietPi-Kodi systemd[1]: emby-server.service: Unit entered failed state.

Apr 21 16:44:05 DietPi-Kodi systemd[1]: emby-server.service: Failed with result 'signal'.

Edited by s.zoli89

Share this post


Link to post
Share on other sites
Luke

Try uninstalling mono and then let's go from there, thanks.

Share this post


Link to post
Share on other sites
s.zoli89

Hi. The problem is still exist :(
Emby server status:
emby-server.service - Emby Server is a personal media server with apps on just about every device.

   Loaded: loaded (/usr/lib/systemd/system/emby-server.service; enabled; vendor preset: enabled)

   Active: failed (Result: signal) since Mon 2018-04-23 16:10:34 CEST; 5h 38min ago

  Process: 14133 ExecStart=/opt/emby-server/bin/emby-server (code=killed, signal=SEGV)

 Main PID: 14133 (code=killed, signal=SEGV)

 

Apr 22 21:39:10 DietPi-Kodi emby-server[14133]:     encoder         : libebml v1.3.1 + libmatroska v1.4.2

Apr 22 21:39:10 DietPi-Kodi emby-server[14133]:     creation_time   : 2016-09-30T10:39:02.000000Z

Apr 22 21:39:10 DietPi-Kodi emby-server[14133]:   Duration: 00:48:18.58, start: 0.000000, bitrate: 641 kb/s

Apr 22 21:39:10 DietPi-Kodi emby-server[14133]:     Stream #0:0: Video: h264 (High), yuv420p(tv, bt709/unknown/unknown, progressi

ve), 720x404 [sAR 1:1 DAR 180:101], 23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc (default)

Apr 22 21:39:10 DietPi-Kodi emby-server[14133]:     Stream #0:1(hun): Audio: aac (LC), 48000 Hz, stereo, fltp (default)

Apr 22 21:39:10 DietPi-Kodi emby-server[14133]:     Stream #0:2(hun): Subtitle: subrip

Apr 22 21:39:10 DietPi-Kodi emby-server[14133]:     Stream #0:3(eng): Subtitle: subrip

Apr 23 16:10:34 DietPi-Kodi systemd[1]: emby-server.service: Main process exited, code=killed, status=11/SEGV

Apr 23 16:10:34 DietPi-Kodi systemd[1]: emby-server.service: Unit entered failed state.

Apr 23 16:10:34 DietPi-Kodi systemd[1]: emby-server.service: Failed with result 'signal'.

Share this post


Link to post
Share on other sites
Luke

When does this happen? Immediately on startup? Or sometime later?

Share this post


Link to post
Share on other sites
s.zoli89

Im done with this. sorry, uninstall.... 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...