Jump to content

EmbyTheatre wont play NextPVR LiveTV


Recommended Posts

Hi,

 

I have finally dropped WMC with EmbyServer. New setup is:

 

HTPC running

  • NextPVR with DVB-T Dual Tuner (BlackGold BG9630)
  • Emby Theatre main client software to Live TV and Emby Server

Asustor NAS running

  • EmbyServer 3.3.0.0 with Emby Premiere (trying for month to see LiveTV works?)
  • EmbyServer 3.3.0.0 with NextPVR PlugIn v3.2.6.0

 

ISSUE

Success - Live TV on HTPC through PVRNext directly

Success - Live TV on HTPC through PVRNext web interface

Success - Live TV on Desktop PC through PVRNext web interface

FAIL - Live TV on HTPC with Emby Theatre

FAIL - Live TV on Desktop PCs / Laptop through Emby web interface

 

Emby error:

Just spins the circle or then provides No Tuners available.

 

*Upd: IPs as follows for logs

HTPC (192.168.1.114)

Asustor NAS (192.168.1.126)

Desktop PC (192.168.1.117) 

 

*Upd: 28/03/18 2pm Error

kU38Nk5.jpg

 
Edited by WayneJD
Link to post
Share on other sites

I'm getting the same "No tuners available" message in the Android TV app running against 3.3.1.10 beta server.

 

My TV source is IPTV though.

Link to post
Share on other sites
PenkethBoy

@@WayneJD

 

You dont mention the nextPVr emby plugin - which you need and to set in nextpvr software - remote access so the plugin can talk to nextpvr etc

Link to post
Share on other sites

@@PenkethBoy

 

Good news and bad..

 

Yes it started working just before lunch today with no changes or attempts since last night. It streamed LiveTV through Emby Server web interface. 

2nd issue is guide is not showing with the EPGData I can see in NextPVR Guide.

 

Now, 2pm

FAILS again trying to watch LiveTV through Emby Server web interface but works fine on HTPC NextPVR and NextPVR Web Interface.

2nd issue above also remains, even though I have not told NextPVR to read a new 7 day EPG, which NextPVR shows in its guide fully.

 

kU38Nk5.jpg

Edited by WayneJD
Link to post
Share on other sites
PenkethBoy

have you run the refresh guide scheduled task?

 

what are you using for epg - Schedules Direct - is it over the air broadcast or iptv or...

 

when it says no stream compatible - in the NextPvR software does it show the tuners in use or not?

Link to post
Share on other sites

NextPVR does have a guide its Emby LiveTv not displaying it for some reason.

 

See images below

 

NextPVR via web interface on my Desktop PC

 

0t3wN6m.jpg

 

 

 

Emby Server Live TV via Web Interface (same time)

 

cx4Conj.jpg

Link to post
Share on other sites

As for the No Compatible Streams...

 

When this happens I can successfully

  1. Ue HTPC and run up NextPVR and watch TV without issue and see a guide
  2. Use Desktop PC and NextPVR web interface and watch TV without issue and see a guide

Hence why Im at a loss Emby Server Live TV stating no streams.

 

btw - Thanks for all the help much appreciate.

 

My epgData is from www.xmltv.co.uk using my own custom Powershell script to maintain it.

 

 


<#
Download EPG data from xmlTV.co.uk

7day limited feed every 4th day since last 7day feed
72hr ALL feed every 72 hrs since last 72hr feed

#>

$dataPath = 'Z:\epgData'
$dataFilePrefix = 'xmltv-EPGData'
$epgDataLog = Join-Path $dataPath '_epgDataLog.txt'

# Setup Feeds available from xmltv.co.uk
$uriFeeds = @()
$uriFeed = @{
type = 'all'
time = '24h'
uri = 'http://www.xmltv.co.uk/feed/6461'# All data for 24 hours since last update.
}
$uriFeeds += $uriFeed
$uriFeed = @{
type = 'all'
time = '72h'
uri = 'http://www.xmltv.co.uk/feed/6463 ' # All data for 72 hours since last update.
}
$uriFeeds += $uriFeed
$uriFeed = @{
type = 'limited'
time = '7d'
uri = 'http://www.xmltv.co.uk/feed/6463 ' # All data for 7 days since last update.
}
$uriFeeds += $uriFeed


# Verify time based URI required based on last update
$uriFeed = $null
if(Test-Path (Join-Path $dataPath ('{0}-72h.xml' -f $dataFilePrefix))){
$df72hour = Get-Item -Path (Join-Path $dataPath ('{0}-72h.xml' -f $dataFilePrefix))
$nextHours = ($df72hour.LastWriteTime).AddHours(72) # last 72h feed update plus 72 hours days to get 72hr ALL feed
}else{
$nextHours = [datetime]"1-Jan-1900 01:00:00"
}
if(Test-Path (Join-Path $dataPath ('{0}-7d.xml' -f $dataFilePrefix))){
$df7day = Get-Item -Path (Join-Path $dataPath ('{0}-7d.xml' -f $dataFilePrefix))
$nextDay = ($df7day.LastWriteTime).AddDays(4) # last 7dy feed update plus 4 days to get 7 day limited feed
}else{
$nextDay = [datetime]"1-Jan-1900 01:00:00"
}
if( (Get-Date) -gt $nextHours){
$timeRange = '72h'
$uriFeed = ($uriFeeds | Where-Object ( { $_.time -eq $timeRange })).uri
}
if( (Get-Date) -gt $nextDay){ # override 72hrs if due next 7day limited feed (last + 4 days)
$timeRange = '7d'
$uriFeed = ($uriFeeds | Where-Object ( { $_.time -eq $timeRange })).uri
}


# Grab new xmlTV feed if required
$dataFile = (Join-Path $dataPath ('{0}.xml' -f $dataFilePrefix) )
$dataNewFile = Join-Path $dataPath ('{0}-{1}.xml' -f $dataFilePrefix, $timeRange)
if($uriFeed){
('{0} Grabbing {1} epgData feed with URI {2}' -f (Get-Date -Format 'dd-MMM-yyyy hh:mm:ss'), $timeRange, $uriFeed) | Out-File $epgDataLog -Encoding ascii -Append
$epgData = Invoke-WebRequest -Uri $uriFeed
$epgData.Content | Out-File $dataNewFile -Encoding ascii
Copy-Item -Path $dataNewFile -Destination $dataFile -Force
('{0} epgData grab complete, updated {1}' -f (Get-Date -Format 'dd-MMM-yyyy hh:mm:ss'), $dataFile) | Out-File $epgDataLog -Encoding ascii -Append
}else{
('{0} skipping 72h update, last update was {1}' -f (Get-Date -Format 'dd-MMM-yyyy hh:mm:ss'), (($df72hour.LastWriteTime).ToString('dd-MMM-yyyy hh:mm:ss')) ) | Out-File $epgDataLog -Encoding ascii -Append
('{0} skipping 7d update post 4th day, last update was {1}' -f (Get-Date -Format 'dd-MMM-yyyy hh:mm:ss'), (($df7day.LastWriteTime).ToString('dd-MMM-yyyy hh:mm:ss')) ) | Out-File $epgDataLog -Encoding ascii -Append
}


 

 

 

Edited by WayneJD
Link to post
Share on other sites

Did you run the guide refresh? Also please try the updated version of theater released today. Thanks.

Link to post
Share on other sites
PenkethBoy

for the guide to show up

 

i would refresh the guide in NextPvr - once its finished then refresh the guide in emby

 

Emby can see the channels so its talking to NextPvr

Link to post
Share on other sites

@@Luke - It seems Asustor NAS version of Emby Server version in there app store though still shows as 3.3.0.0.  However, there's an update showing for 3.3.1.0 listed in NAS current installed 3.3.0.0 version but not auto-updating.  Bit confused.

 

@Penketh - I have done already.  Downloaded new epgData today, updated in NextPVR and its guide shows results correctly (as per screen above).  Went into Emby Server->LiveTV->Refresh Guide Data and nothing.  so have now added XMLTV file (pointed to same on NextPVR uses) and click Refresh Guide Data and still nothing.

Link to post
Share on other sites

@@Luke - It seems Asustor NAS version of Emby Server version in there app store though still shows as 3.3.0.0.  However, there's an update showing for 3.3.1.0 listed in NAS current installed 3.3.0.0 version but not auto-updating.  Bit confused.

 

We mention this on our download page:

https://emby.media/nas-server.html

 

It hasn't gotten through the Asustor review process yet. Thanks.

Link to post
Share on other sites

@@Luke

 

Thanks for this.  Still new to my Asustor NAS as only had month :)

 

Wasn't aware of that link, will bookmark now and use - thanks :)

 

PS: Been Emby support since Media Browser and now finally after 4 years dropping WMC (used since 2004) but found MB/Emby for media library back in 2014 an been so impressed with its development.  Now a Emby Premier supporter to and once get all this sorted will progress to lifetime purchase! :)

Edited by WayneJD
Link to post
Share on other sites

Thanks for the feedback. Once you've updated to the latest version of the server, I would try to play again, and if the issue persists please attach the emby server log. thanks.

Link to post
Share on other sites

Good news all working.  :D

 

I will post a [HOW TO] LiveTV with NextPVR Setup Guide as a thanks for all the help with an FAQ of known issue/fixes we have discussed and few tried myself.

 

Just need to fix the epgData from improved source as seems xmltv.co.uk missing few channels.  Digi Guide at £14.99 p/yr tried but their site fails to send activation of account email for trial so looking for another.

 

Also found cause of the No streams issue, WMC (Windows Media Centre) is still using tuners to record and when not, only minor suspect known issue playing back Live TV.

 

LiveTV play back suspect issue is im still using EoP (Ethernet over Powerline) in front room (until cable later this year).  Although server log todays does show some interesting error/decode timing_picture_timing problems (see attached).  I presume these are due to the limited band with with EoP?

 

 

 

 

Server_Log_LIVETV_2010329.txt

Edited by WayneJD
Link to post
Share on other sites
  • 2 weeks later...
riverboat2001

Good news all working.  :D

 

I will post a [HOW TO] LiveTV with NextPVR Setup Guide as a thanks for all the help with an FAQ of known issue/fixes we have discussed and few tried myself.

 

Just need to fix the epgData from improved source as seems xmltv.co.uk missing few channels.  Digi Guide at £14.99 p/yr tried but their site fails to send activation of account email for trial so looking for another.

 

Also found cause of the No streams issue, WMC (Windows Media Centre) is still using tuners to record and when not, only minor suspect known issue playing back Live TV.

 

LiveTV play back suspect issue is im still using EoP (Ethernet over Powerline) in front room (until cable later this year).  Although server log todays does show some interesting error/decode timing_picture_timing problems (see attached).  I presume these are due to the limited band with with EoP?

 

I'd definitely appreciate a how to guide. Just working through setting up a fresh Win10 install.

  • Like 1
Link to post
Share on other sites

I'd definitely appreciate a how to guide. Just working through setting up a fresh Win10 install.

 

I try gt the guide sorted this week if not definitely the weekend.  Full time employment in the way of fun as usual.

Link to post
Share on other sites
riverboat2001

Hey,

 

I've just got my set up working perfectly apart from a few visual tweaks.

I've made "some" notes along the way,  so would appreciate any how to's that I can copy and keep if I should ever have to re-install !

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...