Jump to content

New ServerWMC Update 3/27/2018


Recommended Posts

krustyreturns

Oh, it looks like I even knew about it at one time....  I don't see how it can be something I am doing in the plugin, but I will take a look.

  • Like 1
Link to post
Share on other sites
krustyreturns

Obviously I am late to this game since my summer hiatus, but Luke's changes to my plugin where just for compatibility to changes to emby, I don't think he attempted to fix whatever the hell is causing this problem.

Link to post
Share on other sites
krustyreturns

@@Sammy

 

OK, I finally got everything up again.  I am running emby 3.5.3.0 and the serverwmc plugin for this is 1.1.8.0.  I'm also using chrome as the client.

 

I can play both live tv and recorded tv.  And I can playback the recorded tv as either a url or through a network share (via serverwmc) - both seem to work fine.  Live-tv works too.  So I have not been able to reproduce the problem described in the post you linked to.

 

@@Luke,

The only weird thing I am seeing is when I play a recorded tv file, emby is not closing the stream down when I hit the back button in chrome.  However live-tv streams are shutdown when I hit the back button.  Any idea why this would be?

  • Like 1
Link to post
Share on other sites

Really, you were able to pull in all my changes and still run on 3.5.3? My code is based on the beta server which has breaking changes.

  • Like 1
Link to post
Share on other sites
krustyreturns

No, I couldn't run your latest change. I had to run the version before that (.1.8). Which matches the catalog version for the version of Emby I am running.

Edited by krustyreturns
  • Like 1
Link to post
Share on other sites

Ok it's because recordings are running through the server's internet channels framework now, and that doesn't have a mechanism for closing streams. i can look at adding that.

  • Like 1
Link to post
Share on other sites

@@Sammy,

 

OK, I finally got everything up again. I am running emby 3.5.3.0 and the serverwmc plugin for this is 1.1.8.0. I'm also using chrome as the client.

 

I can play both live tv and recorded tv. And I can playback the recorded tv as either a url or through a network share (via serverwmc) - both seem to work fine. Live-tv works too. So I have not been able to reproduce the problem described in the post you linked to.

 

@@Luke,

The only weird thing I am seeing is when I play a recorded tv file, emby is not closing the stream down when I hit the back button in chrome. However live-tv streams are shutdown when I hit the back button. Any idea why this would be?

It's been so long and I actually quit using ServerWMC including uninstalling the plugin that I don't remember exactly what the issue was but I think it is that the recordings would not playback from the SeverWMC recordings folder that showed up on the home screen.

 

Sent from my SM-G930P using Tapatalk

Link to post
Share on other sites
krustyreturns

Working with it a little more this morning.  I have so far not had any trouble starting/stopping live streams.  I also don't seem to have a problem playing recordings if serverwmc is configured to use a network share.  However, if instead the recordings are given to emby through a url, it (usually) doesn't work.   (I say 'usually' because once this morning it did work, and I thought for sure it was working last night.)   I am getting the error below in the emby logs when it doesn't work:

2018-09-26 10:40:40.008 Info App: User policy for victor. EnablePlaybackRemuxing: True EnableVideoPlaybackTranscoding: True EnableAudioPlaybackTranscoding: True
2018-09-26 10:40:40.042 Info App: Profile: Unknown Profile, Path: http://192.168.1.219:9180/serverwmc.stream/StreamRemuxFile?clientName=Emby%5eMANTA%5e0, isEligibleForDirectPlay: True, isEligibleForDirectStream: True
2018-09-26 10:40:40.064 Info App: Profile: Unknown Profile, No direct play profiles found for Path: http://192.168.1.219:9180/serverwmc.stream/StreamRemuxFile?clientName=Emby%5eMANTA%5e0
2018-09-26 10:40:40.129 Info App: Profile: Unknown Profile, Path: http://192.168.1.219:9180/serverwmc.stream/StreamRemuxFile?clientName=Emby%5eMANTA%5e0, isEligibleForDirectPlay: True, isEligibleForDirectStream: True
2018-09-26 10:40:40.129 Info App: Profile: Unknown Profile, No direct play profiles found for Path: http://192.168.1.219:9180/serverwmc.stream/StreamRemuxFile?clientName=Emby%5eMANTA%5e0
2018-09-26 10:40:40.130 Info App: Profile: Unknown Profile, Path: http://192.168.1.219:9180/serverwmc.stream/StreamRemuxFile?clientName=Emby%5eMANTA%5e0, isEligibleForDirectPlay: True, isEligibleForDirectStream: True
2018-09-26 10:40:40.130 Info App: Profile: Unknown Profile, No direct play profiles found for Path: http://192.168.1.219:9180/serverwmc.stream/StreamRemuxFile?clientName=Emby%5eMANTA%5e0
2018-09-26 10:40:40.228 Error HttpServer: Error processing request
	*** Error Report ***
	Version: 3.5.3.0
	Command line: C:\Users\victo\AppData\Roaming\Emby-Server\system\EmbyServer.dll
	Operating system: Microsoft Windows NT 6.2.9200.0
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Processor count: 4
	Program data path: C:\Users\victo\AppData\Roaming\Emby-Server\programdata
	Application directory: C:\Users\victo\AppData\Roaming\Emby-Server\system
	System.ArgumentException: key
	   at Emby.Server.Implementations.Library.MediaSourceManager.GetProvider(String key)
	   at Emby.Server.Implementations.Library.MediaSourceManager.OpenLiveStreamInternal(LiveStreamRequest request, CancellationToken cancellationToken)
	   at Emby.Server.Implementations.Library.MediaSourceManager.OpenLiveStream(LiveStreamRequest request, CancellationToken cancellationToken)
	   at Emby.Server.MediaEncoding.Api.MediaInfoService.OpenMediaSource(OpenMediaSource request)
	   at Emby.Server.MediaEncoding.Api.MediaInfoService.GetPlaybackInfo(GetPostedPlaybackInfo request)
	   at Emby.Server.MediaEncoding.Api.MediaInfoService.Post(GetPostedPlaybackInfo request)
	   at Emby.Server.Implementations.Services.ServiceExecGeneral.GetTaskResult(Task task)
	   at Emby.Server.Implementations.Services.ServiceHandler.ProcessRequestAsync(HttpListenerHost appHost, IRequest httpReq, IResponse httpRes, ILogger logger, String operationName, CancellationToken cancellationToken)
	   at Emby.Server.Implementations.HttpServer.HttpListenerHost.RequestHandler(IHttpRequest httpReq, String urlString, String host, String localPath, CancellationToken cancellationToken)
	System.ArgumentException
	   at Emby.Server.Implementations.Library.MediaSourceManager.GetProvider(String key)
	   at Emby.Server.Implementations.Library.MediaSourceManager.OpenLiveStreamInternal(LiveStreamRequest request, CancellationToken cancellationToken)
	   at Emby.Server.Implementations.Library.MediaSourceManager.OpenLiveStream(LiveStreamRequest request, CancellationToken cancellationToken)
	   at Emby.Server.MediaEncoding.Api.MediaInfoService.OpenMediaSource(OpenMediaSource request)
	   at Emby.Server.MediaEncoding.Api.MediaInfoService.GetPlaybackInfo(GetPostedPlaybackInfo request)
	   at Emby.Server.MediaEncoding.Api.MediaInfoService.Post(GetPostedPlaybackInfo request)
	   at Emby.Server.Implementations.Services.ServiceExecGeneral.GetTaskResult(Task task)
	   at Emby.Server.Implementations.Services.ServiceHandler.ProcessRequestAsync(HttpListenerHost appHost, IRequest httpReq, IResponse httpRes, ILogger logger, String operationName, CancellationToken cancellationToken)
	   at Emby.Server.Implementations.HttpServer.HttpListenerHost.RequestHandler(IHttpRequest httpReq, String urlString, String host, String localPath, CancellationToken cancellationToken)

@@Sammy no worries, glad emby's soln is working for you.

  • Like 1
Link to post
Share on other sites

Hi:

The issue with the current version of Emby Server and ServerWMC has to do with multiple 'versions' of LiveTV recordings showing up in the description page.  This behavior is described in the following posts:

 

https://emby.media/community/index.php?/topic/60884-recordings-show-versions-undefined-and-wtv-filename-why/?p=598871

 

and Post #64 in this thread, author "muranoone" (with photos)

https://emby.media/community/index.php?/topic/57468-new-serverwmc-update-3272018/?p=610192

 

In short, ServerWMC recordings when displayed in Emby show a version titled "undefined", and a version titled with the WMC filename. During Active Recording, two versions are shown, both titled "undefined".  If I attempt to play any version titled "undefined", it will not play

 

While I can successfully view ServerWMC Recordings in Emby, it is inconvenient (and difficult from the WAF side of things) to have to make the proper selection.  The "undefined" version is always the default, requiring an additional step to view any of the recordings.

 

Lastly, it would be wonderful if we could view Active Recordings in a time-delay situation, but I understand this is a difficult piece of trickery...

 

Thanks for any help the (combined) dev team can provide!

Link to post
Share on other sites

What version of Emby and the severwmc plug in are you running? And please post your swmc log.

 

Emby 3.5.3.0, ServerWMC 1.0.0.63, build 1255, although the problem existed on several previous versions of Emby and the previous stable build of ServerWMC

 

Here's my ServerWMC logs from the past couple of days:

 

ServerWMC.log

ServerWMC_20180926.log

Link to post
Share on other sites
krustyreturns

Thanks, we are running the same version of emby.  This behavior does not happen on my system, I only get the version of the recording  that swmc sends to emby.  In the muranoone post you referenced, in the post before that one, he says that he added the wmc's rec tv folder as a 'tv show' source to emby, isn't that what is causing this problem?  I am only accessing the recordings through the serverwmc channel (does this new emby call this a channel?).  It that's not the problem, then please tell in detail how to get to that screen in the serverwmc channel because I don't see a description page that looks like that.

 

@@Luke the fact that emby won't shutdown the recording streams is a major pain in trying to debug this stuff.  Is the only hope of getting this addressed in the dev version of emby?  Are you sure there isn't a flag to set in my addon to make emby  send a close stream command? 

Edited by krustyreturns
Link to post
Share on other sites

I don't have the WMC Recorded TV directory set up as a library. There's another post of mine in this thread which explains why that won't work for ServerWMC users(#73).

 

I see the 'version' dropdown box when accessing shows from the ServerWMC Recordings view, and also from Emby's Live TV -> Recordings view.

Link to post
Share on other sites

Correct, there's no way in the release version. Ideally you would just auto close when the client disconnects from the recording url, but if that's not possible then I can add a way to close it.

Link to post
Share on other sites
krustyreturns

@@Steveo369,  sorry I still don't  get it.  This is what I see when I access recordings from either path you describe.  When I click any of the icons they just play, there are no two versions that I have to choose from.  I can't find a version drop down menu.  Please excuse my emby ignorance.

 

5bad09f26c100_Capture.png

Link to post
Share on other sites
krustyreturns

@@Luke,  the recording urls don't work (see my earlier post),  Although for some  reason, it works fine for live stream urls.  This is weird because to serverwmc there is almost no distinction between a recording and a live stream url.   Just having emby access the recording files directly works.

Link to post
Share on other sites

@@Steveo369,  sorry I still don't  get it.  This is what I see when I access recordings from either path you describe.  When I click any of the icons they just play, there are no two versions that I have to choose from.  I can't find a version drop down menu.  Please excuse my emby ignorance.

Try drilling down one more level to get to the tv show description (don't click the play button on the show cover)

 

Here's what my screen looks like (iOS Emby App, but other clients look the same):

post-3984-0-67847500-1538071746_thumb.png

post-3984-0-51792300-1538071761_thumb.png

  • Like 1
Link to post
Share on other sites
krustyreturns

Thank you! I see it now.  Every time I try it, the 'undefined' thing is not the one selected, is that not the same for you?  If its not selected, I have trouble seeing why it would cause much of a problem, but if it is selected then I agree that it's a problem.  

 

I don't understand what this 'version' field is supposed to be anyway.  Is it really supposed to be the raw name of the file?  And with that, why is there something called 'undefined' too?  There is only one file after all.  @@Luke or anybody, what is this version info field supposed to contain for a recording file?  Maybe I am filling out a field incorrectly in the plugin.

Link to post
Share on other sites

For me, the 'undefined' version is always default.

 

This also causes the problem that if I try to play the recording directly from the previous 'Recordings' screen (the one you captured the screen shot of), it will not play, and times out with out any error messages.

 

I believe this is because it tries to play the 'undefined' version...

Link to post
Share on other sites
krustyreturns

@@Luke,  this happens when the MediaSourceInfo object for each recording contains a file path.  I thought I could do a workaround by not passing the path back during GetRecordings and just rely on the MediaSourceInfo that is passed back when Emby plays the stream, (i.e. when it calls GetRecordingStream) but that MediaSourceInfo seems to just be ignored now, is that right?.  If I can do anything on my end to help let me know.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...