Jump to content

New ServerWMC Update 3/27/2018


Recommended Posts

ITMonkey

So it's a server thing too.. I suppose I could disconnect Emby from WMC for the time being and just use the native tuner and guide. Hmm. I'm moving most of my recording duties to Plex for CommSkip right now so IDK if I need to have the connection here other than for the better guide provided from WMC using epg123.

 

Yeah, I'm not sure where the disconnect comes from but the plugin 1.1.3 works with the last stable build of 3.3.1.0 and nothing after that.  Or at least no build for me specifically after that.

Link to post
Share on other sites

Hi guys, sorry I can't be much help I am traveling and will continue to be for another week.  Nice work @@tigrao.  Since nothing has changed in serverwmc I'm certain that the url is getting passed back to the plugin.  Its probably the new version of the plugin that is somehow zeroing out this url.  @@Luke can you think of why this would happen with the changes to the plugin?

 

Hoping for a solution soon. @@Luke, did you get a chance to look into @@krustyreturns inquiry?

 

Thanks!

Link to post
Share on other sites

Thanks. Hopefully krusty will return soon so this can get fixed. ServerWMC works fine to load the guide and watch but recordings are a different thing altogether..

Link to post
Share on other sites

Keep in mind you can always add the recordings folder as a regular emby library.

 

I do have it added as such. What ServerWMC gave me a glimpse of before it stopped working was very nice with shows properly organized. The native recordings library is a huge mess in that it is not organized by show and is missing Metadata.

Link to post
Share on other sites
  • 3 weeks later...
Luke

I'm happy to work with krustyreturns to help chase this down. In the meantime you can just add the recordings folder as a regular emby library. thanks.

Link to post
Share on other sites

Thank you.

 

@@Luke I will continue to be patient as ServerWMC still does the back end stuff it is supposed to do and talks to WMC just fine.

 

@@krustyreturns Have you taken a look at what may be wrong?

Link to post
Share on other sites
muranoone

Hey everyone, ive been experiencing the same exact issues w RecTV  Live TV.. and watching on my Apple TV 4K w Emby App in the Bedroom...

 

If you would like Emby Server to stream RecTV to Bedrooms or any room its in...

 

You must add ur WMC RecordedTV folder to Emby as  a "TV Shows" - "Content Type" Located in Server - Dashboard - Library  after u do so... Scan all ur librarys... then follow

 

1. Open ur Emby App on the Apple TV 4K 

2. Lay down relax Open Emby on your iPhone, iPad, or whatever tablet or phone u use. 

3. Tap the Cast icon - Choose  ******-  tvOS -

3. Navigate to the NEW folder - "TV Shows" - at the top most right tap Episodes - u may have to swipe to see it.

4. Then choose any RecTV Show from "TV Shows" folder u made earlier hit Play, wait for it to load....

 

if things not working...

Restart your Emby App on ur Apple TV 4K if you do not see ****** - tvOS -

******= Your Apple TV 4K name. Mine is "Bedroom - tvOS" make sure its correct room!

If more than 30 sec. to load TV show kill all ur Apps on the Apple TV 4K & Restart it.

 

Confirmed ...

Live TV & ServerWMC Recordings Folder do not work this way! - Not for me

Also, FYI the mobile device is not steaming to the tvOS -  its simply sending the stream from Emby Server to the Apple TV 4K via the Network.

its just a remote control so no battery drain or anything.

 

This should wok with other Steaming Devices so try it if  u like. Hope this helps someone!!

Thanks for all your hard work Luke and Krusty hope we have this back to normal soon.

Link to post
Share on other sites
  • 1 month later...

Hey Guys I need to understand what "Sundefinded" & "Eundefinded" means.. found in the details of the WMC TV recordings specifically the Audio descriptions. 

 

Any Rec. with these descriptions for Audio will not play in any browser and cannot be streamed to any device using the directions above. 

 

If they indicate a "Dolby Digital" 5.1 description they work as designed.  ???

 

5b78e48cdf4e4_YSheldon.png      5b78e4bdd7d2f_YSheldon1.png

Link to post
Share on other sites

Hi, what i would suggest instead is just adding the recordings folder as a regular emby library, rather than playing through serverwmc. can you try that? thanks.

Link to post
Share on other sites

5b7cc5d332299_1Capture.png   5b7cc63bbde72_Capture.png

 

 

 

I am using this method ...So this causes my WMC to error message "No Service available for the current channel" to appear often and it turns all my tuners to "Red"  ... The Temp Folders are hidden but emby still can see them. 

 

This current issue w emby and RecTV not able to play RecTV in browsers and not able to steam the way they would prior to the recent updates to emby server and the ServerWMC plug-in I believe is this Audio "Sundefinded" & "Eundefinded" problem. No audio can be loaded in order to play the file. All the files with 5.1 Play as designed. Do we know what  "Sundefinded" & "Eundefinded" is ? or what we are missing ? Anything I could do to help resolve this please LMK!

 

I would really enjoy emby working like it did for years!!! 

Edited by muranoone
Link to post
Share on other sites

There's no way that could cause a problem with windows media center. All Emby Server would be doing is reading the contents of your recording folder. I've never heard of this before.

Link to post
Share on other sites

Ok I see ... I noticed every time I have the ServerWMC plugin installed on my local HDD I would revive these errors. I would uninstall it and they come back. Idk I will do more testing to see exactly how to reproduce that error.

 

So back to the “Sundefined and Eundefinded audio issue... how can we resolve this any idea why this is happening??

 

Also in the Apple TV App.... the “TV Shows” Folder shows only the two hidden folders “TempRec” & “TempSWMC” that is also an issue.

 

And the only choices we have in the Header is Shows - Suggestions - Generes - Search ——

 

Nothing in there , shows won’t play under suggestions either ..

 

So have to use the iPhone to load the “TV Shows” and remote them that way ??

 

Is this not happing to anyone else .. weird

post-2697-0-91654300-1535341568_thumb.jpeg

post-2697-0-10472100-1535341617_thumb.jpeg

post-2697-0-94453200-1535341631_thumb.jpeg

post-2697-0-58246800-1535341656_thumb.jpeg

Link to post
Share on other sites

The fact that those folders are showing is probably due to the way you setup your TV library. How did you do that?

Link to post
Share on other sites

Did you check our TV naming wiki for supported folder structures and naming conventions:

 

https://github.com/MediaBrowser/Wiki/wiki/TV%20naming

 

What you have is essentially a mish mash without any tv series folders. That's something we'd like to accommodate in the future, but as of now you need folders for each series. With that folder structure you are probably better off selecting the home videos content type.

 

Thanks.

Link to post
Share on other sites

Did you check our TV naming wiki for supported folder structures and naming conventions:

 

https://github.com/MediaBrowser/Wiki/wiki/TV%20naming

 

What you have is essentially a mish mash without any tv series folders. That's something we'd like to accommodate in the future, but as of now you need folders for each series. With that folder structure you are probably better off selecting the home videos content type.

 

Thanks.

 

 

Wait.  WHAT?  As a long time WMC, Emby + ServerWMC user, I've been watching this thread for awhile, hoping that a fix for the re-integration of ServerWMC would appear.  Prior to Emby implementing the 'baked in' version of LiveTV, Emby + ServerWMC worked great!

 

The initial suggested workaround for the broken interaction of ServerWMC and Emby was to create an Emby Library which contained the Recorded TV folder.  The response quoted above seems to imply that this folder must follow naming/folder conventions for Emby to properly parse it?   

 

Quite simply, that won't work.

 

The Recorded TV folder is a system DVR folder, populated by WMC (when scheduled through Emby + ServerWMC).  We have no control over filenames (created by WMC) or folder structure.  The TempSWMC and TempRec Directories as shown in muranoone's images are created during installation of ServerWMC.

 

Creating a native Emby library on the WMC Recorded TV directory will not properly show metadata, and the only way to even see the recordings is to navigate to the 'Folders' view in the created library.

 

Recap:

Using current version of Emby and ServerWMC - 

  • I can still view recorded television in the "Live TV -> Recordings" section of Emby, and I can still view recorded television in the "ServerWMC Recordings" top level library created by the installation of ServerWMC.  To view recorded television, I MUST select the proper "version" of the file, which is inconvenient.  The 'version' dropdown behavior and whether it appears or not also seems to vary based on client used.
  • I cannot view any active Recordings
  • The ability to view Live TV can be spotty, and very dependent on the client I'm using, and whether I'm remote or local, but for the most part does seem to work.  Sometimes it takes awhile of the spinning circle, and I'm not sure if Live TV is ever actually going to come up.

I would much appreciate if the Emby + ServerWMC team could get together (although I haven't seen krustyreturns actually return in awhile!?) and fix the 'Version' dropdown issue when viewing recorded television, and find a solution to viewing active recordings.  Things would be about perfect at that point (at least for me!)

 

Thanks

-Steveo369

  • Like 1
Link to post
Share on other sites

Wait.  WHAT?  As a long time WMC, Emby + ServerWMC user, I've been watching this thread for awhile, hoping that a fix for the re-integration of ServerWMC would appear.  Prior to Emby implementing the 'baked in' version of LiveTV, Emby + ServerWMC worked great!

 

The initial suggested workaround for the broken interaction of ServerWMC and Emby was to create an Emby Library which contained the Recorded TV folder.  The response quoted above seems to imply that this folder must follow naming/folder conventions for Emby to properly parse it?   

 

Quite simply, that won't work.

 

The Recorded TV folder is a system DVR folder, populated by WMC (when scheduled through Emby + ServerWMC).  We have no control over filenames (created by WMC) or folder structure.  The TempSWMC and TempRec Directories as shown in muranoone's images are created during installation of ServerWMC.

 

Creating a native Emby library on the WMC Recorded TV directory will not properly show metadata, and the only way to even see the recordings is to navigate to the 'Folders' view in the created library.

 

Recap:

Using current version of Emby and ServerWMC - 

  • I can still view recorded television in the "Live TV -> Recordings" section of Emby, and I can still view recorded television in the "ServerWMC Recordings" top level library created by the installation of ServerWMC.  To view recorded television, I MUST select the proper "version" of the file, which is inconvenient.  The 'version' dropdown behavior and whether it appears or not also seems to vary based on client used.
  • I cannot view any active Recordings
  • The ability to view Live TV can be spotty, and very dependent on the client I'm using, and whether I'm remote or local, but for the most part does seem to work.  Sometimes it takes awhile of the spinning circle, and I'm not sure if Live TV is ever actually going to come up.

I would much appreciate if the Emby + ServerWMC team could get together (although I haven't seen krustyreturns actually return in awhile!?) and fix the 'Version' dropdown issue when viewing recorded television, and find a solution to viewing active recordings.  Things would be about perfect at that point (at least for me!)

 

Thanks

-Steveo369

 

 

I've kinda given up on ServerWMC, especially since the advent of SiliconDust's PremiumTV which is not visible in WMC. I've deleted the plugin and started to go the route of just using Emby.

 

That said, a thought came to my mind yesterday which I haven't tried yet..

 

Setting up OTA via ServerWMC and then doing PremiumTV via either an xmltv from epg123 or using the SchedulesDirect Lineup directly in Emby.

 

None of this solves the break in communication between Emby and ServerWMC which came about somewhere around Emby version 3.4.0 or so.

Link to post
Share on other sites

I've managed to arrive at some sort of detente in this regard...

 

- New recordings are displayed in the webUI under LiveTV  > Recordings (however, sorting, for ALL views, is BADLY busted in the current server release).

 

- SD artwork image distortion, in the webUI, via SWMC is annoying, but for the amount of time I use this outside of WMC, I'll live.

 

- NO extra TV library & SWMC tile hidden via custom CSS in webUI, & by manually editing configs in EMC. I want NO NEW TILES cluttering up either home screen! Please add UI display options.

 

- Ceton ETH6 has always worked great in WMC, & is passable in the webUI for non-DRM Live TV channels (DRM filtered out via SWMC). I realize others are having problems with Live TV (& recordings) playback but they seem OK for me, to the extent I use them for auditing in Emby. Likely some SWMC config?

 

I must note that the migration to the 'new paradigm' seems to have been REALLY poorly considered & I am increasingly concerned that support for EMC is falling off in favor of clients I will NEVER use. I understand WMC is 'the past', but until an acceptable substitute comes along, I'd like to see EMC & new development continue to get along.

 

Just my $.02 FWIW.

Edited by d00zah
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...