Jump to content
mchadima

Live TV Emby for Android TV freeze

Recommended Posts

mchadima

I attached logs directly from Emby Server on my QNAP TS251 at 10:05 CST username logged in "Mike".

 

Started log on Channel 11 at about 9:50, only one freeze, switched to Channel 5 at 9:58 and the "normal" freezing (occurring every minute or so, with a 5-10 second delay).  

Network is gigabit ethernet direct wired to Android TV (device X96mini version 7.1.2) running Emby for Android TV Version 1.5.32g.

 

Can use HDHomerun app and no freeze.  Playback movies, and stream from HBO, no freeze.  Only live TV.

 

Settings are default.  Freezing happens on every channel.

 

Suggestions?  Thanks.

Share this post


Link to post
Share on other sites
mchadima

Server and two ffmpeg files are attached.  The fb54a file is time stamped 10:02 and the 1311 file is time stamped 9:55, and looking at the times in the files, I would suspect the first file (fb54a) will show the freezes since it starts at 9:55.  The other file starts at 9:48.

 

Thanks.

server-63652435200.txt

ffmpeg-remux-fb54a24b-78b5-44c2-a168-c2290c862efe.txt

ffmpeg-remux-1311a6d9-d508-4549-9a17-65333c9915d.txt

Share this post


Link to post
Share on other sites
mchadima

More information:  I recorded live TV until I got some good examples of freezing.  That log is attached (854d...).  Good example of freezing at the end of the file.  Then played back and the freezing got MUCH worse, basically 15 seconds of replay, then 10 seconds of freeze, repeating.  Unwatchable.  That log is also attached (f4d97...stream is Today Show).

 

Didn't know if that would help identify what is going on.  I know nothing about video and am new to implementing Emby on my home network.  Everything else about Emby works great.

 

Thanks.

ffmpeg-remux-854d0420-639c-4dd2-a940-04f9d9aeed94.txt

ffmpeg-remux-f4d97bab-0a85-48c3-9425-958d15d6dae0.txt

Share this post


Link to post
Share on other sites
ebr

From the app end it just looks like the stream is not coming in quickly enough.  The player keeps pausing and re-starting to catch up.

Share this post


Link to post
Share on other sites
mchadima

OK.  Is there a setting I should look at, or why would the feed from Emby provide a slow stream?  As I noted, the HDHomerun Android TV app playback is perfect.

Share this post


Link to post
Share on other sites
mchadima

Perhaps something I should look at in the QNAP server?

Share this post


Link to post
Share on other sites
mchadima

Another update.  I tested Emby Live TV on an iOS device hooked up through wifi on my LAN.  Playback for movies and music was clean.  Playback for Live TV displayed the same freezing as seen on Android TV.  

Share this post


Link to post
Share on other sites
Luke

Here is the ffmpeg log for the iOS Live TV playback.  Only consists of 3 minutes of playback, but there were 3 (>15 second) freezes during that time.

 

It was just the one single ffmpeg log?

Share this post


Link to post
Share on other sites
mchadima

No, there a many ffmpeg logs, but this was the log with the timestamp of when I was watching Live TV using iOS.

Share this post


Link to post
Share on other sites
ebr

Here is the ffmpeg log for the iOS Live TV playback.  Only consists of 3 minutes of playback, but there were 3 (>15 second) freezes during that time.

 

This one is transcoding and the CPU is simply not able to keep up.  Only moving about 1/2 speed.

Share this post


Link to post
Share on other sites
mchadima

OK, that at least helps to identify the problem.  Now, how to fix it.  Is the QNAP incapable of transcoding Live TV?  How can I test it to transcode something else?  A .mkv file?  Or can I "force" the HDHomerun to do the transcoding, since it seems to be capable when I watch directly from the app, bypassing Emby?  Sorry I don't know more about video.  And thanks for the help.

Share this post


Link to post
Share on other sites
Luke

hi @@mchadima, what model HDHomerun do you have?

Share this post


Link to post
Share on other sites
mchadima

 

CONNECT DUO HDHR5-2US 2- Tuner

 

Share this post


Link to post
Share on other sites
Luke

OK I don't believe this model has onboard transcoding, right? Therefore Emby Server will need to handle it.

 

Please also update to the latest version of Emby Server. Thanks.

Share this post


Link to post
Share on other sites
mchadima

Upgraded the server.  New problem with LiveTV.  Now, the video will freeze, but audio will continue.  That hasn't happened before.  Seems to lock up the anroid tv client, forcing a restart. Sometimes able to ESC and restart from the Channel Guide. In the attached ffmpeg log, the entire stream locked up at the end (8:18) and couldn't recover. 

 

Also attaching server log.

 

More info:  this may be irrelevant, but the "spinning circle" when trying to load a channel appears to often freeze as well.  When it does, the next screen is the "Playback Error?" screen. Click NO and the spinning circle restarts, but is not able to make a connection to the channel.  After no progress for >a minute, ESC to get back to the channel guide.  Try again, same channel.  Same spinning circle freeze.  Click YES to Playback error, no system response.  Total lockup, force reboot of android tv.  That ffmpeg log is attached, too, as ffmpeg log 2-4 V2.

 

Also tested recording the same program "Sunday Morning".  Playback displays freezing about every 10 seconds, freeze for ~5 seconds, then resume.  That ffmpeg log is attached as ffmpeg log 2-4 V3.

 

Finally, you are correct, Luke.  This HDHomerun, like 3 of the 4 models sold in the US does not provide hardware transcoding.

ffmpeg log 2-4.txt

Emby Server log 2-4.txt

ffmpeg log 2-4 V2.txt

ffmpeg log 2-4 V3.txt

Share this post


Link to post
Share on other sites
Luke

@@ebr can comment on the first two but in the v3 log that's because your transcoding was not happening fast enough.

Share this post


Link to post
Share on other sites
ebr

but the "spinning circle" when trying to load a channel appears to often freeze as well.  When it does, the next screen is the "Playback Error?" screen. Click NO and the spinning circle restarts, but is not able to make a connection to the channel.  After no progress for >a minute, ESC to get back to the channel guide.  

 

Can you please do this and then follow the instructions for sending a log from the app?

 

Thanks.

Share this post


Link to post
Share on other sites
mchadima

Log sent from Emby for Android TV app at 4:47 am, user name Mike, playback of recorded TV, program is CBS News Sunday Morning.  This is not the spinning circle error, rather the repeated freeze.  The spinning circle seems to have cleared up with a restart of all devices on the network, which is good.

 

Thanks.

Share this post


Link to post
Share on other sites
ebr

Log sent from Emby for Android TV app at 4:47 am, user name Mike, playback of recorded TV, program is CBS News Sunday Morning.  This is not the spinning circle error, rather the repeated freeze.  The spinning circle seems to have cleared up with a restart of all devices on the network, which is good.

 

Thanks.

 

Hi.  I did not receive this app log.  However, this isn't an app issue.  The repeated freezing is simply your server not able to transcode/deliver the content fast enough.

Share this post


Link to post
Share on other sites
mchadima

Running this on a QNAP TS-251 with Celeron 2.41 GHz dual-core processor.  Watching the Resource Manager during Live TV playback, CPU use is 15%-20%, but during playback of recorded TV, CPU jumps to 99%, which is when the freezing happens. RAM is not an issue.  Suggestions?

 

QNAP claims this unit is well-suited for transcoding.  Is this something I should take up with them?

Share this post


Link to post
Share on other sites
Sammy

You need MORE POWER!

 

Sent from my SM-G930P using Tapatalk

Share this post


Link to post
Share on other sites
mastrmind11

Running this on a QNAP TS-251 with Celeron 2.41 GHz dual-core processor.  Watching the Resource Manager during Live TV playback, CPU use is 15%-20%, but during playback of recorded TV, CPU jumps to 99%, which is when the freezing happens. RAM is not an issue.  Suggestions?

 

QNAP claims this unit is well-suited for transcoding.  Is this something I should take up with them?

a dual core Celeron is barely suited for anything, let alone transcoding.  The bigger question should be why is it transcoding in the first place.

Share this post


Link to post
Share on other sites
Sammy

The player isn't capable of the stream codecs, throttling is on or there's network issues?

 

Sent from my SM-G930P using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...