Jump to content


Photo

Live TV Emby for Android TV freeze

freeze stutter buffer QNAP

  • Please log in to reply
49 replies to this topic

#1 mchadima OFFLINE  

mchadima

    Member

  • Members
  • 23 posts
  • Local time: 07:21 AM

Posted 25 January 2018 - 12:19 PM

I attached logs directly from Emby Server on my QNAP TS251 at 10:05 CST username logged in "Mike".

 

Started log on Channel 11 at about 9:50, only one freeze, switched to Channel 5 at 9:58 and the "normal" freezing (occurring every minute or so, with a 5-10 second delay).  

Network is gigabit ethernet direct wired to Android TV (device X96mini version 7.1.2) running Emby for Android TV Version 1.5.32g.

 

Can use HDHomerun app and no freeze.  Playback movies, and stream from HBO, no freeze.  Only live TV.

 

Settings are default.  Freezing happens on every channel.

 

Suggestions?  Thanks.



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136081 posts
  • Local time: 08:21 AM

Posted 25 January 2018 - 02:52 PM

hi there @mchadima, we're sorry to hear about this. Can you also please attach the emby server and ffmpeg log (if there was one)? You can learn how to do that here:

 

https://emby.media/c...port-a-problem/

 

Thanks.



#3 mchadima OFFLINE  

mchadima

    Member

  • Members
  • 23 posts
  • Local time: 07:21 AM

Posted 25 January 2018 - 08:13 PM

Server and two ffmpeg files are attached.  The fb54a file is time stamped 10:02 and the 1311 file is time stamped 9:55, and looking at the times in the files, I would suspect the first file (fb54a) will show the freezes since it starts at 9:55.  The other file starts at 9:48.

 

Thanks.

Attached Files



#4 mchadima OFFLINE  

mchadima

    Member

  • Members
  • 23 posts
  • Local time: 07:21 AM

Posted 27 January 2018 - 10:40 AM

More information:  I recorded live TV until I got some good examples of freezing.  That log is attached (854d...).  Good example of freezing at the end of the file.  Then played back and the freezing got MUCH worse, basically 15 seconds of replay, then 10 seconds of freeze, repeating.  Unwatchable.  That log is also attached (f4d97...stream is Today Show).

 

Didn't know if that would help identify what is going on.  I know nothing about video and am new to implementing Emby on my home network.  Everything else about Emby works great.

 

Thanks.

Attached Files



#5 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46398 posts
  • Local time: 08:21 AM

Posted 27 January 2018 - 11:03 AM

From the app end it just looks like the stream is not coming in quickly enough.  The player keeps pausing and re-starting to catch up.



#6 mchadima OFFLINE  

mchadima

    Member

  • Members
  • 23 posts
  • Local time: 07:21 AM

Posted 29 January 2018 - 11:38 AM

OK.  Is there a setting I should look at, or why would the feed from Emby provide a slow stream?  As I noted, the HDHomerun Android TV app playback is perfect.



#7 mchadima OFFLINE  

mchadima

    Member

  • Members
  • 23 posts
  • Local time: 07:21 AM

Posted 29 January 2018 - 11:39 AM

Perhaps something I should look at in the QNAP server?



#8 mchadima OFFLINE  

mchadima

    Member

  • Members
  • 23 posts
  • Local time: 07:21 AM

Posted 29 January 2018 - 01:51 PM

Another update.  I tested Emby Live TV on an iOS device hooked up through wifi on my LAN.  Playback for movies and music was clean.  Playback for Live TV displayed the same freezing as seen on Android TV.  



#9 mchadima OFFLINE  

mchadima

    Member

  • Members
  • 23 posts
  • Local time: 07:21 AM

Posted 29 January 2018 - 02:01 PM

Here is the ffmpeg log for the iOS Live TV playback.  Only consists of 3 minutes of playback, but there were 3 (>15 second) freezes during that time.

Attached Files



#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136081 posts
  • Local time: 08:21 AM

Posted 29 January 2018 - 02:39 PM

Here is the ffmpeg log for the iOS Live TV playback.  Only consists of 3 minutes of playback, but there were 3 (>15 second) freezes during that time.

 

It was just the one single ffmpeg log?



#11 mchadima OFFLINE  

mchadima

    Member

  • Members
  • 23 posts
  • Local time: 07:21 AM

Posted 29 January 2018 - 03:13 PM

No, there a many ffmpeg logs, but this was the log with the timestamp of when I was watching Live TV using iOS.



#12 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46398 posts
  • Local time: 08:21 AM

Posted 29 January 2018 - 09:27 PM

Here is the ffmpeg log for the iOS Live TV playback.  Only consists of 3 minutes of playback, but there were 3 (>15 second) freezes during that time.

 

This one is transcoding and the CPU is simply not able to keep up.  Only moving about 1/2 speed.



#13 mchadima OFFLINE  

mchadima

    Member

  • Members
  • 23 posts
  • Local time: 07:21 AM

Posted 30 January 2018 - 06:53 AM

OK, that at least helps to identify the problem.  Now, how to fix it.  Is the QNAP incapable of transcoding Live TV?  How can I test it to transcode something else?  A .mkv file?  Or can I "force" the HDHomerun to do the transcoding, since it seems to be capable when I watch directly from the app, bypassing Emby?  Sorry I don't know more about video.  And thanks for the help.



#14 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136081 posts
  • Local time: 08:21 AM

Posted 02 February 2018 - 03:28 AM

hi @mchadima, what model HDHomerun do you have?



#15 mchadima OFFLINE  

mchadima

    Member

  • Members
  • 23 posts
  • Local time: 07:21 AM

Posted 02 February 2018 - 11:50 AM

CONNECT DUO HDHR5-2US 2- Tuner

#16 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136081 posts
  • Local time: 08:21 AM

Posted 02 February 2018 - 12:26 PM

OK I don't believe this model has onboard transcoding, right? Therefore Emby Server will need to handle it.

 

Please also update to the latest version of Emby Server. Thanks.



#17 mchadima OFFLINE  

mchadima

    Member

  • Members
  • 23 posts
  • Local time: 07:21 AM

Posted 04 February 2018 - 12:02 PM

Upgraded the server.  New problem with LiveTV.  Now, the video will freeze, but audio will continue.  That hasn't happened before.  Seems to lock up the anroid tv client, forcing a restart. Sometimes able to ESC and restart from the Channel Guide. In the attached ffmpeg log, the entire stream locked up at the end (8:18) and couldn't recover. 

 

Also attaching server log.

 

More info:  this may be irrelevant, but the "spinning circle" when trying to load a channel appears to often freeze as well.  When it does, the next screen is the "Playback Error?" screen. Click NO and the spinning circle restarts, but is not able to make a connection to the channel.  After no progress for >a minute, ESC to get back to the channel guide.  Try again, same channel.  Same spinning circle freeze.  Click YES to Playback error, no system response.  Total lockup, force reboot of android tv.  That ffmpeg log is attached, too, as ffmpeg log 2-4 V2.

 

Also tested recording the same program "Sunday Morning".  Playback displays freezing about every 10 seconds, freeze for ~5 seconds, then resume.  That ffmpeg log is attached as ffmpeg log 2-4 V3.

 

Finally, you are correct, Luke.  This HDHomerun, like 3 of the 4 models sold in the US does not provide hardware transcoding.

Attached Files



#18 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136081 posts
  • Local time: 08:21 AM

Posted 04 February 2018 - 12:32 PM

@ebr can comment on the first two but in the v3 log that's because your transcoding was not happening fast enough.

#19 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46398 posts
  • Local time: 08:21 AM

Posted 04 February 2018 - 03:24 PM

but the "spinning circle" when trying to load a channel appears to often freeze as well.  When it does, the next screen is the "Playback Error?" screen. Click NO and the spinning circle restarts, but is not able to make a connection to the channel.  After no progress for >a minute, ESC to get back to the channel guide.  

 

Can you please do this and then follow the instructions for sending a log from the app?

 

Thanks.



#20 mchadima OFFLINE  

mchadima

    Member

  • Members
  • 23 posts
  • Local time: 07:21 AM

Posted 06 February 2018 - 06:53 AM

Log sent from Emby for Android TV app at 4:47 am, user name Mike, playback of recorded TV, program is CBS News Sunday Morning.  This is not the spinning circle error, rather the repeated freeze.  The spinning circle seems to have cleared up with a restart of all devices on the network, which is good.

 

Thanks.







Also tagged with one or more of these keywords: freeze, stutter, buffer, QNAP

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users