Jump to content

Subtitles not showing in video playback (Emby LG App)


calexandre
 Share

Recommended Posts

Emby for LG 1.07 has just been released. Stay tuned to the Emby blog for the release announcement. Please try it out. Thanks !

Link to comment
Share on other sites

andyblac644

Emby for LG 1.07 has just been released. Stay tuned to the Emby blog for the release announcement. Please try it out. Thanks !

 

 

for me I can't get Subtitle to go away, they constantly show even when GUI says none selected.

Link to comment
Share on other sites

I have just tested it. It is working fine for me. I've watched a some tv show episodes and waited for the next starts automatically... that was ok, the subtitle loaded was the right one. I also changed both subtitle and audio with the regular remote, not the magic one, the app didn't crash as it usually did before. I have to test it a little longer but, for this while, this is doing pretty good. Thank you, developers. I am already a big Emby fan.

Link to comment
Share on other sites

for me I can't get Subtitle to go away, they constantly show even when GUI says none selected.

 Can you please provide a mediainfo dump for a file so I can see the subtitle format.  Are the internal or external subs?  Thanks

Link to comment
Share on other sites

andyblac644

1.07 still too slow to be main app use, at least on my 55EF950V (WebOS 2 OLED), still take 15 seconds + to open details page.

 

 

 Can you please provide a mediainfo dump for a file so I can see the subtitle format.  Are the internal or external subs?  Thanks

 

sure here, internal subs.

MediaInfo.txt

Link to comment
Share on other sites

@@Luke, can you please look at andyblac644's MediaInfo in the last post.  Subs are Timed text/sbtl.  Are these supported?  Thanks

Link to comment
Share on other sites

andyblac644

@@Luke, can you please look at andyblac644's MediaInfo in the last post.  Subs are Timed text/sbtl.  Are these supported?  Thanks

 

 

they show just can't turn them off :(

Link to comment
Share on other sites

I've watching more medias after the update and I noticed one little annoying thing about subtitles which was not happening before: the break lines aren't working so well anymore. Take a look of this quote (Sorry, they are in brazilian portuguese):

 

- Por que não há patos?

- Sei lá, nunca teve patos.

 

There is a break line separating the speach of each character, a paragraph, which begins with the "-" sign. This is the line breaks from the .srt file, which is fine for a subtitle. After the update it is not working like that anymore. The lines are merged into one, the paragraph from the original .srt file is being ignored by the player. The break line happens naturaly at the end of the screen limit only. Check this picture taked from my TV.

 

5b0094b54619a_photo_20180519_180517.jpg

 

I've checked the .srt file, the subtitle is correct, the break line is in the righ place, but it not show like that on the screen. I know, that is a little thing, I really can live with that, but if is possible to fix in the future updates, it wold be so good for the users who need the subtitles.

 

Thank you, again, for listen to us.

Link to comment
Share on other sites

No embedded Subtitle Display (SRT) with all my 4K Movies  with v1.07 ... can you fix this finaly ? without this ... Emby App is useless without working Subtitles ..     

Link to comment
Share on other sites

No embedded Subtitle Display (SRT) with all my 4K Movies  with v1.07 ... can you fix this finaly ? without this ... Emby App is useless without working Subtitles ..     

 

I pretty much already know what my response is going to be, but first i need to confirm. Can you please attach the information requested in how to report a media playback issue? Thanks.

Link to comment
Share on other sites

Ok .. some News ...

 

Subtitles working with 1080p-Movies on TV with the App

Subtitles working with 4K-Movies on PC with Emby Theater

Subtitles not working with 4K-Movies on TV with the App

 

So there is no Problem with the Movies or Emby Server .... the Problem is the LG App cant handle Subtitles within 4K-Movies at the Moment.

Link to comment
Share on other sites

Ok .. some News ...

 

Subtitles working with 1080p-Movies on TV with the App

Subtitles working with 4K-Movies on PC with Emby Theater

Subtitles not working with 4K-Movies on TV with the App

 

So there is no Problem with the Movies or Emby Server .... the Problem is the LG App cant handle Subtitles within 4K-Movies at the Moment.

 

Actually it can. Can you please attach the information requested in how to report a media playback issue? Then I can go over your options with you. Thanks.

Link to comment
Share on other sites

Ok ... here is the emberserver.txt playing a non working Subtitle 4k-Movie ... i stopped the Movie after non working Subtitle Display. If you need more .. tell me what.

 

 

 

 

embyserver.txt

Link to comment
Share on other sites

If you put this url into a browser, what is the result?

http://192.168.0.180:8096/emby/Videos/96d55546912daa4ca04b88b9f6a88c05/96d55546912daa4ca04b88b9f6a88c05/Subtitles/3/0/Stream.vtt
Link to comment
Share on other sites

 

If you put this url into a browser, what is the result?

http://192.168.0.180:8096/emby/Videos/96d55546912daa4ca04b88b9f6a88c05/96d55546912daa4ca04b88b9f6a88c05/Subtitles/3/0/Stream.vtt

 

Only Display "WEBVTT"

Link to comment
Share on other sites

These are embedded subtitles? Can you provide a sample video for testing? Thanks.

Link to comment
Share on other sites

 

I've watching more medias after the update and I noticed one little annoying thing about subtitles which was not happening before: the break lines aren't working so well anymore. Take a look of this quote (Sorry, they are in brazilian portuguese):
 
- Por que não há patos?
- Sei lá, nunca teve patos.
 
There is a break line separating the speach of each character, a paragraph, which begins with the "-" sign. This is the line breaks from the .srt file, which is fine for a subtitle. After the update it is not working like that anymore. The lines are merged into one, the paragraph from the original .srt file is being ignored by the player. The break line happens naturaly at the end of the screen limit only. Check this picture taked from my TV.
 
5b0094b54619a_photo_20180519_180517.jpg
 
I've checked the .srt file, the subtitle is correct, the break line is in the righ place, but it not show like that on the screen. I know, that is a little thing, I really can live with that, but if is possible to fix in the future updates, it wold be so good for the users who need the subtitles.
 
Thank you, again, for listen to us.

 

 

Hi, developers. I'm just passing by to remember this issue. I'd appreciate if you could take a look of this. I know, this is a minor issue, but it could be good to know that it'll be fixed in the next release. Thank you.

Link to comment
Share on other sites

Yes ... Embedded Subtitles ... MediaInfo attached

 

Well no i'm wondering if you can supply a sample video as this looks server related if the subtitles are empty.

Link to comment
Share on other sites

Hi, developers. I'm just passing by to remember this issue. I'd appreciate if you could take a look of this. I know, this is a minor issue, but it could be good to know that it'll be fixed in the next release. Thank you.

 

Yes we'll look at it, thanks.

Link to comment
Share on other sites

Well no i'm wondering if you can supply a sample video as this looks server related if the subtitles are empty.

... as i told ... same Movie showing Subs on PC with Emby Theater ... on LG App -> no Subs ... @@Luke send you a PM

Link to comment
Share on other sites

... as i told ... same Movie showing Subs on PC with Emby Theater ... on LG App -> no Subs ... @@Luke send you a PM

 

because Emby Theater doesn't have to rely on the server to display the subs. If you try in the web app, you should see the same issue.

Link to comment
Share on other sites

I don't really trust that link you sent. Can you cut a small sample of the file using mkvtoolnix?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...