Jump to content

Emby music over bluetooth


sk1deep
 Share

Recommended Posts

  • 2 weeks later...
bernado99

I'll do another round of bluetooth testing, thanks.

To be honest Luke I have a feeling it's something peculiar about my phone or else many others here would be reporting it, the result is extreme.

The problem is my phone is a Honor 5 which uses a (horrible) Huawei skinned version of Android, I run it with Nova launcher to mitigate that but of course that's only a cosmetic solution and the Huawei EMUI system is still running.

 

Unless you're unlucky enough to have a Huawei phone this is something you may have trouble replicating.!

Link to comment
Share on other sites

flowlee

I can replicate the problem too, and in my case it's definitely a problem with the phone. I use a Vernee Apollo Lite and the playback is as described.

With any other Android device I was able to test there's no problem with bluetooth audio.

Link to comment
Share on other sites

bernado99

I can replicate the problem too, and in my case it's definitely a problem with the phone. I use a Vernee Apollo Lite and the playback is as described.

With any other Android device I was able to test there's no problem with bluetooth audio.

Comparing the specs between our two phones I can't really see any common denominator other than Bluetooth 4.1, which can't be anything significant I would have thought.

 

Good to know I'm not alone though.

Link to comment
Share on other sites

Qriz75

I can report that the beta fixed the choppy playback for me :) 

It also fixed an unrelated issue where the playback stopped after every track (only happened on certain albums)

Android 6.0 on an LGMS631 

Server 3.3.0

 

the only thing that is a problem now:

I can't seem to jump to a spot in the track by tapping the progress bar. Not a big deal for music playback, but if you have an 8hr audiobook and have to find your spot this is not going to be fun. 

Link to comment
Share on other sites

Qriz75

@@flowlee

@@bernado99

 

When this happens, what kind of music files are you playing?

 

any playback of mp3 files ... I checked it on music as well as audiobooks(library doesn't show up in the beta app). I created a playlist and behaviour is the same.

Link to comment
Share on other sites

flowlee

For me it's also mp3 files. And the result is the same regardless of whether the file is synced or streamed.

 

I can report that the beta fixed the choppy playback for me :)

It also fixed an unrelated issue where the playback stopped after every track (only happened on certain albums)

Android 6.0 on an LGMS631 

Server 3.3.0

 

the only thing that is a problem now:

I can't seem to jump to a spot in the track by tapping the progress bar. Not a big deal for music playback, but if you have an 8hr audiobook and have to find your spot this is not going to be fun. 

 

What version are you using?

Link to comment
Share on other sites

Qriz75

For me it's also mp3 files. And the result is the same regardless of whether the file is synced or streamed.

 

 

What version are you using?

 

the beta app is 1.5.56g

Link to comment
Share on other sites

Qriz75

so Emby for Android(beta now) is choppy again :( ... generally sluggish... Emby TV performs great but isn't meant to be displayed on a phone.. but I rather deal with that than with choppy music. it isn't as noticeable on Audiobooks, so I'll use Emby for Android for that and have the ability to tap on the progress bar. 

will try any new versions that come out and report back :)

Link to comment
Share on other sites

bernado99

@@flowlee

@@bernado99

 

When this happens, what kind of music files are you playing?

Just tried again with the latest release and the odd slow down effect has now gone so hurrah!

Trouble is music playback is now choppy and equally unlistenable so boo!

 

Tried this on mp3 and wav files with the same result.

Link to comment
Share on other sites

bernado99

@@flowlee

@@bernado99

 

When this happens, what kind of music files are you playing?

Just requoting rather than editing my previous post to raise another flag in case you're monitoring Luke, but a very happy update to report.

 

I factory reset my phone which trigured a system upgrade to Android 7 (EMUI 5) and everything's now good so happy days.

We'll never know if it was the reset or system upgrade that cured it but all is well, it might be worth others who are affected trying a factory reset if they can stomach it.

 

I need to put back the apps I was running on the phone so will update here if I identify any resulting problems.

 

Thanks

Link to comment
Share on other sites

flowlee

Just tried again with the latest release and the odd slow down effect has now gone so hurrah!

Trouble is music playback is now choppy and equally unlistenable so boo!

 

Are you using the beta again? The results you are describing sound like the behavior of the stable release.

 

I factory reset my phone which trigured a system upgrade to Android 7 (EMUI 5) and everything's now good so happy days.

We'll never know if it was the reset or system upgrade that cured it but all is well, it might be worth others who are affected trying a factory reset if they can stomach it.

 

I can also confirm that on my Android 7 phone everything is working just fine, so that could be something to look at.

Link to comment
Share on other sites

bernado99

Are you using the beta again? The results you are describing sound like the behavior of the stable release.

 

 

I can also confirm that on my Android 7 phone everything is working just fine, so that could be something to look at.

 

This was with the stable release (non-beta) as you say.

I've just put the 'stable' release on my partner's phone (which is the same as mine) as an experiment though it's not running the same apps as mine was.

 

I seem to recall she had to reset it recently though it's still on Android 6, the audio playback issues are problematic in exactly the same way as it was on my phone pre o/s upgrade so maybe it is something connected to Android 6.

 

Thanks

Link to comment
Share on other sites

  • 4 months later...
wedgekc

I am having a problem with this again after updating to 3.0.00.  I get stuttering every 5-10 seconds using my Bluetooth headset, after plugging in wired headphones music plays normally.

 

Reverting back to 2.9.92 also fixes the Bluetooth problem and music plays normally.

 

Xiaomi Mi Max 2, Android 7.1.1

 

Thanks

Link to comment
Share on other sites

  • 3 weeks later...

Great through the browser on phone, weird and choppy through the app on phone.

 

What device are you on?

Link to comment
Share on other sites

sk1deep

What device are you on?

 

When I started this topic I was on an LG k20 and the issue followed me to an LG stylo 3 and the problem was way worse on both phones at that time. The song would start out fine and progress to being unlistenable with extreme choppiness and distortion. An update fixed the problem and I hadn't tried it since then. Just renewed my gym membership and of course wanted to use my favorite app to listen to my tracks on my home pc at the gym and I see the issue is back just nowhere near as bad as it was before. Noticeable stutters but nothing near as bad as the original problem. Tried it over 4g and wifi to see if that was the issue still frequent skips and as I said it only occurs through the app not through the browser. I don't really lose any features using it through the browser on my phone so it's not the worst thing in the world but of course the app is smoother. Thanks for all the hard work!

Edited by sk1deep
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...