Jump to content

Emby music over bluetooth


sk1deep
 Share

Recommended Posts

I have a weird problem with music on the emby android app. It plays fine through my phone speaker but when I try to play through a bluetooth headset I get extremely choppy playback. The only way I get it to work is to disconnect my headset, start the song then connect the headset. I have to do that every time I want to listen to a song. Tried on 2 different headsets. Video works fine over bluetooth.

Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...
  • 2 weeks later...

Is this still an issue? i have not been able to reproduce it. Thanks !

 

Luke, are you still having trouble diagnosing this?  Happy to help if I can.

Link to comment
Share on other sites

We are looking into it and are in process of replacing both the audio and video players with something brand new, so we'll re-evaluate this as part of that effort. Thanks !

Link to comment
Share on other sites

As a test, can you please try out this version?

https://emby.media/community/index.php?/topic/53753-emby-for-android-libmpv-testing/

 

Thanks !

 

I download the apk, run it and get a dialog to Cancel, Market or install.  I choose Install and it errors with:

 

"There was a problem while parsing the package."

 

I've re-downloaded a couple of times.

 

Samsung Galaxy S6, Android 7, kernel 3.10.61-10958180

Link to comment
Share on other sites

  • 4 weeks later...

Add me to the list of people with this problem. Strangely enough it doesn't do this with a tablet with the same OS(android 7) but has done it across 2 phones I've used. Noticed the other person's phone is a samsung and both mine were LG if that helps.

Link to comment
Share on other sites

  • 2 weeks later...
ghostquito

I just tested this in my car this morning, working perfectly.

 

The only thing i would say is when hitting the track back when a song is playing usually starts the song over. In emby case it actually goes back 1 track. Not sure if that's even a issue, could live with it either way.. Thanks!!!!

Link to comment
Share on other sites

ghostquito

From my experience CD players and Mp3 players start the same track over again if you hit back once, you have to hit back twice to go back a track. Again i don't really care either way, was just so use to having to hit back twice it messed me up a little bit until i figure out what was going on. 

Link to comment
Share on other sites

From my experience CD players and Mp3 players start the same track over again if you hit back once, you have to hit back twice to go back a track. Again i don't really care either way, was just so use to having to hit back twice it messed me up a little bit until i figure out what was going on. 

 

The TV apps do this type of thing.  If you are more than about 10 seconds into the track and hit back, it returns to the beginning of that track, otherwise, it goes to the previous one - the net effect being that two backs take you to the previous track if you are into the current one. 

 

I took this logic from the aforementioned old box behavior.

Link to comment
Share on other sites

  • 3 weeks later...
bernado99

The beta app didn't fix this Bluetooth audio issue for me (using Honor 5C phone).

As mentioned by others works fine in browser or Kodi with Emby addon for me also, It doesn't make a difference either if I download a track and play it offline from the Android app.

Any other suggestions to help fix this?

 

There is no log in the app for today's date though I've been testing this out, unless the beta app stores logs in a different location to the usual?

 

Thanks

Edited by bernado99
Link to comment
Share on other sites

Not sure what you're referring to but if you're referring to a delay then no that is something we haven't looked at adding yet.

Link to comment
Share on other sites

bernado99

No not a delay issue, the app for me just can't play music over Bluetooth without it totally falling apart.

It starts just fine, then gets slow and stuttery until it can't play anymore.

 

As I say this behaviour only happens when using the app, either streaming music from the server or playing offline downloaded files.

 

I can play video files using the app and send the audio to a bluetooth device just fine oddly.

 

I've tried 3 different Bluetooth audio devices with exactly the same result.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...