Jump to content


Photo

Actor image gone after updating

emby actor image web client

  • Please log in to reply
3 replies to this topic

#1 Schtief OFFLINE  

Schtief

    Newbie

  • Members
  • 5 posts
  • Local time: 03:46 AM

Posted 27 August 2017 - 05:49 AM

Hey guys,

 

when I update an actor image in the web client of Emby Server (3.2.26) it gets removed instantly. Reloading the metadata doesn't bring them back. This just happens to my anime section. Updating my movie or tv show actors works fine.

 

Please help.

 

EDIT: I just found out that this just happens to some of the japanese actors. Still don't know why.


Edited by Schtief, 27 August 2017 - 01:34 PM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135803 posts
  • Local time: 09:46 PM

Posted 27 August 2017 - 10:26 PM

Hi there, can you please attach the emby server log? you can learn how to do that here:

https://emby.media/c...port-a-problem/

 

Thanks !



#3 MrAudio OFFLINE  

MrAudio

    Member

  • Members
  • 16 posts
  • Local time: 05:46 PM
  • LocationCalifornia, USA

Posted 28 August 2017 - 01:21 AM

This could be related to the issue where if the actor doesn't have an entry in The Movie DB, when that actor is edited in any way, Emby tries to match it to a tMDb actor, and often links to the wrong one, and changes the actor's name in Emby to match whatever actor was found. This "breaks" the database link and the actor disappears from the movie entry. Then, you have to do a name search and hope you can dig the name out of the database (which is now a guessing game because you have no idea what the name was changed to!).

 

IMO, Emby should only link to a tMBd profile if an exact name match is found, and otherwise should either do nothing or prompt the user to pick the correct entry (ideally, the Emby admin could choose between these options with a global setting). I feel it should *never* change the name and thus break the linked entry. This is especially problematic when you have multiple different people with the same exact name, which is common with foreign movies that either dupe American actor names or use first-name-only names.


Edited by MrAudio, 28 August 2017 - 01:22 AM.

  • pĆ¼nktchen likes this

#4 Schtief OFFLINE  

Schtief

    Newbie

  • Members
  • 5 posts
  • Local time: 03:46 AM

Posted 28 August 2017 - 07:08 AM

This could be related to the issue where if the actor doesn't have an entry in The Movie DB, when that actor is edited in any way, Emby tries to match it to a tMDb actor, and often links to the wrong one, and changes the actor's name in Emby to match whatever actor was found. This "breaks" the database link and the actor disappears from the movie entry. Then, you have to do a name search and hope you can dig the name out of the database (which is now a guessing game because you have no idea what the name was changed to!).

 

That sounds really funny and actually it's a bit annoying to the ones that spend a lot of time maintaining their media library. I just tested the behavior with debug logging on and tried to reproduce the problem. Finally the actors of the anime "blood lad" where removed after updating some pictures. The ones affected just had one suggestion from The Movie DB. After selecting and turning back the actor was missing. The log file is attached below.

 

How can I bring them back? Some of my anime don't have any actor anymore. The sensible data (poster, background etc.) of my shows are locked. When I select update -> reload metadata nothing happens. I tried this with different options. I don't want to refresh the whole anime with every data replaced. Any suggestions?

 

Thanks in advance!

 

EDIT: Any ideas so far?

Attached Files


Edited by Schtief, 02 September 2017 - 08:22 AM.






Also tagged with one or more of these keywords: emby, actor, image, web client

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users