Jump to content


Photo

[SUPPORT THREAD] Embuary - A Emby Kodi Skin


  • Please log in to reply
1327 replies to this topic

#1281 ms78mama OFFLINE  

ms78mama

    Advanced Member

  • Members
  • 63 posts
  • Local time: 02:50 PM

Posted 21 June 2019 - 03:15 AM

That's not a skin issue, your database seems to be messed up. Please try to repair your DB via the Emby addon.

Could you please provide the proceedure?



#1282 sualfred ONLINE  

sualfred

    The Embuary guy

  • Developers
  • 1840 posts
  • Local time: 01:50 PM
  • LocationGermany

Posted 21 June 2019 - 03:17 AM

Addons -> Emby -> Manage Libraries -> Repair libraries -> Select "all" or just the databases that are messed up



#1283 ms78mama OFFLINE  

ms78mama

    Advanced Member

  • Members
  • 63 posts
  • Local time: 02:50 PM

Posted 21 June 2019 - 03:20 AM

Addons -> Emby -> Manage Libraries -> Repair libraries -> Select "all" or just the databases that are messed up

Thanks so much..However i am using Embycon and i dont see the option to fix the libraries


Edited by ms78mama, 21 June 2019 - 05:31 AM.


#1284 TeamB OFFLINE  

TeamB

    Advanced Member

  • Developers
  • 5638 posts
  • Local time: 09:50 PM

Posted 21 June 2019 - 05:39 AM

@ms78mama

Thanks so much..However i am using Embycon and i dont see the option to fix the libraries


There was a recent change in the Beta Emby Server 4.2 that required a few changes to EmbyCon

https://emby.media/c...ptional-fields/

I have released a new beta of EmbyCon that should restore any missing fields.

Please try the latest EmbyCon beta.
  • sualfred likes this

#1285 skank OFFLINE  

skank

    Advanced Member

  • Members
  • 331 posts
  • Local time: 01:50 PM

Posted 22 June 2019 - 10:01 AM

hi

first of all

amazing skin

huge amount of possibilities

my congrats.

 

I got however 2 things to ask

- how do i install different genre icons so it works in embruary kodi skin , i downloaded here https://github.com/S...reicons.horizon

 

- second, in embruary on kodi, my new movies widget show some movies double, any idea?

 

thx



#1286 quack OFFLINE  

quack

    Newbie

  • Members
  • 5 posts
  • Local time: 09:50 PM

Posted 27 June 2019 - 03:40 AM

Hi,

 

Thanks for the great skin.  I have tried many but they seem not to suit me; this one does.

 

Recently I was mucking around trying to work out why the Live TV and PVR selection screens only display the channel icons and not images relating to the show.  'Something' happened and I have ended up with what appears to be some sort of yellow text debug information superimposed on the skin at the left and right sides of the screen.  This is shown in the first screenshot (screeenshot004) I have attached.  Changing to another skin makes this disappear, but reverting to Embuary brings the debug overlay back.  Rebooting the computer (Raspberry Pi 3B, running latest OSMC and Leia) or reloading the skin has no effect wrt this debug overlay.  It stays no matter what media I play.  I am running the latest Embuary (18.7.8) available from the Kodi "Get More..." skins selection.

 

Clearly I have gotten into a state where this is unwatchable.

 

What have I done?  How can I undo what I have done?

 

In the second screenshot (screenshot001) only channel icons are displayed, except for those which are automatically placed in a 'folder structure', but those within have channel icons when opening the 'folder'.  If I open the context menu for one of these recordings and choose "Artwork options" and then "Manually configure artwork" the list shows artwork as being available, but it is never displayed.  However, on some recordings the only available artwork is the channel icon under the 'thumbnail'.

 

In screenshot004 one can see that I have disabled all EPG thumbnail options, though it make no difference either way.

 

Is there something that I am missing?

 

Thank you.

Attached Files



#1287 sualfred ONLINE  

sualfred

    The Embuary guy

  • Developers
  • 1840 posts
  • Local time: 01:50 PM
  • LocationGermany

Posted 27 June 2019 - 04:29 AM

Sidebar -> "Debug" will toggle the setting for it

 

Kodi doesn't support thumbs that are placed next to recordings. The used backend has to provide those and fill it in a info value.

Folders will have no thumbnail at all.

 

Edit:

TV Headenend (4.3<) uses the EPG thumbnail (if available). 

 

Edit2:

You can disable the recording groupings in Kodi by going to the filter options in the header while you are in the recordings window. There is an option called something like "folder structure"


Edited by sualfred, 27 June 2019 - 04:38 AM.


#1288 quack OFFLINE  

quack

    Newbie

  • Members
  • 5 posts
  • Local time: 09:50 PM

Posted 27 June 2019 - 07:54 AM

 

Sidebar -> "Debug" will toggle the setting for it

 

That's embarrassing.  I must have pressed that by accident at some stage.  Lesson learned.

 

 

Kodi doesn't support thumbs that are placed next to recordings. The used backend has to provide those and fill it in a info value.

 

That's weird because Kodi seems to know about and has images for the thumbnail, poster, fanart, etc. which are associated with the recordings.  So, while Kodi downloads these it doesn't use them?  My backend uses enigma.

 

 

 

You can disable the recording groupings

 

No need; I knew about that and am happy with the organisation that they provide.

 

Thanks for your help.



#1289 sualfred ONLINE  

sualfred

    The Embuary guy

  • Developers
  • 1840 posts
  • Local time: 01:50 PM
  • LocationGermany

Posted 27 June 2019 - 08:52 AM

Do me a favour and make me a screenshot: Enable the debug overlay again and focus one of the recording items with missing cover. 


Edited by sualfred, 27 June 2019 - 08:52 AM.


#1290 quack OFFLINE  

quack

    Newbie

  • Members
  • 5 posts
  • Local time: 09:50 PM

Posted 27 June 2019 - 08:09 PM

 

Do me a favour and make me a screenshot: Enable the debug overlay again and focus one of the recording items with missing cover.

 

screenshot005 shows an episode of The Blacklist highlighted with the debug overlay active.

 

screenshot006 shows the artwork known to Kodi when I activate the context menu for that episode and select "Artwork options" followed by "Manual configure artwork".  As you can see, Kodi knows about artwork for The Blacklist.  I notice that none of these are exposed to the debug overlay which only identifies "actual icon" as being the channel icon.

 

For completeness I include the virtual folder (group) created for The Blacklist episodes being highlighted as well; shown in screenshot007.  Similar to each episode, the artwork exists through the "Artwork options|Manual configure artwork" but is not exposed to the debug overlay.

Attached Files



#1291 sualfred ONLINE  

sualfred

    The Embuary guy

  • Developers
  • 1840 posts
  • Local time: 01:50 PM
  • LocationGermany

Posted 28 June 2019 - 12:06 AM

i just wanted to be sure that Enigma doesn't act differently. There is nothing I can show. Take a look at the upper left section. No artwork values except DefaultFolder. 



#1292 Polyzp_emby OFFLINE  

Polyzp_emby

    Advanced Member

  • Members
  • 61 posts
  • Local time: 06:50 AM

Posted 28 June 2019 - 01:07 PM

Hi again!

I noticed when using Embuary Skin Leia, the kodi pvr not behaving as it should be. The video osd during pvr playback will often never disappear. Instead it indefinitely stays visible. With other channels, it will disappear after 5 seconds. My goal is to not have this video osd popup after a channel is switched to. -- the video osd which remains opened can be seen attached --


This occurs especially for channels without associated epg information. I tested this with the default kodi skin, and the issue does not occur. Additionally, I tested this on two devices and the same issue occurs. (N2 coreelec / kodi 18.3 , android mobile kodi 18.2 -- Channel tested CBC via TVheadend (issue occurs with many more channels) --

Although it would be nice to have this osd dissapear consistently after switching channels (for all channels) , ultimately I would like to be able to disable this osd all together. As it stands, I cannot seem to be able to do that at the moment while using Embuary skin.

Thank you for looking into this!

Attached Files



#1293 sualfred ONLINE  

sualfred

    The Embuary guy

  • Developers
  • 1840 posts
  • Local time: 01:50 PM
  • LocationGermany

Posted 28 June 2019 - 05:09 PM

@Polyzp_emby

 

Thanks. Fixed with https://github.com/s...b9888743cb6099f

 

I also removed the forced osd if the current player time is under 4s. But I won't add options to hide it completely.

 

Please let me know if this fixed it on your end.



#1294 Polyzp_emby OFFLINE  

Polyzp_emby

    Advanced Member

  • Members
  • 61 posts
  • Local time: 06:50 AM

Posted 29 June 2019 - 12:23 PM

Thanks for clearing up the osd issue! :) your fix works like a charm! Any reason in particular why you wont allow a toggle to disallow the mini-osd from popping up after channel switches?

Thanks! :)

#1295 sualfred ONLINE  

sualfred

    The Embuary guy

  • Developers
  • 1840 posts
  • Local time: 01:50 PM
  • LocationGermany

Posted 29 June 2019 - 01:05 PM

Mostly because I follow my own rules:

 

-> You can't bless everyone, so don't follow requests that are based on personal preference

-> Don't overload a skin with "useless" options to keep it as much as simple as possible

 

And sometimes it's not as simple as you might think. 


Edited by sualfred, 29 June 2019 - 01:08 PM.

  • hoppel118 and Seger like this

#1296 Polyzp_emby OFFLINE  

Polyzp_emby

    Advanced Member

  • Members
  • 61 posts
  • Local time: 06:50 AM

Posted 30 June 2019 - 06:21 PM

Makes sense! Well thank you for fixing that issue with the pvr, it made a huge difference!

I was wondering also,

Is there any way to scale the UI for smaller monitors/tvs ? (ie. To have a setting to make things appear larger on screen)

Im not sure if this would be outside the scope of the skin itself and more a kodi limitation.

Again,

Thank you for your help
  • hoppel118 likes this

#1297 sualfred ONLINE  

sualfred

    The Embuary guy

  • Developers
  • 1840 posts
  • Local time: 01:50 PM
  • LocationGermany

Posted 01 July 2019 - 02:46 AM

Not really. The Kodi skinning engine is not flexible enough for those things.



#1298 Polyzp_emby OFFLINE  

Polyzp_emby

    Advanced Member

  • Members
  • 61 posts
  • Local time: 06:50 AM

Posted 02 July 2019 - 06:50 PM

Thanks for the insight.

I have noticed the search function is no longer working, as it results in nothing on my end when clicked. It had been working two days ago when I had been messing around with the skin.

I get an error:

Skin has invalid include: search_action

In my log

If you need me to send a full log I can. Im on kodi 18.3.

Thanks saulfred

#1299 sualfred ONLINE  

sualfred

    The Embuary guy

  • Developers
  • 1840 posts
  • Local time: 01:50 PM
  • LocationGermany

Posted 03 July 2019 - 12:02 AM

Thx, already has been fixed and the update is available since yesterday on the repo.



#1300 bowe OFFLINE  

bowe

    Member

  • Members
  • 16 posts
  • Local time: 01:50 PM

Posted 05 July 2019 - 12:56 PM

love this skin, 

One feature request tho. Is it possible to remove the option "reboot to nand" in the power menu?  






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users