Jump to content

Emby Transcoding 4K HEVC


justinglock40
 Share

Recommended Posts

justinglock40

Can't get 4K UHD to playback on Xbox One S. Sound plays in the background but the screen is green the entire time. It keeps transcoding. Any ideas why?

Log.txt

Edited by justinglock40
Link to comment
Share on other sites

Hi there, we respond to every user issue. We thank you for your patience while waiting for a response to this. Thanks !

Link to comment
Share on other sites

1ntroduc3

I have this issue also. Bookmarking this one.

Tried dlna, media-player app from xbox one

Chromecast function in smartphone app and xbox one app, but no 4k

Edited by martheijnen
Link to comment
Share on other sites

@@justinglock40 would you mind testing again and providing an Emby server log? The first log you posted was an ffmpeg log, which was helpful. I would like to see something in the regular server log. Thanks !

Link to comment
Share on other sites

snake98

Yes we are looking into it, thanks.

 

I'm having the same problem but with firefox and Edge.  I"ve attached my logs also.

Link to comment
Share on other sites

@@snake98 you're not having any problem because browsers do not support hevc, therefore transcoding is needed.

Link to comment
Share on other sites

snake98

Should I open a new Thread.  I can't play hevc through firefox or edge.  My understanding is that it emby should trans-code it if the browser doesn't support it. I can play h.264 just fine.

Edited by snake98
Link to comment
Share on other sites

  • 1 month later...

Apologies for the delay. We are waiting on a Microsoft defect to be resolved before we can enable this. Thanks.

Link to comment
Share on other sites

  • 5 months later...

Apologies for the delay. We are waiting on a Microsoft defect to be resolved before we can enable this. Thanks.

 

 

It's Jan 2018, and I'm guessing Microsoft never resolved this "defect"?  I'm on a 4k Xbox One X and can't get 4K.

Link to comment
Share on other sites

  • 3 weeks later...

Still Green screen IF audio is:

 

Format                      : TrueHD
Format profile              : TrueHD+Atmos / TrueHD
Codec ID                    : A_TRUEHD
 
 
OR
 
Format/Info                 : Digital Theater Systems
Format profile              : MA / Core
Codec ID                    : A_DTS
 
Also 4k HDR doesn't work.
Link to comment
Share on other sites

@@Dazog can you please describe what "doesn't work" means? thanks !

 

The video is playing at 4k in SDR eventhough the video has HDR metadata.

 

It's ignoring this:

 

Color range                 : Limited
Color primaries             : BT.2020
Transfer characteristics    : PQ
Matrix coefficients         : BT.2020 non-constant
Link to comment
Share on other sites

 

The video is playing at 4k in SDR eventhough the video has HDR metadata.

 

It's ignoring this:

 

Color range                 : Limited
Color primaries             : BT.2020
Transfer characteristics    : PQ
Matrix coefficients         : BT.2020 non-constant

 

 

Can we see the emby server log? you can learn how to locate that here:

https://emby.media/community/index.php?/topic/739-how-to-report-a-problem/

 

Thanks.

Link to comment
Share on other sites

  • 4 weeks later...

I am also having this same issue when trying to play anything with audio 'TRUEHD 7.1' basically any content with Atmos. On the Xbox One X I have the green screen mentioned. On my Chromecast Ultra it plays fine video wise, but I can't get Dolby Atmos to work.

Link to comment
Share on other sites

I am also having this same issue when trying to play anything with audio 'TRUEHD 7.1' basically any content with Atmos. On the Xbox One X I have the green screen mentioned. On my Chromecast Ultra it plays fine video wise, but I can't get Dolby Atmos to work.

 

What do you mean can't get Atmos to work? It should be converting the audio as Chromecast does not support that.

Link to comment
Share on other sites

What do you mean can't get Atmos to work? It should be converting the audio as Chromecast does not support that.

Basically I can get 5.1 to play just fine, but switching to 7.1 TRUEHD, my receiver decodes this as stereo. Through my testing it seems like the issue is related to Emby as direct playing the file from a PC, I get my receiver to recognize Atmos just fine. I'm not 100% certain that Chromecast Ultra supports Atmos, but am pretty sure it does based on my research. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...