Jump to content
justinglock40

Emby Transcoding 4K HEVC

Recommended Posts

justinglock40

Can't get 4K UHD to playback on Xbox One S. Sound plays in the background but the screen is green the entire time. It keeps transcoding. Any ideas why?

Log.txt

Edited by justinglock40

Share this post


Link to post
Share on other sites
justinglock40

bump

Share this post


Link to post
Share on other sites
Luke

Hi there, we respond to every user issue. We thank you for your patience while waiting for a response to this. Thanks !

Share this post


Link to post
Share on other sites
Luke

hi @@justinglock40, yes i can confirm that hevc is transcoding. we'll review this for an update later this week. thanks.

Share this post


Link to post
Share on other sites
1ntroduc3

I have this issue also. Bookmarking this one.

Tried dlna, media-player app from xbox one

Chromecast function in smartphone app and xbox one app, but no 4k

Edited by martheijnen

Share this post


Link to post
Share on other sites
justinglock40

Any word on this yet?

Share this post


Link to post
Share on other sites
Luke

@@justinglock40 would you mind testing again and providing an Emby server log? The first log you posted was an ffmpeg log, which was helpful. I would like to see something in the regular server log. Thanks !

Share this post


Link to post
Share on other sites
justinglock40

Were you able to determine anything with those logs?

Share this post


Link to post
Share on other sites
Luke

Yes we are looking into it, thanks.

  • Like 1

Share this post


Link to post
Share on other sites
snake98

Yes we are looking into it, thanks.

 

I'm having the same problem but with firefox and Edge.  I"ve attached my logs also.

Share this post


Link to post
Share on other sites
Luke

@@snake98 you're not having any problem because browsers do not support hevc, therefore transcoding is needed.

Share this post


Link to post
Share on other sites
snake98

Should I open a new Thread.  I can't play hevc through firefox or edge.  My understanding is that it emby should trans-code it if the browser doesn't support it. I can play h.264 just fine.

Edited by snake98

Share this post


Link to post
Share on other sites
Luke

Yes you should, thanks.

Share this post


Link to post
Share on other sites
justinglock40

Any progress?

Share this post


Link to post
Share on other sites
Luke

Apologies for the delay. We are waiting on a Microsoft defect to be resolved before we can enable this. Thanks.

Share this post


Link to post
Share on other sites
weeks

Apologies for the delay. We are waiting on a Microsoft defect to be resolved before we can enable this. Thanks.

 

 

It's Jan 2018, and I'm guessing Microsoft never resolved this "defect"?  I'm on a 4k Xbox One X and can't get 4K.

Share this post


Link to post
Share on other sites
Luke

No, you should be able to play 4k now on Xbox One X. Can we see an example? thanks !

Share this post


Link to post
Share on other sites
Dazog

Still Green screen IF audio is:

 

Format                      : TrueHD
Format profile              : TrueHD+Atmos / TrueHD
Codec ID                    : A_TRUEHD
 
 
OR
 
Format/Info                 : Digital Theater Systems
Format profile              : MA / Core
Codec ID                    : A_DTS
 
Also 4k HDR doesn't work.

Share this post


Link to post
Share on other sites
Luke

@@Dazog can you please describe what "doesn't work" means? thanks !

Share this post


Link to post
Share on other sites
Dazog

@@Dazog can you please describe what "doesn't work" means? thanks !

 

The video is playing at 4k in SDR eventhough the video has HDR metadata.

 

It's ignoring this:

 

Color range                 : Limited
Color primaries             : BT.2020
Transfer characteristics    : PQ
Matrix coefficients         : BT.2020 non-constant

Share this post


Link to post
Share on other sites
Luke

 

The video is playing at 4k in SDR eventhough the video has HDR metadata.

 

It's ignoring this:

 

Color range                 : Limited
Color primaries             : BT.2020
Transfer characteristics    : PQ
Matrix coefficients         : BT.2020 non-constant

 

 

Can we see the emby server log? you can learn how to locate that here:

https://emby.media/community/index.php?/topic/739-how-to-report-a-problem/

 

Thanks.

Share this post


Link to post
Share on other sites
PaulW08

I am also having this same issue when trying to play anything with audio 'TRUEHD 7.1' basically any content with Atmos. On the Xbox One X I have the green screen mentioned. On my Chromecast Ultra it plays fine video wise, but I can't get Dolby Atmos to work.

Share this post


Link to post
Share on other sites
Luke

I am also having this same issue when trying to play anything with audio 'TRUEHD 7.1' basically any content with Atmos. On the Xbox One X I have the green screen mentioned. On my Chromecast Ultra it plays fine video wise, but I can't get Dolby Atmos to work.

 

What do you mean can't get Atmos to work? It should be converting the audio as Chromecast does not support that.

Share this post


Link to post
Share on other sites
PaulW08

What do you mean can't get Atmos to work? It should be converting the audio as Chromecast does not support that.

Basically I can get 5.1 to play just fine, but switching to 7.1 TRUEHD, my receiver decodes this as stereo. Through my testing it seems like the issue is related to Emby as direct playing the file from a PC, I get my receiver to recognize Atmos just fine. I'm not 100% certain that Chromecast Ultra supports Atmos, but am pretty sure it does based on my research. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...