Jump to content


Photo

916+ / Nvidia Shield TV Transcoding

transcoding Synology nvidia shield

Best Answer ebr , 24 April 2017 - 08:31 AM

Or, if it is already on Auto, try setting it to at least 15Mb (the item you are playing is about 12).

Go to the full post


  • Please log in to reply
6 replies to this topic

#1 MarcSPNW OFFLINE  

MarcSPNW

    Newbie

  • Members
  • 3 posts
  • Local time: 09:56 AM

Posted 23 April 2017 - 11:13 PM

Question for folks, and while I've run my own server/library for quite a few years now, I'm not entirely sure the best language to use with the community, so please bear with me. :) I did some searching for relevant threads, but I'm not entirely sure what to keyword search on, truth be told.

I just picked up a Synology 916+, and I'm running the Emby app as a server on it. Running great. Question is about transcoding support.

 

I went with the shield because it can stream some of the widest selection of video and audio codecs. But when I was running Moana for my son, I noticed the 916+ CPU was pegged at 100%. Not shocking if it's transcoding. I confirmed in the logs that it WAS transcoding, I'm just trying to understand why.

 

It's an MKV package with h.264 encoding, two audio streams encoded, DTS-HD pass thru and DTS-HD -> AAC. 

 

I'll post two different sections of logs. I'm not sure the most relevant. The one first looks most relevant, but will include a block after that (from earlier in the log) that might be:

Block 1: I think most relevant

    Stream #0:0: Video: h264 (Main), yuv420p(tv, bt709, progressive), 1920x804 [SAR 1:1 DAR 160:67], 23.98 fps, 23.98 tbr, 1k tbn, 180k tbc (default)
    Stream #0:1(eng): Audio: dts (DTS-HD MA), 48000 Hz, 7.1, s32p (24 bit) (default)
    Metadata:
      title           : Surround
    Stream #0:2(eng): Audio: aac (LC), 48000 Hz, 5.1, fltp
    Metadata:
      title           : Surround
[libx264 @ 0x209fc20] using SAR=1/1
[libx264 @ 0x209fc20] using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2
[libx264 @ 0x209fc20] profile Main, level 4.0
Output #0, mpegts, to '/var/packages/EmbyServer/target/var/transcoding-temp/35068d1055a4a879cab336d840c40511.ts':
  Metadata:
    encoder         : Lavf57.56.101
    Stream #0:0: Video: h264 (libx264), yuv420p, 1920x804 [SAR 1:1 DAR 160:67], q=-1--1, 23.98 fps, 90k tbn, 23.98 tbc (default)
    Metadata:
      encoder         : Lavc57.64.101 libx264
    Side data:
      cpb: bitrate max/min/avg: 5068000/0/0 buffer size: 10136000 vbv_delay: -1
    Stream #0:1: Audio: aac (LC), 48000 Hz, stereo, fltp (24 bit), 128 kb/s (default)
    Metadata:
      encoder         : Lavc57.64.101 aac
Stream mapping:
  Stream #0:0 -> #0:0 (h264 (native) -> h264 (libx264))
  Stream #0:1 -> #0:1 (dts (dca) -> aac (native))

Block 2: Less certain

 

{"Protocol":"File","Id":"d35722b76bfbbfae223da72991767538","Path":"/volume1/*******/Movies/Moana/Moana.mkv","Type":"Default","Container":"mkv","Name":"1080P/H264/DTS","IsRemote":false,"ETag":"25b53afbbfd9eb96cacda9cb1654e673","RunTimeTicks":64328230000,"ReadAtNativeFramerate":false,"SupportsTranscoding":true,"SupportsDirectStream":true,"SupportsDirectPlay":true,"IsInfiniteStream":false,"RequiresOpening":false,"RequiresClosing":false,"SupportsProbing":true,"RequiresLooping":false,"VideoType":"VideoFile","MediaStreams":[{"Codec":"h264","TimeBase":"1/1000","CodecTimeBase":"1001/48000","NalLengthSize":"4","IsInterlaced":false,"IsAVC":true,"BitRate":12614057,"BitDepth":8,"RefFrames":1,"IsDefault":true,"IsForced":false,"Height":804,"Width":1920,"AverageFrameRate":23.97602,"RealFrameRate":23.97602,"Profile":"Main","Type":"Video","AspectRatio":"2.40:1","Index":0,"IsExternal":false,"IsTextSubtitleStream":false,"SupportsExternalStream":false,"PixelFormat":"yuv420p","Level":40,"IsAnamorphic":false},{"Codec":"dts","Language":"eng","TimeBase":"1/1000","CodecTimeBase":"1/48000","Title":"Surround","DisplayTitle":"Eng Surround","IsInterlaced":false,"ChannelLayout":"7.1","BitDepth":24,"Channels":8,"SampleRate":48000,"IsDefault":true,"IsForced":false,"Profile":"DTS-HD MA","Type":"Audio","Index":1,"IsExternal":false,"IsTextSubtitleStream":false,"SupportsExternalStream":false,"Level":0,"IsAnamorphic":false},{"Codec":"aac","Language":"eng","TimeBase":"1/1000","CodecTimeBase":"1/48000","Title":"Surround","DisplayTitle":"Eng Surround","IsInterlaced":false,"ChannelLayout":"5.1","Channels":6,"SampleRate":48000,"IsDefault":false,"IsForced":false,"Profile":"LC","Type":"Audio","Index":2,"IsExternal":false,"IsTextSubtitleStream":false,"SupportsExternalStream":false,"Level":0,"IsAnamorphic":false}],"PlayableStreamFileNames":[],"Formats":[],"Bitrate":12614057,"RequiredHttpHeaders":{}}

/var/packages/EmbyServer/target/ffmpeg/bin/ffmpeg -ss 00:37:11.059 -f matroska -codec:0 h264 -codec:1 dts -codec:2 aac -i file:"/volume1/*******/Movies/Moana/Moana.mkv" -map 0:0 -map 0:1 -map -0:s -codec:v:0 libx264 -force_key_frames "expr:gte(t,n_forced*5)" -copyts -avoid_negative_ts disabled -start_at_zero -pix_fmt yuv420p -preset superfast -crf 23 -maxrate 5068211 -bufsize 10136422 -x264opts:0 subme=0:rc_lookahead=10:me_range=4:me=dia:no_chroma_me:8x8dct=0:partitions=none -vsync -1 -map_metadata -1 -map_chapters -1 -threads 0 -codec:a:0 aac -strict experimental -ac 2 -ab 128000 -af "volume=2" -y "/var/packages/EmbyServer/target/var/transcoding-temp/35068d1055a4a879cab336d840c40511.ts"


ffmpeg version 3.2.4-20170217T125043UTC Copyright (c) 2000-2017 the FFmpeg developers
  built with gcc 5.4.0 (GCC)
  configuration: --prefix=/var/packages/EmbyServer/target/ffmpeg --enable-cross-compile --cross-prefix=x86_64-pc-linux-gnu- --target-os=linux --disable-rpath --arch=x86_64 --enable-libzimg --enable-libmfx --enable-vaapi --enable-yasm --enable-gpl --enable-shared --disable-static --disable-debug --disable-ffplay --disable-ffserver --disable-doc --disable-htmlpages --disable-manpages --disable-podpages --disable-txtpages --enable-gnutls --enable-libass --enable-libmp3lame --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxvid --enable-libfreetype --enable-fontconfig --enable-gray --enable-libfribidi --enable-libvidstab --disable-indev=sndio --disable-outdev=sndio --extra-version=20170217T125043UTC --extra-libs='-lm -ldl -lrt -lpthread -llzma -lz -lstdc++ '
  libavutil      55. 34.101 / 55. 34.101
  libavcodec     57. 64.101 / 57. 64.101
  libavformat    57. 56.101 / 57. 56.101
  libavdevice    57.  1.100 / 57.  1.100
  libavfilter     6. 65.100 /  6. 65.100
  libswscale      4.  2.100 /  4.  2.100
  libswresample   2.  3.100 /  2.  3.100
  libpostproc    54.  1.100 / 54.  1.100
Input #0, matroska,webm, from 


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134818 posts
  • Local time: 12:56 PM

Posted 23 April 2017 - 11:16 PM

Hi, welcome. can you please attach the complete logs? We will need them in order to answer why it was transcoding. Thanks !



#3 MarcSPNW OFFLINE  

MarcSPNW

    Newbie

  • Members
  • 3 posts
  • Local time: 09:56 AM

Posted 23 April 2017 - 11:57 PM

Oh sure thing! Done. Would have done that to start, but for some reason, I didn't see the attach file option earlier. Attached!

Thanks Luke!

Attached Files


Edited by mscattergood, 23 April 2017 - 11:57 PM.


#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134818 posts
  • Local time: 12:56 PM

Posted 24 April 2017 - 12:58 AM

It looks like the app is requesting a video quality of around 6mbps from the server, and that would explain the transcoding. Did you adjust any video quality settings? Go into the app's settings and try setting the max streaming bitrate back to Auto. Thanks.



#5 ebr ONLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46107 posts
  • Local time: 12:56 PM

Posted 24 April 2017 - 08:31 AM   Best Answer

Or, if it is already on Auto, try setting it to at least 15Mb (the item you are playing is about 12).


  • MarcSPNW likes this

#6 MarcSPNW OFFLINE  

MarcSPNW

    Newbie

  • Members
  • 3 posts
  • Local time: 09:56 AM

Posted 24 April 2017 - 11:33 AM

Hey folks,

 

Thanks much for the pointers. Now.. could someone explain why it transcodes when bandwidth is throttled? If you're willing and have time. :)

I checked bandwitdh and it was set to auto, but it was dropping the bandwidth to cap at 10 - 11mbps.. I set it to the highest for that movie - 15mbps, and sure enough, it switch from transcode to remux! Just curious why a throttle forces a transcode instead of just a throttled remux.. OH wait.. think I just mentally answered my own question. Transcode allows adjustment of overall quality on the fly, whereas a stream will be the fully unaltered stream so the hardware can just play supported streams, hence the need for the full bandwidth? Something like that?



#7 ebr ONLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46107 posts
  • Local time: 12:56 PM

Posted 24 April 2017 - 02:06 PM

Yeah, there is no such thing as a "throttled remux" :).  Doing that would effectively slow down playback.

 

So, to change the bitrate, the video must be converted to the lower bitrate.







Also tagged with one or more of these keywords: transcoding, Synology, nvidia shield

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users