Jump to content

ASUSTOR Setup and Transcoding Settings


Recommended Posts

Hey guys I have been using Emby / Media Browser since way back when it was a mere WMC plugin (probably 8 years... just guessing). Never really bothered to look into or comment in the forums but did pay for premiere

Recently I took down my Windows based Emby server which worked great and decided to move everything to a NAS


I have noticed there is not much Asustor info so hopefully my setup can help other people.


Recently I setup an Asustor 6104T with 4 x 10TB IronWolf drives and 8GB DDR3L 1600.

It was slow going at first with not much Asustor info in the Emby forums, however after about a week I ended up with a rock solid system, some of my experiences might be able to help people using Asustor or trying to set one up.


Home layout for NAS

Internet - Fibre 100/40

Router - ASUS N55U

LAN - NAS - Asustor AS6104T (4 x 10TB IronWolf drives and 8GB DDR3L 1600) - I tried 1333 RAM and it seemed to have a massive impact on system performance, so I recommend sticking with 1600


The NAS is in a server room with other household equipment, so it is effectively running headless and no content is played directly on the NAS to a monitor



Emby Setup



I initially installed Emby from App Central, then using WinSCP, I FTP into the NAS and update the Emby version with the most current from the Emby website (currently

This process takes around 20 seconds to do and it should be noted that you must shutdown the Emby server, go to App Central and disable the app before updating. Once updated go back into App Central and reenable the app.



I currently have 9 users, 6 of those are usually on the internal network (sometimes external) and 3 are external all the time



My library is around 8TB ranging from TV, SD - HD - 4K, with most of the HD content having DTS 5.1



I have external streams limited to 2Mps, this limits the pressure on transcoding as well as the network



I spent hours and hours in transcoding, testing multiple devices, configurations etc. Below is the best outcome I can get out of the system thus far, please note I cannot get 4K with DTS 5.1 to play reliably yet although I can get some 4K to work with 2.0 sound.


If transcoding continues to be an issue or I can't get Intel Quick Sync working, I will most likely move to something like an Intel NUC i5/i7 to run the Emby server and use the NAS for content only


Hardware Acceleration - Video Acceleration API (VA API) (experimental)

VA API Device - /dev/dri/card0

Transcoding thread count - Max

Enable throttling - unticked

FFmpeg version - Use a custom version - I use the version found in App Central (I find it works better with the Asustor than the version shipped with Emby)

FFmpeg path - /volume1/.@plugins/AppCentral/ffmpeg/bin/ffmpeg

Transcoding temporary path - Set it to whatever you want. In the event of problems I made mine a location that is easily accessible so it can be flushed

Audio boost when downmixing - 2

H.264 encoding preset - Auto

H.264 encoding CRF - 20


Live TV

Using a HDHomeRun HDHR4-2DT but not setup as yet



I have Auto Box Sets and Server Configuration Backup


Scheduled Tasks

- Chapter image extraction can take anywhere from 20 seconds to 2 hours depending on how much content I add at a time, note that this is quite heavy on the CPU so if you have added new content and the chapters are extracting, you may have playback issues if transcoding while this process is running. This will run the CPU up to around 95% of both cores (my system is a dual core, quad core should be better)

- Refresh people takes around 10 mins and loads the CPU to around 5%

- Scan media library takes around 10 - 20 mins and can bump your CPU usage up to between 30 and 60%. Similar to Chapter image extraction, while this process is running transcoded playback may be affected



The biggest bottle necks of this system are the CPU and RAM, CPU is something you can't change once you buy it (only talking about my Asustor NAS here) therefore you have to manage it appropriately, the memory I highly recommend bumping up to as much as your Asustor can handle (mine is 2 x 4GB, total 8GB) I found that using 1333 DDR3 had an adverse effect on the system, I moved to 1600 DDR3L and everything was much better.


I'm not sure if the memory problem was with the clocking speed (1333 vs 1600) or the voltage being used (DDR3 1.5V vs DDR3L 1.35V), limited info on the hardware makes it near impossible for me to know.

I can tell you the original sticks that came installed in the system were 2 x 1GB DDR3L 1600


Network Devices

LAN - Xbox One using Emby Theater or DLNA when remote playing content from my phone (Emby Theater is the main setup and used 99% of the time)

LAN - Xbox 360 using DLNA I think... (havent used it in a while), have done tests on it but don't use it very often

LAN - Yamaha 5.1 Reciever using DLNA for audio (Tested only, not used very often)

LAN - Panasonic TV using DLNA (Tested only, will not normally use)

LAN - HDHomeRun HDHR4-2DT - in the process of setting up so not currently online

5GHz Wifi - S6 Edge

5GHz Wifi - Another S6 Edge

5GHz Wifi - Tab S2 8"

5GHz Wifi - Note 3

5GHz Wifi - Note 5

5GHz Wifi - Windows 10 laptop

5GHz Wifi - another Windows 10 laptop

5GHz Wifi- Android TV (Emby App with MX Player mainly, have tested DLNA, VLC and Chromecast...)

2.4GHz Wifi - Chromecast version 1

2.4GHz Wifi - iPad mini


Most of the time I use the Xbox One and the Tab S2" without any dramas at all, the other devices play content sporadically but have not been as thoroughly tested.

I have also not had any problems with the Chromecast or Android TV


Playback Experience

I have tested all 6 internal users playing content as a direct stream along with 3 external users playing direct content as a direct stream, so with no transcoding present all 9 users were able to play content without interruption (they were all HD movies)


With transcoding it is a different story, I have tested running 4 internal users with 1 external user. 3 of the internal users were direct streaming with 1 internal user transcoding, the external user was also transcoding but with external streaming set to 1Mbps.

This is the max I could get out of the system, adding another user brought the system to a near holt... As soon as I removed one of the users transcoding everything kicked back in again, but note doing this test kept the CPU at 99% constantly.


Throughout all tests I had my laptop (not playing any content at all) logged in the NAS VIA browser and the Emby server VIA browser, this allows you to be able to watch the CPU / RAM allocation of the NAS as well as check which users are streaming what content, and if its direct streaming or transcoding.


The best everyday experience I have used and tested is the Xbox One App and the Emby for Android TV app using MX Player (codecs for MX Player are floating around and can greatly enhance playback).

I always default back to the Emby App on the Tab S2 8" for testing when there is a problem as I haven't had a single issue with it yet... luck i guess.


Hopefully this helps anyone currently using an Asustor NAS and is having issues or helps people thinking about setting one up.










Edited by lllrinzlerlll
  • Like 1
Link to comment
Share on other sites

  • 1 month later...

@@cybe If you installed from Asustor package center then you can update through there. Please let us know if this answers your question. thanks !

Link to comment
Share on other sites

@@cybe If you installed from Asustor package center then you can update through there. Please let us know if this answers your question. thanks !


@@Luke I installed from there but latest Version is 3.1.2r1. No Update available. In emby dashboard itself says Version 3.2.5 available - shutdown server and upadte manually.

Edited by cybe
Link to comment
Share on other sites

Ok @@cybe currently Asustor handles maintenance of the Emby package so we are dependent on them updating it. So you might just have to be patient for now. Thanks.

Link to comment
Share on other sites

Thank you Luke for this Information. I'll be waiting for them to release a new package.


With all due respect to Luke, I strongly recommend AGAINST using Asustor's "App Central" packages to update your Emby installation.


As Luke said, the Emby devs have no control over the timing or reliability of update packages on Asustor App Central, and based on personal observation, Asustor is notorious for late app updates, especially those from the "maintainer" responsible for both their Kodi and Emby apps (at the time of this writing, he is still serving up an ancient Jarvis 16.0.3.R12 version of Kodi, and is a few revs behind on Emby as well, currently at ver. 3.1.2.r1). Worse, Asustor's lack of proper QC and oversight of its App Central updates is disturbing. As others have noted, some of the recent App Central Emby update packages were actually wiping out users' critical metadata and cache folders in the process! 


My impatience with Asustor's crippled OS, nagging compatibility/performance issues and constantly late and/or busted updates packages finally reached critical mass a couple months ago. I no longer run any significant apps natively. It's just not worth the headaches imho. But if you must, then at least consider updating your Emby installation manually using the Linux Emby.Mono.Zip package instead. It's an easy procedure with free tools such as WinSCP, and far less risky than rolling the dice with Asustor goober-builds. If you can't find instructions, send a note to "geoff511."  He has the process down pat.


Also, if the default asustor setup still places the cache and metadata folders in the hidden "@.plugins/AppCentral/mediabrowser" path, you may want to move them to a safer, more accessible folder on your NAS's visible directory tree.



Link to comment
Share on other sites

Well they have to get it from somewhere. We are hoping to take over this process in the near future though.

Link to comment
Share on other sites

Well they have to get it from somewhere. We are hoping to take over this process in the near future though.


Hey Luke,


That's great news. The Emby team updates will undoubtedly be more timely, and certainly more trustworthy.


And yes, I realize that until then, users still need to get updates from somewhere, but my point was that the best "somewhere" is your own Linux server package, Emby.Mono.Zip, off GitHub. It's a far more reliable option than the tardy, busted crap currently available on Asustor's App Central. The manual upgrade process is so easy you could shock a monkey to do it; and bonus, users wouldn't lose gigs of critical cache and metadata files in the process! What's not to love? Perhaps you can't suggest such an option for political reasons due to your position, but as a mere user, I'm not similarly bound... nor am I inclined to be as delicate after 4+ years of having to deal with all the fubar'd tech issues unique to Asustor products.  :)


As for the future, it will be interesting to see if your devs can overcome Asustor's self-inflicted design and performance flaws. I'm not sure if y'all have ever seen Emby Server running on an Asustor NAS, but it's downright painful to watch. Seriously, your guys would likely $h1t themselves if they knew just how bad Asustor's boxes have been making Emby look. You know there are significant platform issues when users can get exponentially better performance running Emby Server on old duo-core laptops or cheap mini boards, than from the "premium, energy efficient processing power" of their shiny new Asustor rigs packing quad-core 2.4GHz Intel CPUs with 8GB RAM, blah, blah, blah. It's truly night and day.


Anyway, good luck with the effort. Heck, I'll even donate time to "the cause" and play crash test dummy for your new Asustor builds. What I may lack in tact, I make up for in tenacity and attention to detail...



Link to comment
Share on other sites

O.K. i've downloaded the EmbyMono.zip file and copied it to my NAS. I extracted the zip, stopped emby server on the NAS, copied all unzipped files to /volume1/.@plugins/AppCentral/mediabrowser/bin/ and restarted emby on the NAS. The emby dashboard says Emby is running. It seems like it worked. Thanks for your infos and i am looking now, how well emby Server performs on my Asustor 5102t.

Edited by cybe
Link to comment
Share on other sites

emby seems to be running fine.

one thing - i tried to get hardware transcoding with either intel quick sync or vaapi with the NAS and emby-server. it seems that hardware transcoding with the asustor 5102t (which uses an intel celeron quad core CPU @ 2GHZ and turbo speed up to 2,48GHZ - an Intel J1900) and emby-server does not work. the CPU seems to be allways @ 80-100% while playing a movie over the web beeing transcoded. also tried the suggested settings from the 1st post. i also tried using the /dev/dri/card0 and /dev/renderD128 device with VAAPI.


when using plex with enabled hardware transcoding and using /dev/renderD128 for the same movie file, with the same settings, the NAS CPU is between 20-40%.

Edited by cybe
Link to comment
Share on other sites

  • 5 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...