Jump to content

BlurN — Blu-Ray Release Notifications


mutu310

Recommended Posts

PrincessClevage

As a future request it would be nice to be able to only display a user based selection of genres I.e I can select the genres that I want displayed in Blurn with xyz star rating etc

Link to post
Share on other sites

@@ebr, my channel creates a movie in the channel, not in the library. The InternalItemsQuery has a property called SourceTypes which is of type SourceType[] using the enumeration SourceType. My channel also queries to check what is in the library (so it won't add those movies in my channel), and in the query I search those with SourceType.Library. Auto Box Set just needs to do the same thing, i.e. filter out those with SourceType.Channel.

@@ebr @@mutu310  I experienced a weird issue with Emby library scans that may or may not be a side effect of movies in the BlurN channel being used in the creation of collections by the AutoBoxset plug-in.  Earlier this week, Emby library scans began stalling at 68.7%.  There was no progress past this point, even after leaving the scan to run overnight for around eight hours.  There were no entries in the Emby log past the time when the scan was initiated.  I stopped the scan, turned on debug logging, and re-initiated the scan.  The scan stalled again at 68.7%.  I checked the log file, and the last entry this time identified a collection had been created for the Mummy movie franchise.  Several hours later there were no additional log entries.

 

I was confused as to why a collection was being created for the Mummy movies, as I don't have any of them in my library.  After reading AboBader's post earlier in this thread, I checked the BlurN channel.   I found that there were items for re-releases of the first two movies in the Mummy franchise.  The AutoBoxSet plug-in was creating the collection based solely on items in the channel without any of the movies physically being present in my library.  I'm not entirely sure why this caused the library scan to stall.  But it was repeatable.  After clearing the BlurN database, uninstalling the BlurN plug-in and manually deleting the Mummy Collection folder that had been added to the collections save location on the server I reran the library scan.  Even though the BlurN channel listings had been cleared, a Mummy Collection boxset was created and the library scan stalled.  The only way I could get the scan to complete was to change the AutoBoxSet plugin settings so that collections would not be created unless there are three or more movies in the collection present on the server.

 

As a result of this behavior, I've decided to uninstall the BlurN plugin for the time being.  Now I just need to figure out why the AutoBoxSet plugin is still finding the Mummy movies in my library after the plugin and the associated channel have been deleted.

Link to post
Share on other sites
Happy2Play

Now I just need to figure out why the AutoBoxSet plugin is still finding the Mummy movies in my library after the plugin and the associated channel have been deleted.

You need to find the cached metadata.  I would check \Metadata\channels\ and \cache\channels\.

Edited by Happy2Play
Link to post
Share on other sites

@@ebr @@mutu310 I experienced a weird issue with Emby library scans that may or may not be a side effect of movies in the BlurN channel being used in the creation of collections by the AutoBoxset plug-in. Earlier this week, Emby library scans began stalling at 68.7%. There was no progress past this point, even after leaving the scan to run overnight for around eight hours. There were no entries in the Emby log past the time when the scan was initiated. I stopped the scan, turned on debug logging, and re-initiated the scan. The scan stalled again at 68.7%. I checked the log file, and the last entry this time identified a collection had been created for the Mummy movie franchise. Several hours later there were no additional log entries.

 

I was confused as to why a collection was being created for the Mummy movies, as I don't have any of them in my library. After reading AboBader's post earlier in this thread, I checked the BlurN channel. I found that there were items for re-releases of the first two movies in the Mummy franchise. The AutoBoxSet plug-in was creating the collection based solely on items in the channel without any of the movies physically being present in my library. I'm not entirely sure why this caused the library scan to stall. But it was repeatable. After clearing the BlurN database, uninstalling the BlurN plug-in and manually deleting the Mummy Collection folder that had been added to the collections save location on the server I reran the library scan. Even though the BlurN channel listings had been cleared, a Mummy Collection boxset was created and the library scan stalled. The only way I could get the scan to complete was to change the AutoBoxSet plugin settings so that collections would not be created unless there are three or more movies in the collection present on the server.

 

As a result of this behavior, I've decided to uninstall the BlurN plugin for the time being. Now I just need to figure out why the AutoBoxSet plugin is still finding the Mummy movies in my library after the plugin and the associated channel have been deleted.

@@ebr @@Luke can the Auto Box Sets plugin be fixed please? I'm assuming I can't fix this issue from my end... Edited by mutu310
Link to post
Share on other sites

You need to find the cached metadata.  I would check \Metadata\channels\ and \cache\channels\.

Thanks @@Happy2Play.  I manually deleted all the "channel" folders I could find under the Emby install directory, which should have removed any cached metadata.  I'll check again later tonight when I get home to see if I missed any.  It was late last night when I finally figured out what was going on, so there is a chance I may have been less than thorough in my search for the folders.

Edited by DarWun
Link to post
Share on other sites

I'm seeing blurn movies in my latest movies view. How can I prevent this?

Seriously? What version of Emby Server? I can't reproduce this issue. @@ebr @@Luke is this related to the Auto Box Sets issue? Why are the movies added to the BlurN channel not being distinguished from movies actually in the library and physically available for playing?
Link to post
Share on other sites

I assume he's seeing them in recommendations, just like you would see trailers for example, which comes from a channel plugin. i just haven't had a chance to look at this yet.

Link to post
Share on other sites

Yes, sorry.

 

 

Thanks @@ebr @@mutu310.  I reinstalled BlurN after the AutoBoxSet plugin updated.  Collections are no longer created based on items in the BlurN channel, and library scans have so far completed without issue. 

Edited by DarWun
  • Like 4
Link to post
Share on other sites

 

Thanks @@ebr @@mutu310.  I reinstalled BlurN after the AutoBoxSet plugin updated.  Collections are no longer created based on items in the BlurN channel, and library scans have so far completed without issue. 

 

 

Welcome back to BlurN :)

Link to post
Share on other sites

Version 1.1.2.4 released

 

- Added anonymous usage tracking purely for statistical purposes.

Edited by mutu310
Link to post
Share on other sites

As a future request it would be nice to be able to only display a user based selection of genres I.e I can select the genres that I want displayed in Blurn with xyz star rating etc

 

I need to plan it out well. The minimum would be a whitelist, as you describe. The maximum would be too complicated for most users and involve a combination of filters... for example show me all war movies and romantic comedies but I don't want to see any romantic dramas. Probably the best balance would be to offer the user the choice of a whitelist (you choose the genres you want, exclude the rest) or a blacklist (you choose the genres you don't want, include anything else).

  • Like 1
Link to post
Share on other sites
PrincessClevage

Two issue

When playing Blurn preview one trailer is played prior (thinks it is a full movie)

When playing Blurn preview I get presented with the error "there is not any streams available Got it"

Are these intended?

Link to post
Share on other sites

Two issue

When playing Blurn preview one trailer is played prior (thinks it is a full movie)

When playing Blurn preview I get presented with the error "there is not any streams available Got it"

Are these intended?

You're using it incorrectly. You're not supposed to try and "play" the BlurN items. In fact @@Luke and @@ebr are aware about this issue and hopefully they can provide a means for hiding the playing functionality when channel items have no actual video attached. BlurN is NOT some movie streaming plugin, it will never play the movies, that would be illegal.
Link to post
Share on other sites
PrincessClevage

You're using it incorrectly. You're not supposed to try and "play" the BlurN items. In fact @@Luke and @@ebr are aware about this issue and hopefully they can provide a means for hiding the playing functionality when channel items have no actual video attached. BlurN is NOT some movie streaming plugin, it will never play the movies, that would be illegal.

Would an official trailer be possible by intergration with the trailers plugin?
Link to post
Share on other sites

Would an official trailer be possible by intergration with the trailers plugin?

They are, and you don't need the Trailer plugin. Just click on the movie and hit the trailer button and you should see the trailer for the movie. Hope that helps!
  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...