Jump to content


Photo

PS4 Web Browser subtitles issue

ps4 subs subtitles display we broswer emby

Best Answer Luke , 05 January 2017 - 03:50 AM

@rubicon, i've pushed a fix. please try it out. thanks !

Go to the full post


  • Please log in to reply
18 replies to this topic

#1 rubicon OFFLINE  

rubicon

    Advanced Member

  • Members
  • 38 posts
  • Local time: 10:17 AM

Posted 30 December 2016 - 07:32 AM

Hello,

 

When I am using EMBY through PS4 web browser and for some reason the subtitles aren't displaying at all.

In the settings I have them always on/forced and enabled by default.

I am using Greek subs with no other issue when I am watching through the Samsung TV app or through my iPhone

(Same user profile of course) but through PS4, subtitles do not show at all.

It's a shame as I really love the PS4 interface.

 

Something to be fixed possibly on another release?

 

Thanks in advance,

George



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140284 posts
  • Local time: 05:17 AM

Posted 30 December 2016 - 01:39 PM

Hi @rubicon thanks for the report. we'll take a look.


  • supermau likes this

#3 rubicon OFFLINE  

rubicon

    Advanced Member

  • Members
  • 38 posts
  • Local time: 10:17 AM

Posted 30 December 2016 - 03:16 PM

As always, thanks for your quick response Luke.

 

Merry Christmas and a Happy New Year!!

 

:)



#4 Sp3kt3r OFFLINE  

Sp3kt3r

    Advanced Member

  • Alpha Testers
  • 147 posts
  • Local time: 06:17 AM
  • LocationCanada

Posted 01 January 2017 - 08:41 PM

Happy New year :) just want to add that I have the same issue. I also can not make subtitle work when clicking on the CC icon.

#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140284 posts
  • Local time: 05:17 AM

Posted 01 January 2017 - 09:25 PM

thanks for the report. we'll take a look.



#6 jackal992 OFFLINE  

jackal992

    Newbie

  • Members
  • 3 posts
  • Local time: 12:17 PM

Posted 02 January 2017 - 08:25 PM

Hi! 

Just to report other problems with subtitles:

I only use internal srt subtitles (embedded in MKVs) and for me the situation is the following:

 

-Web App from Chrome: subtitles do not work (of course selected from the icon...)

-Chromecast: very strange, just some subtitles work, maybe one subtitle track out of three, even though they are all in the same file...for many files they do not work at all...

-Windows Metro App for Emby Theater (from Windows Store): same as Chromecast, sometimes it plays two subtitles tracks out of three (not joking, with same files used with Chromecast), so slightly more robust than Chromecast

-Emby Theater: when used with external player of course everything is working, usually also when it plays the files directly in the internal player (but not tested much...)

-Android app: subtitles works fine

 

What is very strange is that the tracks are embedded into the files, all in same SRT format...probably the Chromecast bug is the one that "bothers" more, for the other platforms there are alternatives often...

 

Edit: The setting "Subtitle Mode" is set to "Default", I haven't tested any other setting...


Edited by jackal992, 02 January 2017 - 08:44 PM.


#7 rubicon OFFLINE  

rubicon

    Advanced Member

  • Members
  • 38 posts
  • Local time: 10:17 AM

Posted 03 January 2017 - 06:48 AM

Hi jackal992,

 

Personally I always had issues with embedded subs even in the other emby apps but since I started using external srt subs I had no issue

(PS4 web app excluded of course, hence the reason of opening originally this thread).

I think the embeded options always were a bit problematic. Another issue I had once, was when I tried to embed 2 different audio tracks in a movie.

Whenever tried to switch to an audio track when the movie was playing, it always crashed so I ended up choosing just one audio track that suits my standards.

 

 

Hi! 

Just to report other problems with subtitles:

I only use internal srt subtitles (embedded in MKVs) and for me the situation is the following:

 

-Web App from Chrome: subtitles do not work (of course selected from the icon...)

-Chromecast: very strange, just some subtitles work, maybe one subtitle track out of three, even though they are all in the same file...for many files they do not work at all...

-Windows Metro App for Emby Theater (from Windows Store): same as Chromecast, sometimes it plays two subtitles tracks out of three (not joking, with same files used with Chromecast), so slightly more robust than Chromecast

-Emby Theater: when used with external player of course everything is working, usually also when it plays the files directly in the internal player (but not tested much...)

-Android app: subtitles works fine

 

What is very strange is that the tracks are embedded into the files, all in same SRT format...probably the Chromecast bug is the one that "bothers" more, for the other platforms there are alternatives often...

 

Edit: The setting "Subtitle Mode" is set to "Default", I haven't tested any other setting...


  • supermau likes this

#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140284 posts
  • Local time: 05:17 AM

Posted 03 January 2017 - 03:11 PM

Thanks, we are looking into it.



#9 jackal992 OFFLINE  

jackal992

    Newbie

  • Members
  • 3 posts
  • Local time: 12:17 PM

Posted 03 January 2017 - 05:44 PM

Hi jackal992,

 

Personally I always had issues with embedded subs even in the other emby apps but since I started using external srt subs I had no issue

(PS4 web app excluded of course, hence the reason of opening originally this thread).

I think the embeded options always were a bit problematic. Another issue I had once, was when I tried to embed 2 different audio tracks in a movie.

Whenever tried to switch to an audio track when the movie was playing, it always crashed so I ended up choosing just one audio track that suits my standards.

 

Hi rubicon!

Thanks for the advice, I'll definitely try to use external subtitles, even if it has always seemed nicer to me to have everything embedded in a file; for instance other players which access the network storage via SMB or NFS are easier to manage with everything embedded in a file, even if they'd probably work with external subs as well..

 

What worries me is that I should manually extract the SRT files from lots of files, unless I find some plugin or subtitle service which completely re-downloads the subtitles...but again I've never used them to be fair, for fear of lack of sync of the downloaded subtitles with the video, for instance in OpenSubtitles there are so many versions of subtitles for a movie in a language. How can I be sure that it finds the correct one? I've never tried, but if it works it would be even too nice to be true!!



#10 rubicon OFFLINE  

rubicon

    Advanced Member

  • Members
  • 38 posts
  • Local time: 10:17 AM

Posted 03 January 2017 - 06:42 PM

Hi rubicon!

Thanks for the advice, I'll definitely try to use external subtitles, even if it has always seemed nicer to me to have everything embedded in a file; for instance other players which access the network storage via SMB or NFS are easier to manage with everything embedded in a file, even if they'd probably work with external subs as well..

 

What worries me is that I should manually extract the SRT files from lots of files, unless I find some plugin or subtitle service which completely re-downloads the subtitles...but again I've never used them to be fair, for fear of lack of sync of the downloaded subtitles with the video, for instance in OpenSubtitles there are so many versions of subtitles for a movie in a language. How can I be sure that it finds the correct one? I've never tried, but if it works it would be even too nice to be true!!

 

 

Hello again!

 

No problem at all  :)

 

Via SMB or NFS you should be fine with external subs, as in the past I have done similar tests with no problem.

 

Finding the subs again can be painful and that is exactly what I had to do... It took me 2 weeks for my whole collection testing various subs through OpenSubtitles and similar sites (most of the time I knew the encoding so no synchronisation was needed) but I think it is worth your time and you'll do it only once. I suggest start using this tool (for mac and windows) : https://subtitlesapp.com which has a trial mode that is fully functional and the ones you see that are not matching, download them manually through any subtitle website.


  • jackal992 likes this

#11 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140284 posts
  • Local time: 05:17 AM

Posted 05 January 2017 - 03:50 AM   Best Answer

@rubicon, i've pushed a fix. please try it out. thanks !


  • rubicon likes this

#12 rubicon OFFLINE  

rubicon

    Advanced Member

  • Members
  • 38 posts
  • Local time: 10:17 AM

Posted 05 January 2017 - 06:19 AM

@rubicon, i've pushed a fix. please try it out. thanks !

 

 

Thanks Luke!

 

When I return today from work, I will give it a go and let you know.

 

Thanks,

Luke



#13 rubicon OFFLINE  

rubicon

    Advanced Member

  • Members
  • 38 posts
  • Local time: 10:17 AM

Posted 05 January 2017 - 03:20 PM

@rubicon, i've pushed a fix. please try it out. thanks !

 

 

@Luke I have just tested it Luke and it works brilliantly!

 

Even the size of the subs looks perfect!

 

Thanks for your assistance  :)  :)


Edited by rubicon, 05 January 2017 - 03:20 PM.


#14 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140284 posts
  • Local time: 05:17 AM

Posted 05 January 2017 - 03:26 PM

Thanks for reporting back.



#15 rubicon OFFLINE  

rubicon

    Advanced Member

  • Members
  • 38 posts
  • Local time: 10:17 AM

Posted 08 January 2017 - 10:19 AM

@Luke will it be possible in the future to choose your own size for the subs? It doesn't look bad, its just handy to be able to change it sometimes. 

I have noticed that within the Samsung app (version 2.1.3) I can change the size and it works really well. Within PS4 web app, android or IOS I haven't seen a similar option.

Just something to consider for a future release if possible.

 

Thanks,

George



#16 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140284 posts
  • Local time: 05:17 AM

Posted 08 January 2017 - 06:46 PM

Yes, we are planning subtitle size settings in the future.


  • rubicon and supermau like this

#17 rubicon OFFLINE  

rubicon

    Advanced Member

  • Members
  • 38 posts
  • Local time: 10:17 AM

Posted 08 January 2017 - 07:14 PM

Thanks @Luke !!



#18 Fredywall OFFLINE  

Fredywall

    Newbie

  • Members
  • 1 posts
  • Local time: 07:17 AM

Posted 19 March 2017 - 08:19 AM

Hi,

I have an strange behavior in the same line of this topic.

In mid-February, from PS4 browser, I saw a movie in mkv format with spanish subtitles embedded inside. It  works perfect as always adn exactly the same with de other files in the same situation. (As well as other devices: android, ipad, and pc)

 

Later in March (always with the PS4 browser), I tried to watch similar movies and in the same format, but there was no way to watch them with subtitles. (Other devices are not affected by this issue).

 

The strangest thing is that the same movies that I could previously see under these conditions, I can no longer see them with subtitles!
What happened in between? Maybe I changed some settings on the server or the changes in the PS4 browser did not reach my device?

 

I always enbed the spanish audio tracks and externals subtiltles inside de MKV container with the MKVTOOLNIX tool, but reading this post, I donĀ“t think it is the best practice anymore. Is this correct? Is it preferable in separate files?

 

Thanks in advance.

Federico



#19 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140284 posts
  • Local time: 05:17 AM

Posted 19 March 2017 - 02:37 PM

hi @Fredywall, we're very sorry to hear about this. The best thing to do is please discuss a specific example, and please provide the information requested in how to report a media playback issue. Thanks !







Also tagged with one or more of these keywords: ps4, subs, subtitles, display, we, broswer, emby

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users