Jump to content

Emby Theater on Raspberry Pi


Recommended Posts

Spaceboy

Is if possible to put a line in the autostart batch file that deletes the config folder before running Emby? What would this look like?

Solved this for now with crontab. Learning all the time. I have to log in each time but it's better this way until the issue can be fixed.
Link to post
Share on other sites

Do you still need to pull the power cable out to restart so that it runs. @@Luke is there anything we can do from our end to help resolve this blank screen issue the only way to get emby going again is to plug in keyboard and mouse and delete the config folder.

Link to post
Share on other sites
Spaceboy

Do you still need to pull the power cable out to restart so that it runs. @@Luke is there anything we can do from our end to help resolve this blank screen issue the only way to get emby going again is to plug in keyboard and mouse and delete the config folder.

Yes you do, but as you've pointed out there was no way of fixing without a keyboard / mouse and no assistance was forthcoming
Link to post
Share on other sites

It does it on its own without my assistance. Interesting thing last night the sd channels start in 3 seconds and hd channels in 6 seconds so there has definitely been improvement in emby server.  I use the analyzeduration flag and so far didn't experience black screen and the channels start much faster.

 

In progress recordings start almost immediately hopefully in can be like that for all live channels.

 

So the key to live tv is that video player needs to know the stream couldn't that somehow be saved since you never have to retune the tv unless there is a new channel there is no reason why emby can't do the same to keep the info saved. I am not a programmer so I could be talking crap.

Edited by denz
Link to post
Share on other sites

What happened to raised cards on selection now have no idea what is selected until i move then noticed it has a faint green border. Can we have raised cards that was much better.

 

I also suggest that you put analyze time as default i have been trailing it for long time and never had a blank screen and its only then we will find out does it work for everyone and if the server doesnt have two seconds analyze time sd channels will start within second and hd channels about 3 seconds.

Edited by denz
Link to post
Share on other sites

What I mean is that everything is flat even though it is selected in windows as you can see it is raised. 

 

No idea regarding electron or how to find out.

 

 

589edf3b20c37_Untitled5.png

 

 

This is from web client as you can see the two movies on the web client have a better thumbnail can this be done in emby.

 

589ee1bf285a3_Capture56.jpg

 

Log.txt

Edited by denz
Link to post
Share on other sites

Ok thought I might give it go.  Fairly new to linux and am at the point where I understand some of what I copy and paste into terminal windows.  I Installed raspbian jessie lite on to a sdcard, expanded the file system, ran sudo apt update && apt upgrade and then installed npm.

 

Tried to install electron and the following error appears:

 

 

pi@embypi:~ $ sudo apt-get install npm

Reading package lists... Done

Building dependency tree       

Reading state information... Done

npm is already the newest version.

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

pi@embypi:~ $ sudo npm -g install electron

npm WARN engine deep-extend@0.4.1: wanted: {"node":">=0.12.0","iojs":">=1.0.0"} (current: {"node":"0.10.29","npm":"1.4.21"})

npm WARN engine request@2.79.0: wanted: {"node":">= 4"} (current: {"node":"0.10.29","npm":"1.4.21"})

npm WARN engine form-data@2.1.2: wanted: {"node":">= 0.12"} (current: {"node":"0.10.29","npm":"1.4.21"})

npm WARN engine hawk@3.1.3: wanted: {"node":">=0.10.32"} (current: {"node":"0.10.29","npm":"1.4.21"})

npm WARN engine cryptiles@2.0.5: wanted: {"node":">=0.10.40"} (current: {"node":"0.10.29","npm":"1.4.21"})

npm WARN engine hoek@2.16.3: wanted: {"node":">=0.10.40"} (current: {"node":"0.10.29","npm":"1.4.21"})

npm WARN engine boom@2.10.1: wanted: {"node":">=0.10.40"} (current: {"node":"0.10.29","npm":"1.4.21"})

/usr/local/bin/electron -> /usr/local/lib/node_modules/electron/cli.js

 

> electron@1.4.15 postinstall /usr/local/lib/node_modules/electron

> node install.js

 

sh: 1: node: not found

npm WARN This failure might be due to the use of legacy binary "node"

npm WARN For further explanations, please read

/usr/share/doc/nodejs/README.Debian

 

npm ERR! electron@1.4.15 postinstall: `node install.js`

npm ERR! Exit status 127

npm ERR! 

npm ERR! Failed at the electron@1.4.15 postinstall script.

npm ERR! This is most likely a problem with the electron package,

npm ERR! not with npm itself.

npm ERR! Tell the author that this fails on your system:

npm ERR!     node install.js

npm ERR! You can get their info via:

npm ERR!     npm owner ls electron

npm ERR! There is likely additional logging output above.

 

npm ERR! System Linux 4.4.38-v7+

npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "-g" "install" "electron"

npm ERR! cwd /home/pi

npm ERR! node -v v0.10.29

npm ERR! npm -v 1.4.21

npm ERR! code ELIFECYCLE

npm ERR! 

npm ERR! Additional logging details can be found in:

npm ERR!     /home/pi/npm-debug.log

npm ERR! not ok code 0

 

It would appear that I need to update my npm but it says its already at the latest version. So I am now stuck.  Can anyone help?

 

Thanks.

Edited by weedos123
Link to post
Share on other sites

I had the same problem as you when I tried to install ET with raspbian jessie lite. I think the problem is because you need some packages which are bundled in the X-window part of the GUI to upgrade the package node. 

My suggestion is to follow this guide https://www.raspberrypi.org/forums/viewtopic.php?f=66&t=133691 to install "Raspbian Lite with PIXEL/LXDE/XFCE/MATE/Openbox GUI". If you follow chapter 8  "Advanced I - Custom Desktop Environment using Openbox" the guide instruct you to install a simple desktop kiosk that only has a GUI application with no desktop environment at all. This will free up some memory and if I remember correct I had no problem to install electron on this custom desktop enviroment. If you choose this path remember to install the package LXTerminal which gives you the terminal window.

Link to post
Share on other sites

It is very complicated with lite as it is needing x so best to install the full version and then follow instructions it is very easy.

Link to post
Share on other sites

@@denz & @@haraldov thanks for your help.  I choose the easy way and downloaded the full version of rasbian and now have a working rpi3.

 

However I have 1 or 2 issues.  I used null-pointers script to auto start MB and that works well except at the end of watching a tv show I get a blank screen which I gather is due to the display being turned  off. So I found null-pointers script for stopping that and tried to combine them.  Here my linux inexperience is showing up as MB didn't auto start.  Where did I go wrong? I amended the script too say:

 

#[Desktop Entry]

xset s off       # don't activate screen saver

xset -dpms       # disable DPMS (energy star) features

xset s noblank   # don't blank the video screen

 

[Desktop Entry]

Type=Application

Exec=/usr/local/bin/electron /home/pi/emby-theater-pi

Hidden=false

X-GNOME-Autostart-enabled=true

Name=Emby Theatre for Pi

Comment=Start Emby Theatre for Pi

 

The 2nd issue is playback freezes for 30 secs or so every ~10 mins or so and then resumes as normal.  I was playing back a tv show episode @1080p.  Where is the best place to start looking for the reasons.

 

Thanks

 

 

Link to post
Share on other sites

Where did you put that autostart file it needs to be placed in a hidden directory .config/autostart

 

I have encountered a issue yesterday as well i was watching live tv changed the channel and i had just spinning circle and the only way is to restart pi so there are few bugs. For devs to fix they need the log of emby server.

Link to post
Share on other sites

Emby Theater for pi use the omxplayer for playing videos. http://elinux.org/Omxplayer

I use lxsession to start up the start.sh script instead of using [Desktop Entry]. http://www.raspberrypi-spy.co.uk/2014/05/how-to-autostart-apps-in-rasbian-lxde-desktop/

Remember to give the GPU 256 MB.
sudo nano /boot/config.txt
gpu_mem=256
You can also do this with:
sudo raspi-config

Install a utility to hide the mouse the start.sh script need
sudo apt-get install xdotool

Start up a text editor to edit the autostart file:
nano ~/.config/lxsession/LXDE-pi/autostart 

Add this line last in the autostart file
@/home/pi/emby-theater-pi/start.sh
Link to post
Share on other sites

There were changes done to live tv screen since it didnt update automatically i deleted the config file and now i cant login i get this screen.

 

I managed to log in not sure how all i know that i pressed up and down arrows and ok button

 

post-1589-0-51877900-1487245767_thumb.jpeg

Edited by denz
Link to post
Share on other sites

A number of posts indicate that a change has been made to the Emby system. I have installed Emby on the R-Pi.  When Emby is upgraded or changed, how do I incorporate the changes?  Or, make sure I have the latest version?

Link to post
Share on other sites

Much of the UI is hosted on our servers. The app runs the content locally on your system in an offline manner, but when you have an active internet connection, it will automatically pull in new changes. So there is nothing you need to do, other than occasionally restart the app. That is why the actual rpi installation is updated so infrequently, we will only have to do that when there is a change specific to raspberry pi.

Link to post
Share on other sites

Interesting so my situation it didn't autoupdate with the recordings changes maybe if I left it over night it would have done it.

Edited by denz
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...