Jump to content

screenplay for WebOS 2.0 and higher TVs


kwilcox
 Share

Recommended Posts

kwilcox

That's happening via the hls.js library

 

Got it Luke. Thanks!  So the video is streaming via HLS using hls.js.  Lol... want to add HLS support to chrome for windows?  Just get Emby.  Based on this, It looks like direct play will continue to work as I described.  Down the road, when I add subtitle support, folks that want to use it will want to either extract SRT files from their mkvs, or mux subtitle SRT files out of the container itself and then download subtitles as external SRT files (I believe emby server makes the latter pretty easy).  I'll support subtitles by building <track> tags for external SRT files and control with HTML5.

 

Or, you could just leave the default track set in the MKV and the chosen subtitles would always display.  However, "toggle subtitles" will not work since there's no WebOS api that I can find to control this.

.

Edited by kwilcox
Link to comment
Share on other sites

cmarques
@@kwilcox, it seems good, even being a bit much technical to I well understand haha

but when you say "there's no WebOS api that I can find to control this" I think perhaps it's not be true, because on Plex WebOS client I can do it pretty easy, and in playback time... so I assume Plex Inc app uses an WebOs api, or maybe they have created something own?

Link to comment
Share on other sites

Yea but the LG has native support for HLS so you would not need hls.js. It also requires browser support for media extensions which i doubt the primitive LG web engine has. Also, if you test on chrome for mobile android, you'll notice hls.js is not used because on that platform Chrome has native hls support.

Link to comment
Share on other sites

kwilcox

Agree.  I'm using LG's native HLS support currently.  For direct streaming, they also have limited MKV support which I'm working on now.  Advantage is that it doesn't fire up transcoding on the server and I can do playback positioning with currentTime.

 

@@cmarques Plex may deconstruct mkvs as part of direct playback then provide an api that allows subtitle control.  I certainly can control subtitles with MKV containers when direct play is turned off since I use emby HLS server side support then as well.

Edited by kwilcox
Link to comment
Share on other sites

Well you always want to direct play when possible. You could take advantage of a lot of the legwork we've already done by using our shared js libraries, but to do all that refactoring you may as well just keep the UI and turn this into an Emby Theater skin. Which i actually think would be very nice because then it would be usable on every platform that Theater runs on.

Link to comment
Share on other sites

cmarques

@@cmarques Plex may deconstruct mkvs as part of direct playback then provide an api that allows subtitle control.  I certainly can control subtitles with MKV containers when direct play is turned off since I use emby HLS server side support then as well.

don't know if it helps, but you could take a look at this https://github.com/simonjhogan/PLAYz-Media-for-PLEX/blob/master/WebContent/system/script/player.js

Link to comment
Share on other sites

kwilcox

Well you always want to direct play when possible. You could take advantage of a lot of the legwork we've already done by using our shared js libraries, but to do all that refactoring you may as well just keep the UI and turn this into an Emby Theater skin. Which i actually think would be very nice because then it would be usable on every platform that Theater runs on.

 

Well, once you release for LG I'll make a decision on it.  This little exercise is really only something to get us Emby support on LG WebOS itmt  (and to do dev work which lowers my blood pressure lol...)

Edited by kwilcox
  • Like 1
Link to comment
Share on other sites

demian42

I got this loaded in the developer environment and running on webOS 3.0 LG, OLED55.  Direct play helped and it make me very eager for full release.  A couple observations:

 

My music appears in the listing for movies and tv, not sure if everything is appearing everywhere or what, but there are musical artists appearing in the movie listing.

Clicking the alphabet on the bottom to navigate through the movies creates a jitter/freeze - perhaps its looking through the db ?  This may be WHEN it starts showing artists.

I could not play music.  Hitting the play button sent me back home.

 

But it looks great and I successfully started a movie or two.

Link to comment
Share on other sites

 

I just pushed v1.0.8.  It has direct play logic.  A couple of notes on this:

  • I'm really interested if somebody with a WebOS 3.0 TV could test this.  The WebOS 3.0 emulator has two issues: it doesn't resume the video when currentTime is changed (resume or skip operation), and it doesn't have the h.265 codec installed so new 4K videos encoded with H265 don't play.  Neither of these two issues affected my WebOS 2.0 TV.  The WebOS 2.0 emulator was also unaffected (not a good sign...).
  • My high bitrate vidios paused/buffered often using my 300MB/s WiFi connection.  I had to directly connect the TV using an ethernet cable to fix.  Maximum video/audio bitrate settings are ignored when Direct Play is turned on.
  • The mkv format is only partially supported by WebOS:
    • Fast Forward/Rewind does not work 
    • embedded Subtitles are always shown
  • Direct play works with the Chrome web browser too but YMMV based on your installed audio/video codec library.  Not all videos will play with a browser and Chrome seems to do about the best.

 

Hi @kwilcox 

 

I have a WebOs 3.0 Tv. How do you get to the settings to enable direct play?

Link to comment
Share on other sites

kwilcox

I got this loaded in the developer environment and running on webOS 3.0 LG, OLED55.  Direct play helped and it make me very eager for full release.  A couple observations:

 

My music appears in the listing for movies and tv, not sure if everything is appearing everywhere or what, but there are musical artists appearing in the movie listing.

Clicking the alphabet on the bottom to navigate through the movies creates a jitter/freeze - perhaps its looking through the db ?  This may be WHEN it starts showing artists.

I could not play music.  Hitting the play button sent me back home.

 

But it looks great and I successfully started a movie or two.

 

 

Thanks for the feedback! Music and photos aren't supported yet.  You will need to adjust your libraries so that no music folders are entered in TV and Movie libraries.

Edited by kwilcox
Link to comment
Share on other sites

kwilcox

Hi @kwilcox 

 

I have a WebOs 3.0 Tv. How do you get to the settings to enable direct play?

When you have screenplay loaded, its an option that can be found in the screenplay settings screen.

Link to comment
Share on other sites

demian42

 

I got this loaded in the developer environment and running on webOS 3.0 LG, OLED55.  Direct play helped and it make me very eager for full release.  A couple observations:

 

My music appears in the listing for movies and tv, not sure if everything is appearing everywhere or what, but there are musical artists appearing in the movie listing.

Clicking the alphabet on the bottom to navigate through the movies creates a jitter/freeze - perhaps its looking through the db ?  This may be WHEN it starts showing artists.

I could not play music.  Hitting the play button sent me back home.

 

But it looks great and I successfully started a movie or two.

 

Thanks for the feedback! Music and photos aren't supported yet.  You will need to adjust your libraries so that no music folders are entered in TV and Movie libraries.

 

 

My libraries are pretty well organized on emby server.  Are there adjustments in the client ?

5839a85cd3aa5_Untitled.png

Link to comment
Share on other sites

kwilcox

My libraries are pretty well organized on emby server.  Are there adjustments in the client ?

 

 

There are no screenplay settings to customize media libraries.  My philosophy here is that you can do this in Emby Server.  Based on your shot, screenplay should have found your Movies, Music, and TV libraries and labeled homescreen buttons accordingly.  For sure you should have a button labeled "Movies" there and there should be no music items in it unless your //unraid_Media/movies folder contains subfolders with music in it.  Ditto with your TV library.

Link to comment
Share on other sites

When you have screenplay loaded, its an option that can be found in the screenplay settings screen.

I think it is a bug. I do not see the settings item because i have allot of libraries. I just changed the code to set Direct play to True on startup. That did the trick. I don't see all my libraries as well. I can only see 6 and I have 9. But the app is working great. Skipping is working and tested a 10bit HEVC 60fps file. This file does not play on my server but its working in the app on the tv.

Edited by Brazer
Link to comment
Share on other sites

Is there a particular reason why you need them to be separate folders, rather than specifying all your movie folders within one library, etc? It certainly wouldn't occur to me to have separate libraries, but obviously I'm not you and maybe it's a use case I haven't thought of :-)

 

Nonethless, @@kwilcox, perhaps it's worth moving the "settings" button to the top right, next to the login stuff? Maybe have it persist across screens?

Link to comment
Share on other sites

Is there a particular reason why you need them to be separate folders, rather than specifying all your movie folders within one library, etc? It certainly wouldn't occur to me to have separate libraries, but obviously I'm not you and maybe it's a use case I haven't thought of :-)

 

Nonethless, @@kwilcox, perhaps it's worth moving the "settings" button to the top right, next to the login stuff? Maybe have it persist across screens?

 

I have my reasons for having multiple libraries. That why I don't use Kodi. Emby allows me to separate my collection as I please. 

 

@@kwilcox one thing I did notice is that it does not allow a login with no password. 

Link to comment
Share on other sites

@@kwilcox one thing I did notice is that it does not allow a login with no password. 

It does, it's just not ideal - you just have to bring up the keyboard on the password field and hit enter.

Link to comment
Share on other sites

It does, it's just not ideal - you just have to bring up the keyboard on the password field and hit enter.

I did try that but it does absolutely nothing when clicking the onscreen keyboard enter.

Link to comment
Share on other sites

Tv Model:                55UH770V-TA

webOS Tv Version: 3.3.1-2014

Software Version:    04.30.40

Link to comment
Share on other sites

kwilcox

I think it is a bug. I do not see the settings item because i have allot of libraries. I just changed the code to set Direct play to True on startup. That did the trick. I don't see all my libraries as well. I can only see 6 and I have 9. But the app is working great. Skipping is working and tested a 10bit HEVC 60fps file. This file does not play on my server but its working in the app on the tv.

 

That many libraries will definitely be an issue with screenplay.  Five is the maximum that it can show IIRC.  Agree that it looks like you've uncovered a bug: The settings screen isn't being shown when > 5 libraries exist. I'll have a look at it.  There is definitely enough room for nine libraries and the settings screen...

 

It also looks like the WebOS 3.0 soft keyboard will not permit just hitting enter.  Why not make a new user called "screenplay" and give it a password?  You can also choose a custom library configuration.

 

By the way: for everybody who has libraries that are Photo or Music content types, having a custom screenplay user will also allow you to exclude them from being displayed on the home screen.  In the example below, my lgtesting user is only allowed access to the Recordings library.  On the screenplay home screen, a button named "Recordings" and a button named "Settings" is all that is displayed.

 

Capture15-vi.jpg

Edited by kwilcox
Link to comment
Share on other sites

kwilcox

I think it is a bug. I do not see the settings item because i have allot of libraries. I just changed the code to set Direct play to True on startup. That did the trick. I don't see all my libraries as well. I can only see 6 and I have 9. But the app is working great. Skipping is working and tested a 10bit HEVC 60fps file. This file does not play on my server but its working in the app on the tv.

Can you run this on the WebOS 3.0 emulator and post a screenshot of your home screen?  I'd like to see how the buttons look.  The 5 item limit is for items within a collection on the summary screens.  There should be no limit to the number of libraries that can be displayed.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...