Jump to content
abeloin

Linux Setup

Recommended Posts

Luke

Just a heads up to anyone running an Emby Server beta package from OBS. In the next week or two we will be retiring the OBS beta channel.

 

Our website download page has been updated with beta install instructions:

 

https://emby.media/download

 

At your convenience it is recommended that you switch over to the new installation process as we will no longer be publishing betas to OBS.

 

If you're running a non-beta (stable) package from OBS, you can continue to do so for the time being.

 

Thanks !

Share this post


Link to post
Share on other sites
iBoss

Just a heads up to anyone running an Emby Server beta package from OBS. In the next week or two we will be retiring the OBS beta channel.

 

Our website download page has been updated with beta install instructions:

 

https://emby.media/download

 

At your convenience it is recommended that you switch over to the new installation process as we will no longer be publishing betas to OBS.

 

If you're running a non-beta (stable) package from OBS, you can continue to do so for the time being.

 

Thanks !

 

Hi Luke,

 

Could you please tell me how I can do a fresh install of the latest beta emby on Ubuntu 14.04 (i386) 32-bit?

 

Thanks

Share this post


Link to post
Share on other sites
Luke

We don't have 32 bit on beta right now sorry. You'll have to stay with the OBS packages except on the stable edition.

 

Hopefully Microsoft will have a Linux x86 runtime for. Net core in the future. Thanks.

Share this post


Link to post
Share on other sites
Space1979

Hello! How to install emby-server on MIPS architecture Debian 8? 

Share this post


Link to post
Share on other sites
Luke

Hi, we don't currently have a package for mips.

Share this post


Link to post
Share on other sites
cunningcrow

I can't get the installer to work with Ubuntu 18.0.4. I'm launching a brand new instance on AWS with nothing else on it, and using the deb for x86 ubuntu listed on the site.

$ sudo dpkg -i emby-server-deb_4.0.0.2_amd64.deb
dpkg-deb: error: 'emby-server-deb_4.0.0.2_amd64.deb' is not a Debian format archive
dpkg: error processing archive emby-server-deb_4.0.0.2_amd64.deb (--install):
 dpkg-deb --control subprocess returned error exit status 2
Errors were encountered while processing:
 emby-server-deb_4.0.0.2_amd64.deb

Any ideas or suggestions?

Share this post


Link to post
Share on other sites
Luke

I can't get the installer to work with Ubuntu 18.0.4. I'm launching a brand new instance on AWS with nothing else on it, and using the deb for x86 ubuntu listed on the site.

$ sudo dpkg -i emby-server-deb_4.0.0.2_amd64.deb
dpkg-deb: error: 'emby-server-deb_4.0.0.2_amd64.deb' is not a Debian format archive
dpkg: error processing archive emby-server-deb_4.0.0.2_amd64.deb (--install):
 dpkg-deb --control subprocess returned error exit status 2
Errors were encountered while processing:
 emby-server-deb_4.0.0.2_amd64.deb

Any ideas or suggestions?

 

What is the architecture of the machine? It's not really x86, is it? 

Share this post


Link to post
Share on other sites
cunningcrow

Ah, so it is! I had installed a previous 3.5.3.0 on that same server (via apt IIRC) but 4.X looks to not be up yet so I was following instructions for X64.

 

EDIT: This is the image: ubuntu-bionic-18.04-amd64-server-20180912

Edited by cunningcrow

Share this post


Link to post
Share on other sites
Luke

Sorry I'm not quite following. So this is 64-bit OS?

Share this post


Link to post
Share on other sites
cunningcrow

It says 64 bit and has x86 in parentheses

post-411051-0-15717900-1547757391_thumb.png

Edited by cunningcrow

Share this post


Link to post
Share on other sites
cunningcrow

Still cant get it, here are more details on the server.

5c54683b4a9b1_ScreenShot20190201at103822

Share this post


Link to post
Share on other sites
Luke

Are you sure you downloaded the file correctly?

Share this post


Link to post
Share on other sites
cunningcrow

Ah, evidently not. I redownloaded it and it worked as expected. Thanks for the patience.

Share this post


Link to post
Share on other sites
Luke

Thanks for the feedback !

Share this post


Link to post
Share on other sites
Riggs

@Luke

Please, to  update this old post.

Please confirm: 

1- Flatpak. release is not maintained anymore? I can't find Emby anymore on flathub.

2- Snaps. Almost sure is not too.

3- Docker still works, however I did a migration of Emby to the system OS on my Debian 10 server following the dpkg default installation .deb. I was concern about the future of docker with Emby.

I also saw last week a completely abandoned Linux desktop Emby project on Github. Sad :(

 

Share this post


Link to post
Share on other sites
Luke

Both are still maintained. We've never been listed in flathub or snap's store yet but we're working towards that. For now you'd need to install the downloadable packages.

  • Thanks 1

Share this post


Link to post
Share on other sites
Riggs
4 minutes ago, Luke said:

Both are still maintained. We've never been listed in flathub or snap's store yet but we're working towards that. For now you'd need to install the downloadable packages.

Perfect, thank you very much for the timely information. ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...