Jump to content

Beta 2.2.0


Recommended Posts

FrostByte

Bug:  On just about every screen (Movies, TV, Music, Collections, etc) when displaying posters the whole screen pops up about one line when scrolling down and shows the word "Index" at the bottom.

 

 5776756547827_WP_20160701_003.jpg

 

Edited by FrostByte
Link to post
Share on other sites

Bug?  I don't believe the HEVC media icon code took.   At least I can't find the code for HEVC in the file GuiPage_ItemDetails.js (or is it somewhere else?) and I don't see any HEVC icon being displayed within the app.

1202 		//VideoCodec	 
1203 		case "h264": 
1204 			htmlToAdd += "<div class='mediaInfo' style=background-image:url(images/MediaInfo/codec_h264.png)></div>"; 
1205 			break; 
1206 		case "mpeg4": 
1207 			htmlToAdd += "<div class='mediaInfo' style=background-image:url(images/MediaInfo/codec_mpeg4visual.png)></div>"; 
1208 			break;	 
1209 		//AspectRatios	 

I like the green borders, helps distinguish the highlighted poster

 

I haven't seen any slowness with downloading any fonts yet

 

Thanks cmcg, looks good

 

It's definitely in there.

https://github.com/MediaBrowser/SamsungSmartTV/blob/2.2_dev/app/javascript/Gui/GuiPage_ItemDetails.js#L1204

 

Glad the font looks ok.

Link to post
Share on other sites
FrostByte

 

Hmm... I guess you moved it for beta, I was looking under master...my bad

 https://github.com/MediaBrowser/SamsungSmartTV/blob/master/app/javascript/Gui/GuiPage_ItemDetails.js

 

Anyway, it's not working :)

 

Edit: After looking at the correct code though I don't know why it wouldn't work for this file

 

57769b263d854_med7.jpg

 

 

 

Edited by FrostByte
Link to post
Share on other sites
Abobader

Good day,

 

Any update about the issue for arabic subtitle with this new build?

 

My best

Link to post
Share on other sites

2.2.0e
Fixed: Bug in More Episodes menu. Thanks @@Ultroman
Improved display of Fav, Watched, Missing and Unaired overlays.
Fixed: Error on Items Details page when season has less than 4 episodes.
Fixed: HEVC media icon not displayed. Thanks @@FrostByte

Edited by cmcg
  • Like 5
Link to post
Share on other sites
FrostByte

2.2.0e

Fixed: Bug in More Episodes menu. Thanks @@Ultroman

Improved display of Fav, Watched, Missing and Unaired overlays.

Fixed: Error on Items Details page when season has less than 4 episodes.

Fixed: HEVC media icon not displayed. Thanks @@FrostByte

 

Thanks cmcg, everything is looking good so far.  Really liking the new look. 

 

You have a great weekend also

  • Like 1
Link to post
Share on other sites
SilentAssassin

just thought i'd try this beta out, installed 2.2.0e.

 

On my H6400 the backdrops are so dark that I didn't think it was displaying anything initially, it was only after playing around for about 10 mins that I finally noticed they were showing just that they really dark and the backdrop that made me notice them was quite a light backdrop usually.

 

The green highlight is a fixed size and ratio. I use Blu-ray covers for my movies (1166x1480) so these have a different ratio than the posters usually used. As such you can see blank space above and below the Blu-ray cover between the green line (hope that makes sense).

 

Now that you're going Theatre green, maybe worth changing the grey selector on the item detail screen to a green colour.

Link to post
Share on other sites
shorty1483

When watching Homescreen, every Top Menu Point is grey except TV, which is white and a bit larger than the others (Movies, Collections...).

Link to post
Share on other sites
Blueeyiz702

Ive got beta 2.2.0 installed on a UN40H5203,and have some issues with it freezing after watching a movie. It keeps showing a black screen after movie is finished. And wont respond to remote control,only way to exit is i have to 

unplug TV or wait for about 10 to 15 minutes for it to finally respond after the fact??

Link to post
Share on other sites
Dodgy Bob

Hey cmcg and Emby community,

 

Thanks heaps for the new beta! Much appreciated   :)  Can't say I will be a big user, well, a user at all of Internet Channels or Recorded TV / Live Channels, but how I do use it and what little I do use it, if I come across anything I'll be sure to let you all know. On that note, Apologies for not being able to jump in any sooner than now as things have been hectic and there always seems to be something else that gets it's own priority over and above Emby testing   :(  Oh well, at least I have been able to start now.

 

So, I'm now using 2.2.0e on my UA55HU8500W

Before installing, I uninstalled previously installed Emby and also did a complete reset of my Smart Hub, so as to make sure I was starting from a clean slate:

 

 

Here's the full change log...

 

2.2.0a
Internet channel support (experimental)
Recorded TV and Live channels (highly experimental!)
DTS-HD HRA and DTS-HD MA 7.1 audio enabled on H series and F series.
New setting: Allow Evo Kit owners to override the model year value.
Support for H.264 variable frame rates.
Support frame rate up to 60pfs at 720p on H-Series.
Fixed: "Unset (mixed content)" Showing in Movies.

 

Thanks heaps for adding in "Fixed: "Unset (mixed content)" Showing in Movies.". I had done some further testing with SamES, but for whatever reason it just is not working for me; still my random and YouTube videos all show up in Movies blowing out and messing up my 'Movies' list.

 

Is there anything else that I can do to test or try?

 

 

Is anyone having problems with the app freezing on the splash screen after restart?

 

I had noticed this with some of the pre-beta builds from SamES, when we were testing the "Unset (mixed content)" issue - I think thats when I first started noticing it? It might have been with stable 2.1.3, but maybe not. But I have definitely noticed it. I will keep my eye out for it in any case.

 

 

On my H6400 the backdrops are so dark that I didn't think it was displaying anything initially, it was only after playing around for about 10 mins that I finally noticed they were showing just that they really dark and the backdrop that made me notice them was quite a light backdrop usually.

 

The green highlight is a fixed size and ratio. I use Blu-ray covers for my movies (1166x1480) so these have a different ratio than the posters usually used. As such you can see blank space above and below the Blu-ray cover between the green line (hope that makes sense).

 

 

I have the same issue with dark backdrops too.

 

I'll see if any of my Blu-ray covers do this SilentAssassin.

 

 

When watching Homescreen, every Top Menu Point is grey except TV, which is white and a bit larger than the others (Movies, Collections...).

 

Yeah, I noticed this too - happening for me as well.

Link to post
Share on other sites

When watching Homescreen, every Top Menu Point is grey except TV, which is white and a bit larger than the others (Movies, Collections...).

 

That's by design. The white one is the page you are currently on. Same as Theatre.

 

577a39eda65d7_Theatre.png

  • Like 2
Link to post
Share on other sites
yudicuba

Your 3d file appears to be good looking at the mediainfo.  I just played a movie with similar mediainfo and had no issues on my TV - though I don't play a lot of 3d movies so can't say for sure there isn't some sort of intermittent problem. 

 

The one thing I noticed is that your HTS is a j-series model.  I believe the Samsung j-series HTS are not using the new Tizen OS like their TVs which is why you can install it, but I don't believe cmcg is using the 2015 SDK to write the app.   I think he is using the 2014 SDK which supports up to and including h-series devices.  That may be the cause of some irregularities in running the app for you.  He would have to confirm which SDK he is using though

Hey,

Dude you are right

I have installed on my Samsung TV (same settings) as on my HT system!! And it runs awesome ;)

The only problem is that my TV can’t handle 7.1 audio :(

So I have to make a choice  3D films 7.1 audio

Tanks a lot for ur help

Link to post
Share on other sites
FrostByte

The only problem is that my TV can’t handle 7.1 audio :(

So I have to make a choice  3D films 7.1 audio

Tanks a lot for ur help

 

If the 7.1 audio is DTS-HD then you should be okay.  My TV doesn't support 7.1 audio either, but the DTS decoder in my TV is smart enough to use the core DTS track which is only 5.1 channels and plays it without transcoding. 

 

However, with TrueHD the app will transcode automatically or you could use a program like MKVToolNix to pull out the 5.1 core ACS track and then remux both audio tracks in if you want to keep both and avoid any transcoding

 

Edit: The app is designed to deal with most files though, if your hardware isn't capable of direct streaming a file because of something like the number of channels, or codec, etc then it should transcode the file and play fine...hopefully

Edited by FrostByte
  • Like 1
Link to post
Share on other sites
shorty1483

That's by design. The white one is the page you are currently on. Same as Theatre.

 

577a39eda65d7_Theatre.png

But TV is highlighted on the Homescreen.

 

gesendet von meinem Galaxy Tab S2 LTE

  • Like 2
Link to post
Share on other sites
FrostByte

Looks like I'm in the minority.  I kind of like the shadowed look of the backgrounds, makes the text easier to read.  I would go one step further and eliminate the backgrounds on certain screens altogether to make the app faster.  Screens like the All Movies, or All Collections where there are so many posters you can't even make out the background seems like a waste to display one.  Other apps don't have backgrounds on these screens

  • Like 2
Link to post
Share on other sites
CBers

I'm confused.

 

Isn't post #69 just confirming what @@cmcg said in post #66 ??

 

I haven't had a chance to upgrade yet, so seeing that image looks good to me and I agree with @Frosttbyte.

 

I'll have to upgrade tonight and have a proper looksie :)

Link to post
Share on other sites
shorty1483

I'm confused.

 

Isn't post #69 just confirming what @@cmcg said in post #66 ??

 

I haven't had a chance to upgrade yet, so seeing that image looks good to me and I agree with @Frosttbyte.

 

I'll have to upgrade tonight and have a proper looksie :)

The point was that on Homes Screen nothing needs to be highlighted.

 

gesendet von meinem Galaxy Tab S2 LTE

  • Like 1
Link to post
Share on other sites
FrostByte

I think the app is only supposed to highlight white when you are viewing that screen.  Green is for where the cursor is at, but you haven't necessarily clicked on it yet.  On the home screen the "TV"  on the top menu is highlighted white all the time.  I'm thinking the point is nothing should be white on the home screen since you aren't really viewing Movies, TV, etc

  • Like 2
Link to post
Share on other sites
FrostByte

The point was that on Homes Screen nothing needs to be highlighted.

 

gesendet von meinem Galaxy Tab S2 LTE

 

 

I think the app is only supposed to highlight white when you are viewing that screen.  Green is for where the cursor is at, but you haven't necessarily clicked on it yet.  On the home screen the "TV"  on the top menu is highlighted white all the time.  I'm thinking the point is nothing should be white on the home screen since you aren't really viewing Movies, TV, et

 

Doh!!

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...