Jump to content


Photo

emby addon kodi no library sync on wake

emby kodi sleep nuc wake library sync thread

  • This topic is locked This topic is locked
5 replies to this topic

#1 mechguy OFFLINE  

mechguy

    Advanced Member

  • Members
  • 41 posts
  • Local time: 03:47 PM

Posted 19 May 2016 - 07:00 AM

I use the Emby addon (2.2.10) with Kodi (16.1) on an Intel NUC with rapid start enabled. This allows me to keep the NUC in a sleep/powered off state but still start up in a few seconds however this means that Kodi is rarely restarted.

My Emby server is woken up with a wake on LAN add on upon wake of the NUC.

I have noticed that when waking from sleep I do not get the Emby log on notification that I receive when I open Kodi fresh.

This seems to effect real time updating of the libraries.

Playback is not effected.

 

This was not the case in previous builds of the addon where I would get either an error saying the server could not be reached or a welcome notification.

 

Is this normal behavior?



#2 xnappo OFFLINE  

xnappo

    Advanced Member

  • Developers
  • 4755 posts
  • Local time: 10:47 AM
  • LocationAustin, TX

Posted 19 May 2016 - 02:57 PM

This isn't an answer to your question - but I had a similar setup and had lots of lock up problems - unrelated to Emby.

 

I have a script on my NUC to restart Kodi on wakeup.  Not a direct answer to your question, but it would fix it...


Edited by xnappo, 19 May 2016 - 02:58 PM.


#3 mechguy OFFLINE  

mechguy

    Advanced Member

  • Members
  • 41 posts
  • Local time: 03:47 PM

Posted 19 May 2016 - 03:59 PM

Thanks for your input, that is what I will do.

I thought that since this wasn't always the case that it might be something worth reporting as a potential bug.

 

Since we have a similar setup could you share the script please?


Edited by mechguy, 19 May 2016 - 04:00 PM.


#4 xnappo OFFLINE  

xnappo

    Advanced Member

  • Developers
  • 4755 posts
  • Local time: 10:47 AM
  • LocationAustin, TX

Posted 19 May 2016 - 11:24 PM

Sure:

OpenELEC:~ # more /storage/.config/sleep.d/01-restart.power
#!/bin/sh
case "$1" in
   pre)
     ;;
   post)
     systemctl restart kodi
     ;;
esac



#5 mechguy OFFLINE  

mechguy

    Advanced Member

  • Members
  • 41 posts
  • Local time: 03:47 PM

Posted 20 May 2016 - 06:39 AM

Thanks so much for your help. Unfortunately I use a built in CEC adapter to allow my TV to control the NUC and vice versa. So when I turn on my TV it turns on the NUC, with a script like this when Kodi is restarted it turn my TV back off as it detects kodi has shut down and then on again which is not ideal.

I noticed yesterday evening I did not have this issue so I will try to hone in on what the actual issue is.



#6 mechguy OFFLINE  

mechguy

    Advanced Member

  • Members
  • 41 posts
  • Local time: 03:47 PM

Posted 21 May 2016 - 07:37 PM

It seems like adding a 4 second delay to startup on the Emby addon somewhat rectifies the syncing issue on startup although not all of the time.







Also tagged with one or more of these keywords: emby, kodi, sleep, nuc, wake, library sync thread

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users