Jump to content


Photo

Plugin for LCD/VFD Screens [Windows] Imon Replacement - using FrontView Server Plugin

imon LCD VFD FrontVIew+ USB LCD VFDs SoundGraph VFDs

  • Please log in to reply
69 replies to this topic

#21 Teddy OFFLINE  

Teddy

    Advanced Member

  • Members
  • 397 posts
  • Local time: 10:26 AM
  • LocationMadrid (SPAIN)

Posted 19 February 2016 - 12:45 PM

Glenn, I do not have enough words how was your support and explanations .... Incredible, great !!

 

With your new updates LCDSmartie works fine for me and for most Spanish people, whether it is a butcher the language, many young people in my country rarely used accents.
Now it's all legible, and even I read the synopsis without difficulty.
Again, thank you for your admirable work.


Edited by Teddy, 19 February 2016 - 12:45 PM.


#22 GlennNZ OFFLINE  

GlennNZ

    Advanced Member

  • Members
  • 319 posts
  • Local time: 07:26 PM
  • LocationAustralia

Posted 19 February 2016 - 11:57 PM

Thanks Teddy - you are more than welcome!  :D

 

Minor Fix/Update:

To LCDSmartie Plugin to version 1.0.0.4

- Correctly deals with LCDSmartie using (old) 8859-1 encoding (not UTF) This was causing issues mainly if quote "s in text stream - would convert to strange characters.  Now checks overview and function 1 for this and coverts to encoding to utf-8

 

Glenn

Attached Files


Edited by GlennNZ, 19 February 2016 - 11:59 PM.

  • Teddy likes this

#23 GlennNZ OFFLINE  

GlennNZ

    Advanced Member

  • Members
  • 319 posts
  • Local time: 07:26 PM
  • LocationAustralia

Posted 20 February 2016 - 09:33 PM

New Update:

Emby Server Plugin to 1.0.0.16 - finally fixed Jquery page load issues/current selection correctly highlighted on page entry.
 
Link at main Page
 
Cheers
 
Glenn


#24 GlennNZ OFFLINE  

GlennNZ

    Advanced Member

  • Members
  • 319 posts
  • Local time: 07:26 PM
  • LocationAustralia

Posted 22 February 2016 - 01:13 AM

Update:

FrontView+ API now in Emby Catalog (yah!)

(who is going to be first to review??  :D )

1zmi7eq.png

Current Version 1.0.0.16


Edited by GlennNZ, 22 February 2016 - 01:27 AM.

  • Luke and Teddy like this

#25 Teddy OFFLINE  

Teddy

    Advanced Member

  • Members
  • 397 posts
  • Local time: 10:26 AM
  • LocationMadrid (SPAIN)

Posted 24 February 2016 - 12:04 PM

Glenn , FrontView+ is working fantastic with Emby but for user as me using WMC, when play any video, TV recorded or Photos the VFD shows black showing none information.

It would be possible LCDSmartie displaying too information reproduced when play something from WMC folders?

I think there is not an easy solution because IMON manager Frontview is disable to work with the Emby api, but maybe you could have a solution for this.


Edited by Teddy, 24 February 2016 - 01:34 PM.


#26 GlennNZ OFFLINE  

GlennNZ

    Advanced Member

  • Members
  • 319 posts
  • Local time: 07:26 PM
  • LocationAustralia

Posted 24 February 2016 - 04:27 PM

Hi
Probably best solution is to use a wmc plugin for LCDSmartie and change between Emby and wmc screens depending on what is active.
That is possible but probably requires a bit of LCDSmartie configuration
(Particular action screens and change screen if wmc active, and vice versa for Emby)

This looks like a recent plugin for wmc (although haven't used it)
https://mcedll.codeplex.com/

Glenn


Sent from my iPad using Tapatalk

#27 Teddy OFFLINE  

Teddy

    Advanced Member

  • Members
  • 397 posts
  • Local time: 10:26 AM
  • LocationMadrid (SPAIN)

Posted 24 February 2016 - 06:50 PM

Thanks again to support, Glenn.

I'll look when I have time , trying swapping as you advice.

Regards


Edited by Teddy, 24 February 2016 - 06:54 PM.


#28 GlennNZ OFFLINE  

GlennNZ

    Advanced Member

  • Members
  • 319 posts
  • Local time: 07:26 PM
  • LocationAustralia

Posted 24 February 2016 - 10:36 PM

Thanks again to support, Glenn.
I'll look when I have time , trying swapping as you advice.
Regards

Will also have a look and see what your options might be.
(Have managed to locate a silver stone imon lcd to enable testing, wider support)
Have been looking a imon code as would like to get icons also working - so far issues with the old code and won't initialise - but still tinkering when able/no promises!
Glenn


Sent from my iPad using Tapatalk

#29 GlennNZ OFFLINE  

GlennNZ

    Advanced Member

  • Members
  • 319 posts
  • Local time: 07:26 PM
  • LocationAustralia

Posted 26 February 2016 - 02:46 AM

:lol: Teaser Photos  :lol:

 

Have iMon Icons working in LCDSmartie (and auto-off screen, and no clock override);

Still figuring out best way to get info to LCDSmartie from now updated Plugin:

56cff5d81e58e_IMG_5300.jpg

 

Hopefully post update soon.

Glenn


Edited by GlennNZ, 26 February 2016 - 02:51 AM.

  • AlwinHummels and Teddy like this

#30 GlennNZ OFFLINE  

GlennNZ

    Advanced Member

  • Members
  • 319 posts
  • Local time: 07:26 PM
  • LocationAustralia

Posted 26 February 2016 - 11:43 PM

OK

As Promised iMON Icon support:

 

Steps to update: (if already installed running etc.)

 

1.  Update your FrontView+API Emby Server Plugin to latest version 1.0.0.18  -- on Emby Catalog as of now.

 

2.  Download the attached zip.

 

3,  Replace iMON_OEM_LCD.dll in LCDSmartie/displays directory with the one attached.

(this is a replacement dll from dgBruce over in SageTV - enables Icon support by using Fan(num,num) command of LCDSmartie.

the readme is included for those that need to customise)

 

4.  Replace FrontViewLCDSmartie.dll in the LCDSmartie/plugins directory with this new 1.0.0.5 version.

(Adds a few more commands to deal with number of speakers, codecs etc. - detailed in updated first page)

 

4.  Replace config.ini with the one is this package to enable Icon support.

(Icon support uses a lot of actions - ie. turn on icon, turn off icon etc..  there appears a issue with LCDSmartie where it cannot save above 17 actions to the config.ini file.  To go above this number the config.ini file needs to be manually edited. )

 

5. Run LCD Smartie

: Select the new iMON_OEM_LCD.dll

(As before need to copy the SG_VGD.dll into LCDSmartie main directory)

 

6.  Configure the Display

56d11a90117c1_NewOEM_LCDdllsettings.png

 

 

NB: the new Startup Parameters

Suggest - leave as is.

This will turn off/blank/no backlight the display when LCDSmartie exits.

 

 

Thanks

 

Please post pictures if can - as you can see couple of posts above - my new Silverstone iMON LCD is defective - doesn't include top icons or L/C/R speaker icons.  I have disassembled and they are simply not on the printed LCD.   Probably not worth the effort to return - but means hard to test those icons.

 

Glenn

 

 

 

 

Attached Files



#31 Teddy OFFLINE  

Teddy

    Advanced Member

  • Members
  • 397 posts
  • Local time: 10:26 AM
  • LocationMadrid (SPAIN)

Posted 27 February 2016 - 02:33 PM

Glenn, when I was going to start setting your changes (thanks), the MediaBrowser.Plugins.FrontView.dll seems it is corrupted from the catalog, its size is 28,672 bytes, where the previous version was 44,032 bytes. So is not available in My Plugins.

Please solve from catalog or attach the dll to the topic.

Regards


Edited by Teddy, 27 February 2016 - 03:25 PM.


#32 GlennNZ OFFLINE  

GlennNZ

    Advanced Member

  • Members
  • 319 posts
  • Local time: 07:26 PM
  • LocationAustralia

Posted 27 February 2016 - 05:44 PM

Glenn, when I was going to start setting your changes (thanks), the MediaBrowser.Plugins.FrontView.dll seems it is corrupted from the catalog, its size is 28,672 bytes, where the previous version was 44,032 bytes. So is not available in My Plugins.
Please solve from catalog or attach the dll to the topic.
Regards

Yikes!
Fixed 1.0.0.18 file and to be sure/push update to all added new 1.0.0.19
In catalog now.
Glenn

#33 Teddy OFFLINE  

Teddy

    Advanced Member

  • Members
  • 397 posts
  • Local time: 10:26 AM
  • LocationMadrid (SPAIN)

Posted 28 February 2016 - 12:16 PM

Sorry Glenn but is not working for me.

After configure and follow the configuration steps up to 5 times it provides a DLL initialization problem that does not find SG-VFD.dll although in the directory.

I compressed all the Smartie directory if you want to take a look.

 

https://mega.nz/#!4c...D3TXgC0zFDkcywA

 

 



#34 GlennNZ OFFLINE  

GlennNZ

    Advanced Member

  • Members
  • 319 posts
  • Local time: 07:26 PM
  • LocationAustralia

Posted 28 February 2016 - 04:24 PM

Thanks for files.
Hmm. Getting the same error when run your setup/files.

Thought it might be version of SG_VFD.dll -- but on further testing wasn't the cause of issue.

Appears to be fixed by reselecting the display dll and then selecting again.
Go back in LCDSmartie display Plugin, select another dll apply, and then reselect iMON_OEM_LCD.dll - this works for me with all your files and error is gone.

Glenn

(have attached another version of SG_VFD.dll - but shouldn't need it)

Attached Files


Edited by GlennNZ, 28 February 2016 - 07:35 PM.


#35 Teddy OFFLINE  

Teddy

    Advanced Member

  • Members
  • 397 posts
  • Local time: 10:26 AM
  • LocationMadrid (SPAIN)

Posted 28 February 2016 - 10:31 PM

Glenn, I selecting another display dll and then selecting iMON_OEM_LCD.dll again and fixed the SG-VFD.dll problem as you already said.

But LCDSmartie only is working fine when played from Emby (like before) . If I play any movie or recorded TV from WMC the LCDSmartie only shows Emby and date, and the VFD shows the last info Emby played.

I don't know if problem could be vfd's firmware or something.
You could send me please your whole directory structure Smartie and so try it on my machine to find out for sure?
Thanks again for your patience.



#36 GlennNZ OFFLINE  

GlennNZ

    Advanced Member

  • Members
  • 319 posts
  • Local time: 07:26 PM
  • LocationAustralia

Posted 28 February 2016 - 10:40 PM

Glenn, I selecting another display dll and then selecting iMON_OEM_LCD.dll again and fixed the SG-VFD.dll problem as you already said.
But LCDSmartie only is working fine when played from Emby (like before) . If I play any movie or recorded TV from WMC the LCDSmartie only shows Emby and date, and the VFD shows the last info Emby played.
I don't know if problem could be vfd's firmware or something.
You could send me please your whole directory structure Smartie and so try it on my machine to find out for sure?
Thanks again for your patience.


This doesn't change the fact that there is no WMC plugin. There are some around for LCDSmartie but they seem a bit complicated.
WMC is dead and unsupported. Writing a plugin for it (which would be complicated) doesn't seem like a good use of time.

This update enables icons for Imon displays - but does not change the unsupported nature of WMC.

Hope that clarifies.
Glenn

#37 Teddy OFFLINE  

Teddy

    Advanced Member

  • Members
  • 397 posts
  • Local time: 10:26 AM
  • LocationMadrid (SPAIN)

Posted 29 February 2016 - 08:22 AM

I understand your explanations Glenn.

It's a shame that LCDSmartie not supports WMC. The only reason to use Windows 7 is due WMC whose support ends in 2020.

When finalize hope that Microsoft has raised a new version of Windows with something like WMC or perhaps will change my approach to any HTPC Linux-based platform. I do not know, is a long time to think about a replacement for WMC now.

Anyway thanks for your concern and fantastic support.



#38 jsbarde OFFLINE  

jsbarde

    Member

  • Members
  • 17 posts
  • Local time: 04:26 AM

Posted 11 March 2016 - 12:00 AM

After a bunch of trial and error I got this to work on my Antec Fusion v2 VFD (The silver case) on Windows 10 x64 with the following:

 

In LCD Smartie:

Screens Tab:

Display Plugin: imond.dll (must close imon software first, if you have it set to auto start on bootup like I did you should disable it.)

LCD Size: 2x16

 

 

Startup/Shutdown Tab:

I selected Autostart hidden and this seems to work fine, as it starts each time the pc boots and reconnects.  

 

So far it's worked pretty well for me. Big thanks to Glenn for all his hard work! 



#39 AndreasL OFFLINE  

AndreasL

    Newbie

  • Members
  • 7 posts
  • Local time: 10:26 AM
  • LocationGermany

Posted 05 April 2016 - 04:26 PM

Thank you so much Glenn.This works like a charm!

Took me only about 45 minutes to setup everything and now shows exactly what I want on OrigenAE S14V irtrans VFD display with Windows 10 x64 and Emby Theater.

 

You are great! Keep on your good work!

 

Best Regards from Germany,

Andreas



#40 GlennNZ OFFLINE  

GlennNZ

    Advanced Member

  • Members
  • 319 posts
  • Local time: 07:26 PM
  • LocationAustralia

Posted 10 April 2016 - 02:46 AM

So far it's worked pretty well for me. Big thanks to Glenn for all his hard work! 

 

 

Thank you so much Glenn.This works like a charm!

Took me only about 45 minutes to setup everything and now shows exactly what I want on OrigenAE S14V irtrans VFD display with Windows 10 x64 and Emby Theater.

 

You are great! Keep on your good work!

 

Best Regards from Germany,

Andreas

 

Happy to hear all is working well!

 

All the best

 

Glenn







Also tagged with one or more of these keywords: imon, LCD, VFD, FrontVIew+, USB LCD, VFDs, SoundGraph VFDs

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users