Jump to content
GlennNZ

Plugin for LCD/VFD Screens [Windows] Imon Replacement - using FrontView Server Plugin

Recommended Posts

GlennNZ

Hi

Probably best solution is to use a wmc plugin for LCDSmartie and change between Emby and wmc screens depending on what is active.

That is possible but probably requires a bit of LCDSmartie configuration

(Particular action screens and change screen if wmc active, and vice versa for Emby)

 

This looks like a recent plugin for wmc (although haven't used it)

https://mcedll.codeplex.com/

 

Glenn

 

 

Sent from my iPad using Tapatalk

Share this post


Link to post
Share on other sites
Teddy

Thanks again to support, Glenn.

I'll look when I have time , trying swapping as you advice.

Regards

Edited by Teddy

Share this post


Link to post
Share on other sites
GlennNZ

Thanks again to support, Glenn.

I'll look when I have time , trying swapping as you advice.

Regards

Will also have a look and see what your options might be.

(Have managed to locate a silver stone imon lcd to enable testing, wider support)

Have been looking a imon code as would like to get icons also working - so far issues with the old code and won't initialise - but still tinkering when able/no promises!

Glenn

 

 

Sent from my iPad using Tapatalk

Share this post


Link to post
Share on other sites
GlennNZ

:lol: Teaser Photos  :lol:

 

Have iMon Icons working in LCDSmartie (and auto-off screen, and no clock override);

Still figuring out best way to get info to LCDSmartie from now updated Plugin:

56cff5d81e58e_IMG_5300.jpg

 

Hopefully post update soon.

Glenn

Edited by GlennNZ
  • Like 2

Share this post


Link to post
Share on other sites
GlennNZ

OK

As Promised iMON Icon support:

 

Steps to update: (if already installed running etc.)

 

1.  Update your FrontView+API Emby Server Plugin to latest version 1.0.0.18  -- on Emby Catalog as of now.

 

2.  Download the attached zip.

 

3,  Replace iMON_OEM_LCD.dll in LCDSmartie/displays directory with the one attached.

(this is a replacement dll from dgBruce over in SageTV - enables Icon support by using Fan(num,num) command of LCDSmartie.

the readme is included for those that need to customise)

 

4.  Replace FrontViewLCDSmartie.dll in the LCDSmartie/plugins directory with this new 1.0.0.5 version.

(Adds a few more commands to deal with number of speakers, codecs etc. - detailed in updated first page)

 

4.  Replace config.ini with the one is this package to enable Icon support.

(Icon support uses a lot of actions - ie. turn on icon, turn off icon etc..  there appears a issue with LCDSmartie where it cannot save above 17 actions to the config.ini file.  To go above this number the config.ini file needs to be manually edited. )

 

5. Run LCD Smartie

: Select the new iMON_OEM_LCD.dll

(As before need to copy the SG_VGD.dll into LCDSmartie main directory)

 

6.  Configure the Display

56d11a90117c1_NewOEM_LCDdllsettings.png

 

 

NB: the new Startup Parameters

Suggest - leave as is.

This will turn off/blank/no backlight the display when LCDSmartie exits.

 

 

Thanks

 

Please post pictures if can - as you can see couple of posts above - my new Silverstone iMON LCD is defective - doesn't include top icons or L/C/R speaker icons.  I have disassembled and they are simply not on the printed LCD.   Probably not worth the effort to return - but means hard to test those icons.

 

Glenn

 

 

 

 

LCDSmart Fontview iMON Icon support.zip

Share this post


Link to post
Share on other sites
Teddy

Glenn, when I was going to start setting your changes (thanks), the MediaBrowser.Plugins.FrontView.dll seems it is corrupted from the catalog, its size is 28,672 bytes, where the previous version was 44,032 bytes. So is not available in My Plugins.

Please solve from catalog or attach the dll to the topic.

Regards

Edited by Teddy

Share this post


Link to post
Share on other sites
GlennNZ

Glenn, when I was going to start setting your changes (thanks), the MediaBrowser.Plugins.FrontView.dll seems it is corrupted from the catalog, its size is 28,672 bytes, where the previous version was 44,032 bytes. So is not available in My Plugins.

Please solve from catalog or attach the dll to the topic.

Regards

Yikes!

Fixed 1.0.0.18 file and to be sure/push update to all added new 1.0.0.19

In catalog now.

Glenn

Share this post


Link to post
Share on other sites
GlennNZ

Thanks for files.

Hmm. Getting the same error when run your setup/files.

 

Thought it might be version of SG_VFD.dll -- but on further testing wasn't the cause of issue.

 

Appears to be fixed by reselecting the display dll and then selecting again.

Go back in LCDSmartie display Plugin, select another dll apply, and then reselect iMON_OEM_LCD.dll - this works for me with all your files and error is gone.

 

Glenn

 

(have attached another version of SG_VFD.dll - but shouldn't need it)

SG_VFD.zip

Edited by GlennNZ

Share this post


Link to post
Share on other sites
Teddy

Glenn, I selecting another display dll and then selecting iMON_OEM_LCD.dll again and fixed the SG-VFD.dll problem as you already said.

But LCDSmartie only is working fine when played from Emby (like before) . If I play any movie or recorded TV from WMC the LCDSmartie only shows Emby and date, and the VFD shows the last info Emby played.

I don't know if problem could be vfd's firmware or something.
You could send me please your whole directory structure Smartie and so try it on my machine to find out for sure?
Thanks again for your patience.

Share this post


Link to post
Share on other sites
GlennNZ

Glenn, I selecting another display dll and then selecting iMON_OEM_LCD.dll again and fixed the SG-VFD.dll problem as you already said.

But LCDSmartie only is working fine when played from Emby (like before) . If I play any movie or recorded TV from WMC the LCDSmartie only shows Emby and date, and the VFD shows the last info Emby played.

I don't know if problem could be vfd's firmware or something.

You could send me please your whole directory structure Smartie and so try it on my machine to find out for sure?

Thanks again for your patience.

This doesn't change the fact that there is no WMC plugin. There are some around for LCDSmartie but they seem a bit complicated.

WMC is dead and unsupported. Writing a plugin for it (which would be complicated) doesn't seem like a good use of time.

 

This update enables icons for Imon displays - but does not change the unsupported nature of WMC.

 

Hope that clarifies.

Glenn

Share this post


Link to post
Share on other sites
Teddy

I understand your explanations Glenn.

It's a shame that LCDSmartie not supports WMC. The only reason to use Windows 7 is due WMC whose support ends in 2020.

When finalize hope that Microsoft has raised a new version of Windows with something like WMC or perhaps will change my approach to any HTPC Linux-based platform. I do not know, is a long time to think about a replacement for WMC now.

Anyway thanks for your concern and fantastic support.

Share this post


Link to post
Share on other sites
jsbarde

After a bunch of trial and error I got this to work on my Antec Fusion v2 VFD (The silver case) on Windows 10 x64 with the following:

 

In LCD Smartie:

Screens Tab:

Display Plugin: imond.dll (must close imon software first, if you have it set to auto start on bootup like I did you should disable it.)

LCD Size: 2x16

 

 

Startup/Shutdown Tab:

I selected Autostart hidden and this seems to work fine, as it starts each time the pc boots and reconnects.  

 

So far it's worked pretty well for me. Big thanks to Glenn for all his hard work! 

Share this post


Link to post
Share on other sites
AndreasL

Thank you so much Glenn.This works like a charm!

Took me only about 45 minutes to setup everything and now shows exactly what I want on OrigenAE S14V irtrans VFD display with Windows 10 x64 and Emby Theater.

 

You are great! Keep on your good work!

 

Best Regards from Germany,

Andreas

Share this post


Link to post
Share on other sites
GlennNZ

So far it's worked pretty well for me. Big thanks to Glenn for all his hard work! 

 

 

Thank you so much Glenn.This works like a charm!

Took me only about 45 minutes to setup everything and now shows exactly what I want on OrigenAE S14V irtrans VFD display with Windows 10 x64 and Emby Theater.

 

You are great! Keep on your good work!

 

Best Regards from Germany,

Andreas

 

Happy to hear all is working well!

 

All the best

 

Glenn

Share this post


Link to post
Share on other sites
hedgehogg

Not sure if this is a silly question :( 

Do I need Imon running as well or does this replace it?

Share this post


Link to post
Share on other sites
GlennNZ

Hi

Depends!   :)   (both are possible)

But depends on your LCD screen and what dll is compatible with it.

Most here as posted back a page seem to run it without imon (and that was my main reason to get rid of dodgy old code that is imon)

 

Glenn

Share this post


Link to post
Share on other sites
NOCHTPC

I have frontview+ setup and kodi inputted in the remote server for frontview+.  I can't seem to get Emby to work, I installed the plugin in my server but when I go to frontview+ and try and input Emby as the remote server and the local server ip for the remote server ip in frontview+(tried remote access ip for remote server ip in frontview+) and I put the port for emby which is 8096, I click verify and nothing happens.  I tried restarting and still nothing.  Any ideas?

Share this post


Link to post
Share on other sites
GlennNZ

I have frontview+ setup and kodi inputted in the remote server for frontview+.  I can't seem to get Emby to work, I installed the plugin in my server but when I go to frontview+ and try and input Emby as the remote server and the local server ip for the remote server ip in frontview+(tried remote access ip for remote server ip in frontview+) and I put the port for emby which is 8096, I click verify and nothing happens.  I tried restarting and still nothing.  Any ideas?

Probably need a bit more info.

 

Are you in the right thread?  Are you using FrontView+ the application or LCD/FrontView+ API Plugin only?

 

As with LCD one - there is no where to enter details in FrontView+

 

Screenshots or log would be helpful.

 

Glenn

Share this post


Link to post
Share on other sites
NOCHTPC

578938d2b25ce_Untitled.png

This is what I am talking about, as you can see in the background I got kodi to work with frontview+ but emby is not responding to the info.

Share this post


Link to post
Share on other sites
GlennNZ

Ok, wrong thread then.

 

You need to enter those boxes - for Emby because it is a server based app (unlike Kodi) you need to enter the server IP in the remote IP setting, along with appropriate Emby username and password.

 

Glenn

Share this post


Link to post
Share on other sites
NOCHTPC

I did, I entered EMBY as the remote name, then I entered the local access ip number from my emby server for remote ip, then the port # which in emby is 8096, then I clicked get from ip for the mac address, and typed the username and password for emby connect since i don't use a password for logging into emby server.  I get error bad parameters.

Share this post


Link to post
Share on other sites
GlennNZ

I did, I entered EMBY as the remote name, then I entered the local access ip number from my emby server for remote ip, then the port # which in emby is 8096, then I clicked get from ip for the mac address, and typed the username and password for emby connect since i don't use a password for logging into emby server. I get error bad parameters.

Hi

Need to set up emby user for Frontview

 

Pretty sure emby connect details won't work and probably cause of issue.

 

Also don't worry about MAC address - is not needed and can be left blank (can be used for wake up via LAN) but would get connection working.

 

If still have issues turn on debug and trace logging and restart - and try to connect again - pm me zipped log and happy to have a look.

 

Glenn

 

 

Sent from my iPhone using Tapatalk

Edited by GlennNZ

Share this post


Link to post
Share on other sites
NOCHTPC

Still not working,  I will pm you the log, thanks.

Share this post


Link to post
Share on other sites
NOCHTPC

GlennNZ, just sent you the log.  Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...