Jump to content
Sign in to follow this  
metaman

Issues with subtitles

Recommended Posts

metaman

There are some issues with the subtitles I'd like your thoughts on. I have not been doing any extensive testing, but it shall seem the issue at least arises during playback using Chrome webrowser. Quick, rough testing done with Emby Android App on a couple of files, reveal the issue seems not appear there. I have only done very basic preliminary testing, but it shall seem that SRT subtitles embedded into an MKV container does not function the way one would expect it to. 

 

I am referring to browser Chrome and Emby 3.0.5781.8. I have in my profile set English subtitles to be chosen during playback. During testing on at the very least 5 video files, I encounter more than one issue. First, during video playback, the english subtitles are applied as expected, but they are applied twice; meaning, each line of subtitle is repeated twice. That is, the subtitles are duplicated. Line 1 would be repeated on line 2 or line 1 and 2 would be repeated on line 3 and 4. If i weren't so damned lazy, I'd provide a picture of how it looks. Furthermore, it would seem that changing the subtitle language doesn't work with the embedded SRT subs. That is, I change the language via the menu in Chrome, but the expected change is not applied. It would appear there's no way to change them at all. Additionally and although it's been stated, it will seem that files with embedded subtitles are processed significantly slower than those files who are without subs. I suppose I am wondering whether Emby Team has planned an overhaul on the system that takes care of embedded subtitles. I acknowledge that my testing has been very limited and there are things I could have missed, but the issue is so dominant that I'll have to find ways to make it more performance and user friendly. Could my options be of looking into ways to exttract subs from the mkv and make them external? Or would you know if the issue arise due to the MKV file itself containing embedded subtitles?

 

Thank you for your consideration,

Thomas 

Share this post


Link to post
Share on other sites
Luke

I don't know what you mean by changing the language but the user language setting is a preference. We do not currently offer any way to change the audio language of an embedded subtitle track. The only way to do this is by remuxing the file.

 

Embedded subtitles can be slower the first time they are accessed because we extract them to a text file and then store the result for future use. This process only happens once per subtitle. On some systems it only takes a second or two, on others it can take much longer, but it is currently the best method available because the browsers do not support embedded subtitle tracks. 

 

The reason why the android app does not exhibit this behavior is because it can handle embedded subtitle tracks without requiring the server to pre-extract them. In general, if you want to stream lots to lots of different browsers and devices, then external subtitles are much more efficient.

 

as far as the repeated lines, please provide a screenshot.

Share this post


Link to post
Share on other sites
metaman

Thanks Luke, for taking the time to respond. Noteworthy. I am by far not competent enough to be making conclusions, but I will admit to strongly feeling, that the way embedded SRT subtitles are dealt with by the Emby, has made me think "oh shit, what do I do. This is embarrassing". Understand me correctly, but this is not how I want my mother to experience this otherwise orgasmically beautiful piece of technology. As I've said, I'm only in the preliminary phases of testing, but thus far it shall seem that something, somwhere has royally been overlooked. Embedded subtitles appear to be completely broken for a given set of circumstances. I have been able to gather from another user that these embedded subs are also malfunctioning in the Emby android app. Skimming through the logs, I've witnessed a sizeable count of errors that all to varying degrees appear to be related to playback of these MKV files with SRTs embedded into them. I don't mean to bell any alarms, but I'd really appreciate feedback on how to tackle this issue that simply serves to break the system. I'm running on a high-end Xeon and the time it takes to process these files are within the tens of seconds to minutes range. That can not be. Not for a lousy couple(actually more than ten) of embedded subtitles. Please enlighten me and tell me what I can do to make this go away. Meanwhile I'll attach some screenshots from a couple of titles I tested with.

 

edit: I'll report back once I have something more concrete. I'd appreciate hints on how to test, where to look if those might aid to speed  the process towards a solution.

post-2780-0-53083900-1451095059_thumb.png

post-2780-0-67398400-1451095068_thumb.png

post-2780-0-62468000-1451095086_thumb.png

post-2780-0-74789400-1451095101_thumb.png

post-2780-0-93854900-1451095115_thumb.png

post-2780-0-41524800-1451095129_thumb.png

Edited by metaman

Share this post


Link to post
Share on other sites
metaman

Thank you.

 

I will look into it and come back with a clearer description once I have as well as the logs you request. It's diffuse what's really happening, whether I'm dealing with a separate issue or if they are multiple issues coming together; nor is it clear to what extent. My friend reported yesterday evening that subtitles weren't working on his Emby Android app, but he was mostly able to get them to work in Chrome by turning them on and off, playing around until the server somehow got them right. This was a bit contrary to my own findings during preliminary testing, where subtitles appeared working as expected in Emby Android app and not so much in Chrome.

 

Futhermore, I'd like to add, not only as a critique, but also because it might be of significance towards this issue arising in the first place. Using Emby's subtitle system(the one that grabs subtitles from OpenSubtitles) without thorougly testing and understanding how it worked first, I've recently had no other way than to delete a count in the thousands of SRT files that had populated my media folders. Thus, I just want to make sure that abruptly deleting these SRT files without Emby's knowing; won't have a later impact on the processing of the corresponding media file(does that even make sense?). If Movie A, has an external SRT subtitle, then deleting it won't affect how Emby later handles that file. Ugh.

 

The critique is that Emby's subtitle system isn't as smart as it should be. Correct me if I'm wrong, the way I understand it to work now, is that it takes file's hash and look for it on OpenSubtitles. If no hash is found then Emby will make a guess and download the subtitle it best thinks is a match. That's the gist, right? If so, please don't. Just don't. Better is; if hash is found, then download subtitle. If no hash is found then store the results and let the user decide how to deal with it. The default can not be to let Emby decide what happens if no hash match is found. The very minimum should be to not download subtitles at all if hash isn't found. As things are being handled now, the accuracy isn't high enough to justify a default of letting Emby guess which subtitle to download. A finer granularity is required before such a default becomes a viable alternative. 

 

As a consequence of the current subtitle implementation, I recently found myself deleting a gigabyte's worth of externally downloaded SRT files. It's too unpredictable. While some subtitles are a good, perfect, synchronized match, many are just plain wrong. I've no idea to tell them apart and the viewers suffer as a result. I want a smooth, hassle-free, worry-free playback experience for my users, so my only choice was to delete all files with an SRT extension and start on new with a revised design. For this revision, my media files will have their subtitles embedded into them.

 

I'm aware I belong to a category of users that is a niché of a niché, if that makes any sense, but we all want a great product. Also, I hate to be the one producing long boring texts, boasting my opinions as important(they are not), but I really admire the gang working to make this beautiful technology available to me and the possibilities it brings. The thread's topic being what it is, allow me anyhow to use this post as an opportunity to addtionally voice my critique, complaint and opinion. Maybe it shall serve to improve my situation. At least let it be known that my group of users exist.

 

Emby has come a long way since its inception and grown in all kinds of directions. I've no idea of its resources or its organization. To me, Emby is what I use to organize my media. 60TB of it. It's also the superiorly preferred way of making this media available to my friends and family who will frequently be accessing the service; and Emby is a common conversation topic among them. They are all intrigued. About 20 of them. Hailing from non-English destinations, but also for other reasons, my users like subtitles. They are important and the experience is not the same without. Apparently, it shall seem that subtitles is really difficult to do well and it appears to require a great number of problems to be solved. Truth be told, subtitles appear to complicate everything where they're involved. A huge mystery.

 

For the years of using this service now, I have yet to be convinced that subtitles are done right by Emby. There's always been this slight, lingering fear/worry/concern that the subs will act up and it's difficult to predict why or when without digging really deep into it, which is more than I am willing to do. It's better to write off the files that aren't dealt with properly and accept that maybe they're gonna work in the future when things are more stable. For the most part, subtitles usually work if you're careful not to mess around with them through the Emby playback interface. Playing around with them, turning them on and off, switching the languages back and forth will -- and of course anecdoctal -- in not an insignificant number of cases interrupt the playback experience. In a majority of cases it works as expected, but the opposite cases are many enough to leave me pondering on how to deal with it alltogether.

 

Likelihood of smooth playback experience appears increasing if the user has set a default subtitle to playback on start in her profile menu settings, while setting them manually during playback will decrease those chances. In general, I can't trust that they will work as expected; I can only hope, which just isn't good enough. I won't have this worry and I don't want my users questioning me about these things. I want a system that works, that I can set, forget and regard as a natural tool in my life. Oh, and I demanding a lot, but I'm sure we all want the same while we all understand it will take time to get there.

 

In the event, I should have been honoured with your attention and kept you reading though my garbage, thank you for your patience, time, consideration. It's with happiness I see Emby growing up to become a respectable player and I understand there are priorities of which I can't be aware of, but I'd be very interested in learning what the status of subtitles is or whether thougths have gone into finding more accurate solutions on the problem as a whole. If you recall from earlier, I have decided to change the state of my MKV media from being a mixture of embedded and external SRT files to a state where subtitles will purely be in the embedded format. While still keeping it open that these issues are due to faults on my end and not the Emby system itself that's not the assumption I'm working with. Preliminary testing indicates that Emby can't handle MKV files with numerous(not sure if count has a significane) subtitles included in them. Performance is too slow, functionality isn't working and the playback experience is unacceptable. I could be interested in finding a solution, if I knew what the problem was. There's an MKV, it's got subtitles in it. Why is that difficult to deal with? Extracting the subtitles from the MKV, turning them into external entities is not the problem. The problem is having subtitles that are synchronized, which is a problem solved with embedded subtitles. 

 

Well, that is all. I'm embarrassed to have put you through this, but I'm really excited by getting my system up and working the way it should be working and for that there some problems I must solve. Thank you for reading, thank you for aiding, assisting or otherwise being helpful.

 

I'll come up with logs as agreed at a later time

 

meanwhile,

merry x-mas

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...