Jump to content

password reset


allison.proudfoot
 Share

Recommended Posts

allison.proudfoot

I cannot get my password to reset. I am able to get the page that comes up and gives you your link & pin. However, when I open the link I am redirected to the page where you enter the pin but only for a spilt second, it then redirects me to the log in page where it asks for user name and password. It won't let me stay on the pin page long enough to enter the pin. 

 

I have tried uninstalling and reinstalling but it didn't work. I think i have the latest version 3.05781.1. I have tired using firefox and chrome. 

Link to comment
Share on other sites

Hi there,

I just tested this and it seemed to work fine, but let me ask you. If you uninstalled and reinstalled, weren't you presented with the server startup wizard? If that's the case then the password reset is kind of a moot point because there's no longer anything to rest.

Link to comment
Share on other sites

allison.proudfoot

No when I reinstalled it automatically logged my information in, the start up wizard did not ask for any of my log in information.  I cannot access my library online. Its very strange. I can open the server, I can access it using my roku and watch movies off my tv, but it won't update my library when I have new content. I need to be able to log into the library online and get it to update the library, but I can't log in because it won't allow me to reset my password. I might work fine for you when you try to reset but it is not working for me. I have had this problem for a month now. 

Link to comment
Share on other sites

Ok, so if I understand correctly you can login with emby apps such as Roku but you can't get into the web interface? Have you tried signing into the web interface with a blank password? If you just reinstalled the server there would be no password unless you went and added one. Have you tried that?

Link to comment
Share on other sites

allison.proudfoot

The only reason I am able to access it through my roku is because it has not prompted me for a password. I have tried it with a blank password it won't work. 

Link to comment
Share on other sites

  • 2 weeks later...
david smith

I'm experiencing the exact same issue as the OP:

- I cannot reset my admin password as the pin entry screen
  (forgotpasswordpin.html) exits/redirects immediately.

- server: 3.0.5781.3-1 (arch linux package)
- client: firefox 42.0-2 (clean profile, no add-ons)
- connecting to the exact address shown in passwordreset.txt

(Note: I also tried the 'forgot password' process with the android app, but
that enters a loop submitting the username.)

Is there a way to reset the password from the commandline?
 

Link to comment
Share on other sites

Thanks for the report. I've resolved this issue for the next release of the server. We'll have a patch release coming in a couple days. In the meantime you could delete your user database file if you don't mind a destructive process, it's in the server's program data folder /data/users.db

Link to comment
Share on other sites

david smith

Thanks Luke!  (I ended up editing the user database to regain access :))

 

Also, I imagine this is already on a TODO somewhere, but you may want to revisit storing passwords as "sha1(password)".

 

Thanks again for a great project!

Link to comment
Share on other sites

  • 2 months later...

I still have this issue. Kind of annoying. Deleting users.db is not really an option for me.

 

Hi, sorry to hear this, but in order for us to help you, please describe your issue in detail by seeing how to report a problem. Thanks.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...