Jump to content

Raspberry Pi


Luke

Recommended Posts

I installed it this morning.

 

Installation went fine, just followed the instructions and started the emby-service.

 

Generating the images in the web client isn't very fast, but that's not the biggest issue.

 

The biggest issue for me is that I'm not able to play anything using the Web Client or MB Theater. I think ffprobe is not working, since the Extra's have no details:

 

56373856b583c_nan.jpg

 

and there is no media information available. It only shows the container and the path to the file.

 

When running  /var/lib/emby-server/ffmpeg/20150917/ffprobe this output is generated:

 

/var/lib/emby-server/ffmpeg/20150917/ffprobe: error while loading shared libraries: libass.so.4: cannot open shared object file: No such file or directory

 

running /var/lib/emby-server/ffmpeg/20150917/ffmpeg gives the same output

Edited by djonnie
Link to post
Share on other sites

I also needed to add an "On application startup" trigger for the "Scan Media Library" scheduled task to have movies to show up in the Web Client.

Link to post
Share on other sites
hurricanehrndz

I installed it this morning.

 

Installation went fine, just followed the instructions and started the emby-service.

 

Generating the images in the web client isn't very fast, but that's not the biggest issue.

 

The biggest issue for me is that I'm not able to play anything using the Web Client or MB Theater. I think ffprobe is not working, since the Extra's have no details:

 

56373856b583c_nan.jpg

 

and there is no media information available. It only shows the container and the path to the file.

 

When running  /var/lib/emby-server/ffmpeg/20150917/ffprobe this output is generated:

 

/var/lib/emby-server/ffmpeg/20150917/ffprobe: error while loading shared libraries: libass.so.4: cannot open shared object file: No such file or directory

 

running /var/lib/emby-server/ffmpeg/20150917/ffmpeg gives the same output

Thank you. Did you try and install the library that is missing?

Link to post
Share on other sites

Tried sudo apt-get install libass4, but got an error "Unable to locate package libass4"

 

I'm not sure if this is correct though, since I don't use Linux very often

 

Building ffmpeg from source and then running the exe with the -ffprobe and -ffmpeg parameters works, but this is a very slow process

Edited by djonnie
Link to post
Share on other sites
hurricanehrndz

Tried sudo apt-get install libass4, but got an error "Unable to locate package libass4"

 

I'm not sure if this is correct though, since I don't use Linux very often

 

Building ffmpeg from source and then running the exe with the -ffprobe and -ffmpeg parameters works, but this is a very slow process

Thank you for your feedback. We will try and resolve the issue with ffmpeg.

 

PS what distribution are you using?

Edited by hurricanehrndz
Link to post
Share on other sites

On a fresh Raspbian (Jessie) install, this code:

sudo echo "deb-armhf http://ports.ubuntu.com/ trusty main restricted universe multiverse" > /etc/apt/sources.list.d/trusty.listcat << EOF | sudo tee -a /etc/apt/prefereces.d/trusty.pref
Package: *
Pin: release a=trusty
Pin-Priority: 10
EOF
apt-get -t trusty install libtiff5

Will return this error:

-bash: /etc/apt/sources.list.d/trusty.listcat: Toegang geweigerd
tee: /etc/apt/prefereces.d/trusty.pref: Bestand of map bestaat niet

 

Link to post
Share on other sites

I'm also using Raspbian Jessie.

 

Not sure if it's related to this problem, but the Raspberry's default runs on an useraccount "pi". During installation of emby-server there's a (text-based) screen where a username "emby" is suggested. I didn't change it, not sure if this is necessary.

 

Another issue I'm having is that the chapter images are not extracted. When I run the scheduled task it finishes in 0 seconds.

 

From the log file (IP address removed):

 

2015-11-04 20:24:21.1871 Info - HttpServer: HTTP GET http://---.---.---.---:8096/emby/ScheduledTasks?isHidden=false
        Ip: ---.---.---.---:61325. Headers: Host=---.---.---.---:8096,User-Agent=Mozilla/5.0 (Windows NT 10.0; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0,Accept=application/json, text/javascript, */*; q=0.$
2015-11-04 20:24:21.2179 Info - HttpServer: HTTP Response 200 to ---.---.---.---. Time: 30ms. http://---.---.---.---:8096/emby/ScheduledTasks?isHidden=false
2015-11-04 20:24:28.9525 Info - HttpServer: HTTP POST http://---.---.---.---:8096/emby/ScheduledTasks/Running/0c5b02d9cff045cc0d813394df65dcad
        Ip: ---.---.---.---:61325. Headers: Host=---.---.---.---:8096,User-Agent=Mozilla/5.0 (Windows NT 10.0; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0,Accept=*/*,Accept-Language=nl,en-US;q=0.7,en;q=0.3,$
2015-11-04 20:24:28.9627 Info - App: Executing Chapter image extraction
2015-11-04 20:24:29.3550 Info - App: Chapter image extraction Completed after 0 minute(s) and 0 seconds
 

Link to post
Share on other sites
hurricanehrndz

The user is not an issue, in terms of chapters it seems there might be an issue with the ffmpeg we are distributing on arm, we are trying to track it down.

 

Sent from my D6603 using Tapatalk

Link to post
Share on other sites
hurricanehrndz

 

On a fresh Raspbian (Jessie) install, this code:

sudo echo "deb-armhf http://ports.ubuntu.com/ trusty main restricted universe multiverse" > /etc/apt/sources.list.d/trusty.listcat << EOF | sudo tee -a /etc/apt/prefereces.d/trusty.pref
Package: *
Pin: release a=trusty
Pin-Priority: 10
EOF
apt-get -t trusty install libtiff5

Will return this error:

-bash: /etc/apt/sources.list.d/trusty.listcat: Toegang geweigerd
tee: /etc/apt/prefereces.d/trusty.pref: Bestand of map bestaat niet

Instructions were printed wrongly.

 

Please copy and paste this to terminal:

echo "deb-armhf http://ports.ubuntu.com/ trusty main restricted universe multiverse" > /etc/apt/sources.list.d/trusty.list

Followed by:

cat << EOF | sudo tee -a /etc/apt/prefereces.d/trusty.pref
Package: *
Pin: release a=trusty
Pin-Priority: 10
EOF
apt-get -t trusty install libtiff5
Edited by hurricanehrndz
Link to post
Share on other sites

Got this at the first command:

pi@raspberrypi ~ $ sudo echo "deb-armhf http://ports.ubuntu.com/ trusty main restricted universe multiverse" > /etc/apt/sources.list.d/trusty.list
-bash: /etc/apt/sources.list.d/trusty.list: Permission denied
Link to post
Share on other sites
hurricanehrndz

 

Got this at the first command:

pi@raspberrypi ~ $ sudo echo "deb-armhf http://ports.ubuntu.com/ trusty main restricted universe multiverse" > /etc/apt/sources.list.d/trusty.list
-bash: /etc/apt/sources.list.d/trusty.list: Permission denied

sorry about that,

 

it should be this

sudo echo "deb-armhf http://ports.ubuntu.com/ trusty main restricted universe multiverse" | sudo tee -a /etc/apt/sources.list.d/trusty.list
Link to post
Share on other sites

 

I

Followed by:

cat << EOF | sudo tee -a /etc/apt/prefereces.d/trusty.pref
Package: *
Pin: release a=trusty
Pin-Priority: 10
EOF
apt-get -t trusty install libtiff5

 

There's missing a "n" in /etc/apt/prefereces.d/trusty.pref

Link to post
Share on other sites

For me its not working (fresh jessie)

apt-get upgrade                                                                                                                                                   
Reading package lists... Error!
E: Type 'deb-armhf' is not known on line 1 in source list /etc/apt/sources.list.d/trusty.list
E: The list of sources could not be read.
E: The package lists or status file could not be parsed or opened.

Link to post
Share on other sites

@@Sabcoll

 

If you only follow the first part (under Raspberry PI Instructions) that should be enough. It worked for me without following the steps under "If running Raspbian".

 

There is an issue with ffmpeg though, so playing files could be problematic at the moment.

 

You can resolve this by manually compiling FFMpeg:

 

cd /usr/src

git clone git://git.videolan.org/x264

cd x264

sudo ./configure --host=arm-unknown-linux-gnueabi --enable-static --disable-opencl

sudo make

sudo make install

 

git clone git://source.ffmpeg.org/ffmpeg.git
cd ffmpeg

sudo ./configure --arch=armel --target-os=linux --enable-gpl --enable-libx264

sudo make

sudo make install

 

and then editing emby-server.sh to use this version of ffmpeg.

Link to post
Share on other sites

It's weird, i already tried that.

I uncommented the line in sources.list, but i get an error of unmet dependencies:

    apt-get install mono-runtime mediainfo libsqlite3-dev imagemagick-6.q8 libmagickwand-6.q8-2 libmagickcore-6.q8-2
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    mediainfo is already the newest version.
    mono-runtime is already the newest version.
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
     libmagickcore-6.q8-2 : Depends: libjpeg8 (>= 8c) but it is not installable
    E: Unable to correct problems, you have held broken packages.



Link to post
Share on other sites
hurricanehrndz

@@Sabcoll

 

If you only follow the first part (under Raspberry PI Instructions) that should be enough. It worked for me without following the steps under "If running Raspbian".

 

There is an issue with ffmpeg though, so playing files could be problematic at the moment.

 

You can resolve this by manually compiling FFMpeg:

 

cd /usr/src

git clone git://git.videolan.org/x264

cd x264

sudo ./configure --host=arm-unknown-linux-gnueabi --enable-static --disable-opencl

sudo make

sudo make install

 

git clone git://source.ffmpeg.org/ffmpeg.git

cd ffmpeg

sudo ./configure --arch=armel --target-os=linux --enable-gpl --enable-libx264

sudo make

sudo make install

 

and then editing emby-server.sh to use this version of ffmpeg.

You shouldn't need to emby-server.sh if you are using the service scripts. 

Link to post
Share on other sites

When compiling FFMpeg yourself the emby-server.sh needs to be changed to use this compiled version. Although the emby-server.sh seems to use which to locate the correct ffmpeg file (running it from the prompt show the correct path) for some strange reason it will not pick it up running the script, so I editted the file and now it works fine.

Link to post
Share on other sites
hurricanehrndz

@@Sabcoll

 

If you only follow the first part (under Raspberry PI Instructions) that should be enough. It worked for me without following the steps under "If running Raspbian".

 

There is an issue with ffmpeg though, so playing files could be problematic at the moment.

 

You can resolve this by manually compiling FFMpeg:

 

cd /usr/src

git clone git://git.videolan.org/x264

cd x264

sudo ./configure --host=arm-unknown-linux-gnueabi --enable-static --disable-opencl

sudo make

sudo make install

 

git clone git://source.ffmpeg.org/ffmpeg.git

cd ffmpeg

sudo ./configure --arch=armel --target-os=linux --enable-gpl --enable-libx264

sudo make

sudo make install

 

and then editing emby-server.sh to use this version of ffmpeg.

Thanks, maybe that needed for earlier versions of raspbian.

Link to post
Share on other sites
hurricanehrndz

When compiling FFMpeg yourself the emby-server.sh needs to be changed to use this compiled version. Although the emby-server.sh seems to use which to locate the correct ffmpeg file (running it from the prompt show the correct path) for some strange reason it will not pick it up running the script, so I editted the file and now it works fine.

Okay,

 

Instead of compiling have you tried using the following ppa?

http://www.deb-multimedia.org/

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...