Jump to content
Raze

Emby not Scraping Youtube Trailer information?

Recommended Posts

Raze

No, as far as I understand things work as i described. So the emby addon pays no attention to the nfo metadata scraped by emby or any other addon and populates the trailer tags if there are trailers returned by the API call to get trailers. So for example if in the web client you can click on the trailer button, it should then be the same in kodi. If the OP installed the trailers plugin, tested it works in the web client and then did a complete re sync in the emby addon the trailers should be there.

 

@@im85288 Are you saying that Emby addon for Kodi intentionally does not grab the trailer metadata? Instead there is some other method (through the trailer plugin on the server) by which trailers should be visiable? 

 

If that is what you are saying, why would the Kodi addon not do both? There are several Kodi skins (at least Confluence, Amber and Transparency) which (based on my - very novice - interpretation of the code) would only give the option to diplay a trailer IF the metadata exisits:

<control type="button" id="11">
<description>Play Trailer</description>
<include>ButtonInfoDialogsCommonValues</include>
<label>20410</label>
<visible>!IsEmpty(ListItem.Trailer) + !Skin.HasSetting(WindowedTrailer)</visible>
</control>

<control type="button" id="15">
<description>Play Trailer Windowed</description>
<include>ButtonInfoDialogsCommonValues</include>
<label>20410</label>
<onclick>PlayMedia($INFO[ListItem.Trailer],1)</onclick>
<visible>!IsEmpty(ListItem.Trailer) + Skin.HasSetting(WindowedTrailer)</visible>
</control>

Hopefully i'm understanding you - correct me if i'm wrong on my interpretation of your post of the code above.

 

Cheers,

 

~Mike.

Share this post


Link to post
Share on other sites
Raze

@ - what do you mean by "pointed Kodi to those folders"?

 

Are you adding sources to Kodi?

 

Also, what do you mean in point 3,"When I export my library from Kodi"?

 

 

@ CBers To answer your first questions - to test to see if the it was the metadata if Kodi was not happy with I did the following:

  1. I set Emby to "save artwork and metadata in media folders" which generates images, artwork and a .nfo file in the folder where the video files are located (c:\users\mike\desktop\movies). This is a temporary directory for testing purposes with only a few movies.
  2. I added a new video source (within a fresh install of Kodi, no Emby installed) which pointed to the same folder (c:\users\mike\desktop\movies).
  3. I forced a refresh of these movies (context menu (press 'c' when movie is highlighted) > movie info > refresh) at which point i was asked if i wanted to use locally stored info, or to rescrape from the internet - i selected use locally stored info.

When doing this, the option to watch a trailer was there and worked beautifully. In fact it told me the youtube addon was needed and asked if i wanted to install. I said yes. Youtube installed and the trailer was played.

 

To answer your second question - when in Kodi you can go into settings > library > export library. This exports a copy of your library (which can be used for backup, transfering to another install, etc). I opened up the file generated by this export and the trailer information is blank. To me this confirms that somewhere along the line the trailer metadata is not being transfered from the Emby server to the Kodi library.

 

~Mike

  • Like 1

Share this post


Link to post
Share on other sites
xnappo

You shouldn't be doing that.

 

Do not add any sources to Kodi at all.

 

You don't need nfos at all.

 

Just follow the instructions in my intro video.

 

xnappo

Share this post


Link to post
Share on other sites
im85288

@@im85288 Are you saying that Emby addon for Kodi intentionally does not grab the trailer metadata? Instead there is some other method (through the trailer plugin on the server) by which trailers should be visiable? 

 

If that is what you are saying, why would the Kodi addon not do both? There are several Kodi skins (at least Confluence, Amber and Transparency) which (based on my - very novice - interpretation of the code) would only give the option to diplay a trailer IF the metadata exisits:

 

<control type="button" id="11">
<description>Play Trailer</description>
<include>ButtonInfoDialogsCommonValues</include>
<label>20410</label>
<visible>!IsEmpty(ListItem.Trailer) + !Skin.HasSetting(WindowedTrailer)</visible>
</control>

<control type="button" id="15">
<description>Play Trailer Windowed</description>
<include>ButtonInfoDialogsCommonValues</include>
<label>20410</label>
<onclick>PlayMedia($INFO[ListItem.Trailer],1)</onclick>
<visible>!IsEmpty(ListItem.Trailer) + Skin.HasSetting(WindowedTrailer)</visible>
</control>
Hopefully i'm understanding you - correct me if i'm wrong on my interpretation of your post of the code above.

 

Cheers,

 

~Mike.

Like I've been saying from the beginning, we are not doing anything with your local NFOs. As xnappo states this addon does not work that way. The instructions I have given for trailers will work if you follow the steps through.

 

Thanks

Share this post


Link to post
Share on other sites
Raze

Like I've been saying from the beginning, we are not doing anything with your local NFOs. As xnappo states this addon does not work that way. The instructions I have given for trailers will work if you follow the steps through.

 

Thanks

 

@@xnappo @@im85288 I'm sorry for the confusion I've created. I'm aware that Emby does not use the local nfos. I'm aware that I don't need to other add sources. I've only been doing these things for trouble shooting purposes.

 

But lets ignore what I've already done from a trouble shooting perspecitve. I have tried the steps @@im85288 has recomended as follows:

  1. Started from a clean install of Emby server and Kodi;
  2. Installed the trailers plugin on the Emby server;
  3. Tested and confirmed that trailers work in the server web client;
  4. Performed a complete library update through the Emby addon;
  5. Attempted to play trailers in Kodi through movies > context menu (press 'c') > movie information

Trailers do not work. Option to play trailer is not available.

 

Cheers,

 

~Mike

Share this post


Link to post
Share on other sites
im85288

Fair enough, they are working fine for me but mine are local trailers. Perhaps another developer will help you,

 

Cheers

Share this post


Link to post
Share on other sites
ursli

I think I'm having the same problem, I can play trailers with the web interface but in Kodi they're not showing up. The web interface metadata editor complains about not having a local trailer (which is true) but the youtube trailer is certainly there and playable.

 

Server Version 3.0.5621.4

Kodi Addon Version 1.0.0

Kodi Version 14.2

 

 

post-49212-0-28397300-1434476084_thumb.jpgpost-49212-0-55224800-1434476094_thumb.jpg

Edited by ursli
  • Like 1

Share this post


Link to post
Share on other sites
Angelblue05

Ok I've added support for youtube trailers. You will need to reset - resync your library for the trailers to be scanned in. It will be available in the next version 1.0.09. :)

  • Like 1

Share this post


Link to post
Share on other sites
CBers

Is that online trailers?

 

They're not being downloaded?

Share this post


Link to post
Share on other sites
Angelblue05

They are online - But the url to it needs to be imported. :)

  • Like 2

Share this post


Link to post
Share on other sites
Raze

Ok I've added support for youtube trailers. You will need to reset - resync your library for the trailers to be scanned in. It will be available in the next version 1.0.09. :)

 

Awesome! Thank you for working on this and for deciphering my cryptic ramblings and understanding what I was trying to say!

 

This really is going improve the experience in Kodi (at least in my opinion)!

 

Now I just have to hold my breath for the next version! Hopefully it will be soon?

 

~Mike

Share this post


Link to post
Share on other sites
CBers

They are online - But the url to it needs to be imported. :)

 

So it's importing from Emby ??

Share this post


Link to post
Share on other sites
Angelblue05

Yes its grabbing the remote trailer in emby if there's no local trailer set. So the trailer button will show and when you select it, it will launch the trailer via the youtube add-on :)

 

 

Sent from my iPhone using Tapatalk

  • Like 2

Share this post


Link to post
Share on other sites
Angelblue05

Version 1.0.09 is out, so give it a try and let me know everything is working for trailers. Thanks :)

  • Like 3

Share this post


Link to post
Share on other sites
CBers

Version 1.0.09 is out, so give it a try and let me know everything is working for trailers. Thanks :)

 

Seems to be so far on the half-dozen movies I tested it with.

 

Some I have local trailers, which play fine, but some don't have trailers, so they are played from YT.

  • Like 2

Share this post


Link to post
Share on other sites
ursli

No dice here, I've updated to 1.0.9, did a full reset of my database but still don't see trailers in Kodi.

 

This is with:

 

plugin.video.emby: 1.0.9 (git aa156a5a63d5ec28dbb26f394262ff7e16b12b97)

Kodi: 14.2 Git:20150326-7cc53a9

emby-server: 3.0.5621.4

 

I've turned on debug logging for the kodi addon after resetting the db but didn't see anything that points to youtube, if you feel like the logs could help I'll be happy to post them.

Edited by ursli

Share this post


Link to post
Share on other sites
CBers

Do you see trailers in the dashboard ??

Share this post


Link to post
Share on other sites
Angelblue05

@@ursli

 

Are you able to attach your database (MyVideosXX.db) to your post or PM me it? It's the only way to confirm if it imported correctly. :) (That is if they do display in the web client)

Edited by Angelblue05

Share this post


Link to post
Share on other sites
ursli

Do you see trailers in the dashboard ??

 

post-49212-0-28397300-1434476084.jpg

 

I guess you're talking about this? Then yes, most of my movies got youtube trailers I can play when I use the html5 browser interface.

Edited by ursli
  • Like 1

Share this post


Link to post
Share on other sites
CBers

post-49212-0-28397300-1434476084.jpg

 

I guess you're talking about this? Then yes, most of my movies got youtube trailers I can play when I use the html5 browser interface.

 

Is it a local trailer, or just a link to an online (YT) trailer ??

 

Have you access to other Emby clients you can test on ??

Share this post


Link to post
Share on other sites
Angelblue05

Yeah, his trailers didn't import. It should be fine if he retries.

  • Like 1

Share this post


Link to post
Share on other sites
ursli

It indeed was solved by another reset, was probably user error. :D

  • Like 1

Share this post


Link to post
Share on other sites
Raze

Version 1.0.09 is out, so give it a try and let me know everything is working for trailers. Thanks :)

@@Angelblue05 I had a quick chance to test this morning and seems to be working!! Halejula! :) thanks for your work!! I will test more extensively tonight!

 

I think it's time to ditch plex and switch to emby! :D

 

~Mike

  • Like 2

Share this post


Link to post
Share on other sites
Raze

Version 1.0.09 is out, so give it a try and let me know everything is working for trailers. Thanks :)

@@Angelblue05 I had a quick chance to test this morning and seems to be working!! Halejula! :) thanks for your work!! I will test more extensively tonight!

 

I think it's time to ditch plex and switch to emby! :D

 

~Mike

Share this post


Link to post
Share on other sites
Raze

@@Angelblue05 I had a quick chance to test this morning and seems to be working!! Halejula! :) thanks for your work!! I will test more extensively tonight!

 

I think it's time to ditch plex and switch to emby! :D

 

~Mike

 

Hi all and @@Angelblue05,

 

I've done a full library test for my movies and it looks like this works for 90% plus of my movies. Where it is not working, it seems to be a problem with the scape - there is either no trailer information available or the video has been removed, etc. Either way not an Emby issue.

 

If I could make one more request? Would it be possible in the metadata manager (on the emby server web utility) to have a feild which displays the youtube trailer information which has been scraped AND allow us to edit it?

 

I intend to update as much as possilbe on the source sites (tMDB.org) but this would be a helpful way to manage the library locally.

 

Cheers and again thanks for all your help. I'm now browsing hardware for my new server. :)

 

~Mike

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...