Jump to content
BrettM

App won't log onto server

Recommended Posts

BrettM

Hi all

 

I have updated to the latest version of the android app, when I try to login I put the username & password it finds my server but comes up with a message Connection Failure" We're unable to connect to the selected server right now. Please ensure it is running and try again.

I have checked the server it is running, I have rebooted my Samsung tablet I have also uninstalled and reinstalled the app, but it still comes up with the same message.

 

I have also downloaded the latest version of the server from the website, still same error message.

 

I have the android app installed on my Samsung S5 and have the same issue

 

If I try from the site I can log in no problem

 

Any Ideas?

Edited by BrettM

Share this post


Link to post
Share on other sites
Luke

By site you mean app.emby.media or your local web client?

Share this post


Link to post
Share on other sites
tman

Same problem. Just upgraded my Android mobile client, and on my local wireless LAN, entering the Emby server IP and port (assume 8096), I get the same message. Old client worked perfectly.

 

Server is running ok (web client connects fine).

Share this post


Link to post
Share on other sites
Luke

Did you enter the local address? Did it auto detect the server?

Share this post


Link to post
Share on other sites
knuta

Friend of mine had a similar problem. Turned out he had a whitespace or what it's called at the end of the server address. 

Share this post


Link to post
Share on other sites
Luke

Friend of mine had a similar problem. Turned out he had a whitespace or what it's called at the end of the server address.

Thanks, good info. We can trap that.

Share this post


Link to post
Share on other sites
knuta

Thanks, good info. We can trap that.

 

Nice! :)

Share this post


Link to post
Share on other sites
BrettM

By site you mean app.emby.media or your local web client?

 

Sorry luke only just seen your question, If I sign in from the emby media site, it works without an issue it's only when I try from my tablet or phone, It automatically detects my server but just won't connect?

 

Share this post


Link to post
Share on other sites
Luke

what if you try the website from your tablet, does that work?

Share this post


Link to post
Share on other sites
BrettM

Hi Luke,

 

I have just tried from both my Tablet (Samsung) and my Samsung S5 mobile both worked with the old version, but now either of them will not connect with the new version of the App.

My daughters husband also has the app on his Samsung s5 phone and he is having the same issue ?

 

It's a real shame because this was awesome previously and I own a jukebox company in Australia and we are building a home entertainment system to sell to the general public and we have featured emby heavily, we are due to demonstrate our product end of the week coming  but now I'm worried that this is heading for disaster.

 

any help or advise would be greatly appreciated.

Edited by BrettM

Share this post


Link to post
Share on other sites
Luke

are you using emby connect or just local discovery?

Share this post


Link to post
Share on other sites
BrettM

When I updated the app it takes me to the login page where I put my username and password. It then finds my server but won't connect.

 

what is the difference between emby connect and local discovery?

 

we haven't changed anything and it was all working fine until the upgrade

Share this post


Link to post
Share on other sites
BrettM

Is it possible to get a solution to this issue?

 

I have again deleted then reinstalled the app but still it does not log into the server, I even re download the server software to the PC but same result. If I go to the embassy website and login from the website then I goes in no problem....

 

I'm not sure what else to do....

Share this post


Link to post
Share on other sites
knuta

Is it possible to get a solution to this issue?

 

I have again deleted then reinstalled the app but still it does not log into the server, I even re download the server software to the PC but same result. If I go to the embassy website and login from the website then I goes in no problem....

 

I'm not sure what else to do....

 

It's not like Luke can just make some changes to the server code and it magically works... I am also using the newest android app on a Samsung S5 with server version 3.0.5636.29944 and I can connect with no problem at all without using "Connect".

 

Might just be something wrong outside of the Emby ecosystem.

Edited by knuta

Share this post


Link to post
Share on other sites
BrettM

Thanks Knuta,

 

I understand there is no magic fix and I was not trying to be rude. I have two samsung products it worked perfectly on before the updated version came out, I am simply trying to get it working that is all...

 

I have the samsung 5S phone and the samsung tablet as I said it worked perfectly on both until the new app came out now neither will connect.

Share this post


Link to post
Share on other sites
Luke

Yes I am looking into it.

 

On the Emby Connect screen, what happens if you press Skip and then connect to your server manually? Does that work?

Share this post


Link to post
Share on other sites
knuta

I'm not sure if you've tried this. I will try to give precise instructions:

 

1. Open a web browser on your MOBILE device, for example Chrome.

 

2. Enter "app.emby.media" in the address field. Without the " " of course.

 

3. If asked for username and password, enter them as you would on your computer.

 

4. Does your server appear there? Can you select it and get in?

Edited by knuta

Share this post


Link to post
Share on other sites
BrettM

Hi Knuta,

thanks heaps for the info yes it does work if I do it that way, so only if I try to login to the app it won't work.

Share this post


Link to post
Share on other sites
knuta

That is strange indeed, but I'm no developer so I hope Luke can do some magic after all ;)

 

What server version are you on?

Edited by knuta

Share this post


Link to post
Share on other sites
BrettM

Hi Knuta & Luke

I just tried to login with my samsung s tablet I did everything that i did on my samsung s5 and it won't login, it finds the server no issue but the same error message comes up and won't login very strange.But i can login on the phone

 

App.emby.media is where i go.

Edited by BrettM

Share this post


Link to post
Share on other sites
knuta

Very strange. Again, which server version are you on? I had some trouble getting in a few weeks ago on the stable or beta release.

Share this post


Link to post
Share on other sites
BrettM

The one you gave me earlier today / night BUT now the phone won't login but it was fine this morning before i went to work, the server on the pc is set to beta updates from memory

Share this post


Link to post
Share on other sites
knuta

Would you be willing to change it from beta to dev to see if it makes any difference? If you got an update recently you might already be on dev, though I'm not sure.

I'm on dev and on version 3.0.5637.29705.

 

Maybe try to delete all data for the app on the Android devices.

For the S5 go to:settings> application manager> emby> "clear data" and "clear cache".

Share this post


Link to post
Share on other sites
DCRL

I am having the exact same problem, I have 2 days ago received an android tablet, downloaded the app and signed in and I can see my server but it won't allow me to connect to it.

It works fine on wifi connecting to the local network but not over 4g or 3G

Share this post


Link to post
Share on other sites
BrettM

DCRL

My problem has now been resolved download the latest server release (Beta) install it then restart your tablet it should connect mine did without any problems.

I downloaded the server 5am aussie time and it's all good

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...