Jump to content


Photo

Vera Home Automation Plugin (Emby Vera)

Home Automation

  • Please log in to reply
480 replies to this topic

#61 chef OFFLINE  

chef

    Advanced Member

  • Developers
  • 4274 posts
  • Local time: 01:19 AM
  • LocationPeterborough, Canada

Posted 03 April 2015 - 09:55 AM

Chef,

Does the server know when a DLNA device/client has started?? Reason I ask is because I too have an Xbone, I'd like to simply turn on/off lights when the Xbox has powered on/off. Is this possible with the app right now??

Yes the server knows when a Xbox one has logged into an account.
So in other words, you would have to start DLNA Emby through Xbox One Media player, in order to have the device show up in the server.



But the server won't raise events after that.

I think this is a serious matter that we should take up with the main developers. We needs to know if some of these functions are possible and on a road map of development, or if we have to wait for the Xbox one emby app to be released.

@Luke I know you are a busy guy but could you please read this particular entry in this thread and possibly comment.

Edited by chef, 03 April 2015 - 10:00 AM.


#62 Latchmor OFFLINE  

Latchmor

    Advanced Member

  • Moderators
  • 1602 posts
  • Local time: 06:19 AM
  • LocationScotland

Posted 03 April 2015 - 10:22 AM

Hi @chef, just so you know Luke doesn't get @ 'ed posts anymore. I think because he almost scans all posts  :blink: so if you're desperate you'd need to PM him.

Cheers


  • chef likes this

#63 chef OFFLINE  

chef

    Advanced Member

  • Developers
  • 4274 posts
  • Local time: 01:19 AM
  • LocationPeterborough, Canada

Posted 03 April 2015 - 10:44 AM

Hi @chef, just so you know Luke doesn't get @ 'ed posts anymore. I think because he almost scans all posts :blink: so if you're desperate you'd need to PM him.
Cheers


Hopefully he reads this one. Maybe I will just pm him the link here.

#64 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146507 posts
  • Local time: 01:19 AM

Posted 03 April 2015 - 10:48 AM

the events you're using are the correct ones. there's nothing special you need to do with dlna devices.



#65 chef OFFLINE  

chef

    Advanced Member

  • Developers
  • 4274 posts
  • Local time: 01:19 AM
  • LocationPeterborough, Canada

Posted 03 April 2015 - 02:43 PM

Sweet so we got an answer which is great!

DLNA should raise the events we need xzener.

I will go back and see where I have made a mistake, and see what we can get going with Xbox one.

#66 Xzener OFFLINE  

Xzener

    Advanced Member

  • Super Testers
  • 3112 posts
  • Local time: 10:19 PM
  • LocationLemoore, CA

Posted 03 April 2015 - 09:30 PM

Well, no. I was hoping the server saw she I powered on the Xbone. I don't use it for Emby playback. It's ok... No big deal.

Edited by Xzener, 03 April 2015 - 09:30 PM.


#67 Vidman OFFLINE  

Vidman

    Advanced Member

  • Alpha Testers
  • 2680 posts
  • Local time: 02:19 PM

Posted 04 April 2015 - 02:44 AM

Well, no. I was hoping the server saw she I powered on the Xbone. I don't use it for Emby playback. It's ok... No big deal.

There is a wol/ping plugin for vera that you could use to tell when the xbone connects to your LAN as a possible work around

#68 chef OFFLINE  

chef

    Advanced Member

  • Developers
  • 4274 posts
  • Local time: 01:19 AM
  • LocationPeterborough, Canada

Posted 04 April 2015 - 10:31 AM

There is a wol/ping plugin for vera that you could use to tell when the xbone connects to your LAN as a possible work around


This would be cool! Then we could tie it into the plugin interface.

#69 chef OFFLINE  

chef

    Advanced Member

  • Developers
  • 4274 posts
  • Local time: 01:19 AM
  • LocationPeterborough, Canada

Posted 04 April 2015 - 02:05 PM

I still can't get Xbox one to raise playback events.

#70 Xzener OFFLINE  

Xzener

    Advanced Member

  • Super Testers
  • 3112 posts
  • Local time: 10:19 PM
  • LocationLemoore, CA

Posted 05 April 2015 - 12:11 AM

There is a wol/ping plugin for vera that you could use to tell when the xbone connects to your LAN as a possible work around


Done. BRILLIANT!!! Thanks Vidman!! A bit of a delay when turning off, no big deal. It works, I'm happy.

Edited by Xzener, 05 April 2015 - 12:16 AM.

  • Vidman likes this

#71 chef OFFLINE  

chef

    Advanced Member

  • Developers
  • 4274 posts
  • Local time: 01:19 AM
  • LocationPeterborough, Canada

Posted 08 April 2015 - 12:47 PM

Thats exciting, we're in the catalog.



#72 techywarrior OFFLINE  

techywarrior

    Advanced Member

  • Members
  • 2408 posts
  • Local time: 10:19 PM

Posted 08 April 2015 - 01:01 PM

Congrats Chef. I guess you figured out some more jQuery since you didn't PM me a cry for help last week :)


  • chef likes this

#73 chef OFFLINE  

chef

    Advanced Member

  • Developers
  • 4274 posts
  • Local time: 01:19 AM
  • LocationPeterborough, Canada

Posted 08 April 2015 - 04:34 PM

Congrats Chef. I guess you figured out some more jQuery since you didn't PM me a cry for help last week :)


Lol.
I started watching jquery videos on YouTube, and also researched the jquery mobile site.
I feel confident in my plugin building if we want to build another server side plugin, I can help 😄

#74 PGL OFFLINE  

PGL

    Member

  • Members
  • 20 posts
  • Local time: 07:19 AM

Posted 08 April 2015 - 04:47 PM

What about some Fibaro - HC 2 integration ? :D



#75 chef OFFLINE  

chef

    Advanced Member

  • Developers
  • 4274 posts
  • Local time: 01:19 AM
  • LocationPeterborough, Canada

Posted 08 April 2015 - 05:07 PM

What about some Fibaro - HC 2 integration ? :D


Let me research it and I will get back to you.

Do you have any information site you could pass along?

#76 techywarrior OFFLINE  

techywarrior

    Advanced Member

  • Members
  • 2408 posts
  • Local time: 10:19 PM

Posted 08 April 2015 - 08:36 PM

Hm, I installed the plugin and I am not getting a client list on page load or by using the refresh device list. Tried in IE11 and Chrome 41.



#77 chef OFFLINE  

chef

    Advanced Member

  • Developers
  • 4274 posts
  • Local time: 01:19 AM
  • LocationPeterborough, Canada

Posted 08 April 2015 - 10:46 PM

Hm, I installed the plugin and I am not getting a client list on page load or by using the refresh device list. Tried in IE11 and Chrome 41.


That's not good. Are you logged into the devices on your network?

#78 techywarrior OFFLINE  

techywarrior

    Advanced Member

  • Members
  • 2408 posts
  • Local time: 10:19 PM

Posted 08 April 2015 - 10:54 PM

That's not good. Are you logged into the devices on your network?

Yea, first time I was just logged in on the browser so when nothing showed up I launched MBC and tried again. Same issue. Refreshed the page too after MBC was launched and tried both browsers too.



#79 chef OFFLINE  

chef

    Advanced Member

  • Developers
  • 4274 posts
  • Local time: 01:19 AM
  • LocationPeterborough, Canada

Posted 08 April 2015 - 11:03 PM

I can confirm.

 

On internet explorer it is broken. But chrome is working for me.

 

The configuration XML is updating properly in IE, but the list is not being populated.


Edited by chef, 08 April 2015 - 11:04 PM.


#80 techywarrior OFFLINE  

techywarrior

    Advanced Member

  • Members
  • 2408 posts
  • Local time: 10:19 PM

Posted 08 April 2015 - 11:09 PM

Strange. I will try chrome again and see if it works. The old test builds used to work for me in IE and Chrome (although there was that refresh issue) so I am a little surprised with the trouble right now. I also remember seeing the browser show up in the list previously so even with MBC not running I would expect to see something in the list in Chrome.







Also tagged with one or more of these keywords: Home Automation

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users