Jump to content


Photo

Trailer being classed as movie

movie trailer server

  • Please log in to reply
50 replies to this topic

#1 gillmacca OFFLINE  

gillmacca

    Advanced Member

  • Members
  • 331 posts
  • Local time: 10:56 AM
  • LocationSwindon, UK

Posted 14 December 2014 - 01:08 PM

I use the trailer plug-in to download trailers for movies I have, and all work except for one movie.

For this one movie (Wolverine), rather than displaying the movie with the link to the trailer, the server is separating, so that under movies, I have one entry for the film and another one for the trailer

 

Latest Movies: https://www.dropbox.....03.55.png?dl=0

Movie page: https://www.dropbox.....06.11.png?dl=0

Trailer page: https://www.dropbox.....06.57.png?dl=0

 

I can't see why it is separating just this movie & trailer, and not others



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153204 posts
  • Local time: 05:56 AM

Posted 14 December 2014 - 01:11 PM

the filename isn't right. it should be 

 

{movie}-trailer.ext

 

otherwise it has no way to correlate the two of them together.



#3 gillmacca OFFLINE  

gillmacca

    Advanced Member

  • Members
  • 331 posts
  • Local time: 10:56 AM
  • LocationSwindon, UK

Posted 14 December 2014 - 01:14 PM

Thanks for the quick response, I knew it would be something simply..lol.

Strange as I haven't edited the filename myself. It was downloaded by the trailer plug-in



#4 godbodian OFFLINE  

godbodian

    Advanced Member

  • Alpha Testers
  • 203 posts
  • Local time: 05:56 AM

Posted 14 December 2014 - 01:18 PM

Yeah the same thing is happening to me. I have like 23-25 new movie adds that either were or weren't trailers, coming up. The kicker is NONE of them are movies or trailers that have been recently fetched. It's like as soon as I did the updates, it went left.

 

As you can see from the screenshot. It's not just trailers in my case. The movies are essentially showing in three positions, as they original were when working and these blank icons basically showing the contents of these file folders.

 

Attached File  Trailers and movies separating.JPG   111.87KB   9 downloads
 


Edited by godbodian, 14 December 2014 - 01:23 PM.


#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153204 posts
  • Local time: 05:56 AM

Posted 14 December 2014 - 01:25 PM

Thanks for the quick response, I knew it would be something simply..lol.

Strange as I haven't edited the filename myself. It was downloaded by the trailer plug-in

 

any idea when it was downloaded? because looking at the code for the plugin, i don't think it does this anymore. 



#6 godbodian OFFLINE  

godbodian

    Advanced Member

  • Alpha Testers
  • 203 posts
  • Local time: 05:56 AM

Posted 14 December 2014 - 01:38 PM

Update: I figured out what it is. Something and by something I mean I have no earthly idea what inside MBS, is randomly renaming my files and file folders, into weird configurations. ie. The Faculty (2001) becomes The Faculty and The.Faculty

 



#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153204 posts
  • Local time: 05:56 AM

Posted 14 December 2014 - 01:39 PM

mbs is not doing that, i can assure you of that. we don't do any renaming at all.



#8 godbodian OFFLINE  

godbodian

    Advanced Member

  • Alpha Testers
  • 203 posts
  • Local time: 05:56 AM

Posted 14 December 2014 - 01:45 PM

So if I'm not actively touching my system (physically that is) and MBS is in charge of downloading my local trailers, there's no chance that there may be something else within MBS or MBC?

 

I'm not trying to be rude or doubtful but I haven't done anything abnormal in anyway, the only thing I did this morning was restart MBS after .5462 was installed and allow an update for MBC. Literally 5 minutes later after a long pause on the MBC extender once MBC was loaded completely these movies were different. My children and I have been watching Christmas movies all morning and these issues weren't present seemingly until those two updates were done.

 


Edited by godbodian, 14 December 2014 - 01:46 PM.


#9 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153204 posts
  • Local time: 05:56 AM

Posted 14 December 2014 - 01:48 PM

If you search the forum you will find plenty of examples of people who thought MBS was renaming or deleting their files. And they were very persistent about it. But each time, after finally investigating, they found it was something else on their machine. I'm telling you that there is nothing in MBS that renames or deletes files (aside from delete function). So you can either stay here and tell me i'm wrong or you can try to find the real reason for it.



#10 godbodian OFFLINE  

godbodian

    Advanced Member

  • Alpha Testers
  • 203 posts
  • Local time: 05:56 AM

Posted 14 December 2014 - 02:05 PM

Luke, no one was telling you that YOU were wrong. I was asking you if YOU were absolutely certain. While you did assist in the creation of MB3 (for which I'm grateful), I clearly explained I wasn't trying to be rude or doubtful of you and/or your answer. As you clearly stated based upon prior evidence (with others, as well as me) was unaware of what took place and in MY BEING AWARE of that unawareness, I was looking for clarity as opposed to clarity laced with attitude or snarky responses. I apologize if perhaps my response wasn't worded in a way that made such clear but realistically I APPRECIATE the first part of your answer as always, as for the last sentence you could have kept that to yourself.


Edited by godbodian, 14 December 2014 - 02:07 PM.


#11 kkhan OFFLINE  

kkhan

    Advanced Member

  • Members
  • 65 posts
  • Local time: 10:56 AM

Posted 14 December 2014 - 02:08 PM

Hello

 

I am having the same problem for The Wolverine and a few other movies but cannot figure out what is wrong.  The trailer and the main movie are being separated as two movies

 

The two video files are

The Wolverine (2013).mkv

The Wolverine (2013)-trailer.mp4 (downloaded by the trailer plugin)

 

I have also found that some mulipart movies are also being separated.  However, this is not consistent.  All my multi-part movies are named as 

name (year) partx.ext

 

Very odd as some of the movies are 3-4 years old and the naming convention has been consistent.



#12 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153204 posts
  • Local time: 05:56 AM

Posted 14 December 2014 - 02:09 PM

Hello

 

I am having the same problem for The Wolverine and a few other movies but cannot figure out what is wrong.  The trailer and the main movie are being separated as two movies

 

The two video files are

The Wolverine (2013).mkv

The Wolverine (2013)-trailer.mp4 (downloaded by the trailer plugin)

 

I have also found that some mulipart movies are also being separated.  However, this is not consistent.  All my multi-part movies are named as 

name (year) partx.ext

 

Very odd as some of the movies are 3-4 years old and the naming convention has been consistent.

 

can you show screenshots of the folders in the file system? also, post your version of the server. thanks.



#13 godbodian OFFLINE  

godbodian

    Advanced Member

  • Alpha Testers
  • 203 posts
  • Local time: 05:56 AM

Posted 14 December 2014 - 02:14 PM

KKhan. What I think is happening is (and this is JUST my opinion) if you have MBS downloading trailers, the trailers that are downloaded may be downloading to a different naming convention. I know in certain instances, like the Mission Impossible movies, I did a custom naming convention so the movies would appear in a certain manner but today all of those files were separated when the trailer was downloaded.

 

Go through those files copy the name of the file ;folder and make sure the name is the same for each file. ie. Dr. Seuss’ The Lorax (2012), Dr. Seuss’ The Lorax (2012).mp4 & Dr. Seuss’ The Lorax (2012)-trailer.mp4/ext... etc.  That's what helped me.



#14 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153204 posts
  • Local time: 05:56 AM

Posted 14 December 2014 - 02:16 PM

the trailer downloader plugin does name them correctly, but it's possible that in the past there may have been a bug. that's why i asked him about the timeline. i don't think you'll see it happen with newly downloaded ones.



#15 kkhan OFFLINE  

kkhan

    Advanced Member

  • Members
  • 65 posts
  • Local time: 10:56 AM

Posted 14 December 2014 - 02:30 PM

Luke, Here you go.

 

Godbodian, thanks yes I am checking the naming.

 

Multipart movie being split in the library as two.  However, this behaviour does not appear to be consistent

 

548dd5db51879_FileSystemMultipart.jpg

 

Example of the Wolverine where the trailer is now recognised as The Wolverine and the main movie is now recognised as Wolverine vs. Sabretooth which I do not actually have in my library.

 

 

 

548dd60340427_FileSystemWolverine.jpg



#16 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153204 posts
  • Local time: 05:56 AM

Posted 14 December 2014 - 02:55 PM

Khan - in example one, the trailer should be "No (2012)-trailer.mp4"...however, i think your name is ok so i will address it when the beta goes stable. So you can either just wait or change it now.

 

In example 2, the trailer isn't named right. it should be "Wolverine (2013)-trailer.mp4"



#17 kkhan OFFLINE  

kkhan

    Advanced Member

  • Members
  • 65 posts
  • Local time: 10:56 AM

Posted 14 December 2014 - 03:36 PM

Thanks Luke.  Makes sense.  I will make the changes to maintain Service Levels with my partner.

 

Great work as always; I continue to pinch myself as a reality check as MB3 is so unbelievably good.



#18 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153204 posts
  • Local time: 05:56 AM

Posted 14 December 2014 - 04:05 PM

i'll put up a dev build later on with the file stacking fix in case anyone can help test that.



#19 Jobber8742 OFFLINE  

Jobber8742

    Advanced Member

  • Members
  • 116 posts
  • Local time: 04:56 AM
  • LocationIL

Posted 14 December 2014 - 05:41 PM

I'm having this same issue with the latest server update. All trailers were downloaded by the trailer plug-in and I have never changed the names. Media Browser is also now classifying movies with a Specials folder as a TV show. My whole library isn't working correctly as a result of this last update.



#20 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153204 posts
  • Local time: 05:56 AM

Posted 14 December 2014 - 05:45 PM

I'm having this same issue with the latest server update. All trailers were downloaded by the trailer plug-in and I have never changed the names. Media Browser is also now classifying movies with a Specials folder as a TV show. My whole library isn't working correctly as a result of this last update.

 

please give specific examples, with the same kind of screenshots supplied above.







Also tagged with one or more of these keywords: movie, trailer, server

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users