Jump to content

Unraid - I lose all my metadatas libraries twice


Kirkiazz75
 Share

Recommended Posts

Kirkiazz75

Hello everyone :)

Last Friday I restarted my Docker Emby container on Unraid. I lost all my libraries. I had the "Server Configuration Backup" extension, but no restore worked. I was using this Emby package, so I thought that this one had a problem.

2021-08-27_10h03_25.png.ec08d99aa5d2947b86f64d67127bc10f.png

So I installed a new package at the end of the day.

image.png.68e221d63106ee8bf111031a60580c6d.png

Everything was working until today when I had no cover image on my libraries. I restarted my container, and I lost all my containers. I also tried a restore but nothing worked. Also, it deleted my old Emby log files...

However, I found an error in the little log file :

Quote

2021-08-27 09:30:40.382 Error Server: Error processing request
    *** Error Report ***
    Version: 4.6.4.0
    Command line: /app/emby/EmbyServer.dll -programdata /config -ffdetect /app/emby/ffdetect -ffmpeg /app/emby/ffmpeg -ffprobe /app/emby/ffprobe -restartexitcode 3
    Operating system: Linux version 5.10.28-Unraid (root@Develop) (gcc (GCC) 9.3.0, GNU ld version 2.33.1-slack15) #1 SMP Wed Apr 7 08:23:18 PDT 2021
    Framework: .NET Core 3.1.13
    OS/Process: x64/x64
    Runtime: app/emby/System.Private.CoreLib.dll
    Processor count: 56
    Data path: /config
    Application path: /app/emby
    System.IO.DirectoryNotFoundException: System.IO.DirectoryNotFoundException: Could not find a part of the path '/config/metadata/library/b5/b5a7b05b5d178f4f1254df2d427e6820/poster.png'.
       at Interop.ThrowExceptionForIoErrno(ErrorInfo errorInfo, String path, Boolean isDirectory, Func`2 errorRewriter)
       at Microsoft.Win32.SafeHandles.SafeFileHandle.Open(String path, OpenFlags flags, Int32 mode)
       at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options)
       at Emby.Server.Implementations.IO.ManagedFileSystem.GetFileStream(String path, FileOpenMode mode, FileAccessMode access, FileShareMode share, Int32 bufferSize, FileOpenOptions fileOpenOptions)
       at Emby.Server.Implementations.IO.ManagedFileSystem.GetFileStream(String path, FileOpenMode mode, FileAccessMode access, FileShareMode share, FileOpenOptions fileOpenOptions)
       at Emby.Server.Implementations.IO.IOManager.GetResponse(HttpRequestOptions options, MediaProtocol protocol)
       at Emby.Server.Implementations.IO.IOManager.GetResponse(HttpRequestOptions options)
       at Emby.Server.Implementations.HttpServer.HttpResultFactory.GetContent(StaticFileResultOptions options, Int64 offset, Int64 length, CancellationToken cancellationToken)
       at Emby.Server.Implementations.HttpServer.FileWriter.SetContentResponseHeaders(Nullable`1 reportedTotalContentLength, CancellationToken cancellationToken)
       at Emby.Server.Implementations.HttpServer.HttpResultFactory.GetStaticResult(IRequest requestContext, StaticResultOptions options)
       at MediaBrowser.Api.Images.ImageService.GetImage(ImageRequest request, Int64 itemId, BaseItem item, Boolean isHeadRequest)
       at Emby.Server.Implementations.Services.ServiceController.GetTaskResult(Task task)
       at Emby.Server.Implementations.Services.ServiceHandler.ProcessRequestAsync(HttpListenerHost appHost, IRequest httpReq, IResponse httpRes, RestPath restPath, String responseContentType, CancellationToken cancellationToken)
       at Emby.Server.Implementations.HttpServer.HttpListenerHost.RequestHandler(IRequest httpReq, ReadOnlyMemory`1 urlString, ReadOnlyMemory`1 localPath, CancellationToken cancellationToken)
    Source: System.Private.CoreLib
    TargetSite: Void ThrowExceptionForIoErrno(ErrorInfo, System.String, Boolean, System.Func`2[Interop+ErrorInfo,Interop+ErrorInfo])
    

When I look in my system, all the metadatas are deleted... !
2021-08-27_10h14_22.png.bf603824af75d41db93c39922e70429d.png
 

Do you know can i fix it and restore my metadas ?

 

Thanks a lot :)

embyserver-63765654731.txt

Link to comment
Share on other sites

chacawaca

how your map are configured in your docker ?

i dont understand why you are under /mnt/cache/

Link to comment
Share on other sites

Kirkiazz75

I use an SSD Samsung 870 plus 1 To for cache and some other docker Apps. Anything gone wrong until 1,5 years

The disk is in perfect condition (99%) and there are 940 Gigas of available space. 

Link to comment
Share on other sites

Did something delete the whole mounted folder? That's kinda of what it looks like.

Link to comment
Share on other sites

chacawaca

how your map are configured in your docker ?

do you point on /mnt/user/emby/...

or on /mnt/cache/emby/...

Link to comment
Share on other sites

Kirkiazz75
Posted (edited)

@Luke
It is possible, but my others containers don't have problems.

@chacawaca i point on /mnt/user/emby :)

Screenshot_20210828-000859_Firefox.jpg

Edited by Kirkiazz75
Link to comment
Share on other sites

On 8/27/2021 at 6:10 PM, Kirkiazz75 said:

@Luke
It is possible, but my others containers don't have problems.

@chacawaca i point on /mnt/user/emby :)

Screenshot_20210828-000859_Firefox.jpg

Why have you explicitly configured the subfolders? It's only the top level that you should be worrying about. Are all of those mounted to the same place?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...