Jump to content

Original CoverArt questions


crashkelly
Go to solution Solved by ebr,

Recommended Posts

crashkelly

Having trouble with CoverArt not applying the selected treatment to my box set collection. Most of the covers are fine but newly added boxsets appear very strange.

 

I have tried refreshing the collection through the web interface but nothing changes.

 

The first 2 screenshots are what the new boxsets look like and the 3rd is what they should look like

 

I am using CoverArt 4.0.2.1

 

Thanks

 

 

 

post-104-0-41348400-1381448427_thumb.png

post-104-0-23199100-1381448428_thumb.png

post-104-0-86180500-1381448428_thumb.png

server-63517023229.log

 

Link to post
Share on other sites
crashkelly

For sure. I setup the individual movies first and then created the boxset folder with shortcuts to the UNC path. All my boxsets are set up this way.

 

Thanks

 

post-104-0-83495800-1381464774_thumb.png

Link to post
Share on other sites

I can say that I have had the odd occurrence of this also. I have found that if I go to the affected boxset, delete the primary image and then upload a new primary image, the treatment is applied. Not sure what the cause is, but it has only happened to maybe 2 of my boxsets

Link to post
Share on other sites
crashkelly

Hi,

 

And those are tagged as boxsets? If you edit them is the display type boxset?

 

Yes, they have [boxset] in the folder name and the collection type is set to BoxSet.

 

I can say that I have had the odd occurrence of this also. I have found that if I go to the affected boxset, delete the primary image and then upload a new primary image, the treatment is applied. Not sure what the cause is, but it has only happened to maybe 2 of my boxsets

 

I will give that a shot.

 

It basically happens to ever boxset I add and eventually it sorts itself out. I was waiting until the new releases over last weekend before posting anything

 

Thanks for the help

Link to post
Share on other sites
  • Solution

It basically happens to ever boxset I add and eventually it sorts itself out. I was waiting until the new releases over last weekend before posting anything

 

Okay, you are probably adding the boxset folder first and then adding the children, right?  What is happening is the BoxSet image is getting generated before the children.  So, the children aren't there at the time and aren't in the image.  This is a tricky problem of chicken and egg but can probably be minimized by not bringing up any interface that would cause the image to generate before the children are all there.

  • Like 1
Link to post
Share on other sites

Okay, you are probably adding the boxset folder first and then adding the children, right?  What is happening is the BoxSet image is getting generated before the children.  So, the children aren't there at the time and aren't in the image.  This is a tricky problem of chicken and egg but can probably be minimized by not bringing up any interface that would cause the image to generate before the children are all there.

 

Aaahh - that could be what I have done as well in those couple of instances...

Link to post
Share on other sites
crashkelly

Okay, you are probably adding the boxset folder first and then adding the children, right?  What is happening is the BoxSet image is getting generated before the children.  So, the children aren't there at the time and aren't in the image.  This is a tricky problem of chicken and egg but can probably be minimized by not bringing up any interface that would cause the image to generate before the children are all there.

 

That sounds about right for what I have been doing.

 

I have another boxset to rip today and I will go in the order of children then parent and see what happens

 

Thanks for the info

 

Cheers

Link to post
Share on other sites

Okay, you are probably adding the boxset folder first and then adding the children, right?  What is happening is the BoxSet image is getting generated before the children.  So, the children aren't there at the time and aren't in the image.  This is a tricky problem of chicken and egg but can probably be minimized by not bringing up any interface that would cause the image to generate before the children are all there.

 

What if you were to incorporate the list of children into GetConfigurationCacheKey?

Link to post
Share on other sites

What if you were to incorporate the list of children into GetConfigurationCacheKey?

 

I actually already do that (to handle the situation where children are added or removed).  The problem here is that the images for the children don't exist yet, not the children themselves.

Link to post
Share on other sites
crashkelly

Hi,

 

I tried the method that you suggested on three different box sets and it seems a bit hit and miss. Two of the box sets worked out perfectly and the treatment was applied. The other did not get the treatment and seems stuck that way.

 

Once the movies were in place, and after the scan media collection was done and all the metadata was downloaded, I created the box set folder and then pasted in the shortcuts to the movies. Fairly quickly the collection metadata was downloaded and I went to check the BoxSet collection page in the web browser. The boxset was there but the selected treatment was not applied and it stated "0 movies" beside it. I went back and checked the shortcuts and they work fine. I have tried removing the box set collection and reading it but the treatment is never applied. I have tried refreshing everything via "Edit >> Refresh", with "Force Refresh" and "Refresh Child Items" selected, but the treatment is still not applied.

 

Checking this morning, the box set now says "2 movies" and all items are accessible, but after refreshing the treatment is still not being applied.

 

Thanks for any help

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...