Jump to content

Android app random stops when playing in car with bluetooth


Przemek
 Share

Recommended Posts

Przemek

Hello, I have my Emby Server on Debian mini pc. When I connect my smartphone trough bluetooth and play music app randomly stops and I have to exit it and open again to make it work. Then after few minutes stops again. It's horrible experience. Don't have that problem on other android apps when listen trough bluetooth. When i listen with browser from my smartphone it works OK. I attach log on different topic: emby.log
regards,
Przemek

Link to comment
Share on other sites

Hi there, what device and version of android?

Link to comment
Share on other sites

Przemek

Hi, @Luke. I have Motorola One Vision with Android 10. 

regards.

Link to comment
Share on other sites

OK, please try again with the next update to the emby android app. Thanks.

Link to comment
Share on other sites

Przemek
Posted (edited)

Hi, @Luke I noticed today that Android app don't play at all. I try music, series and audiobook. This is not bluetooth car issue because I turn off bluetooth and it won't work either. Then I open in chrome n smartphone and it works OK.

Edit. Now I play with app and it works. I try wifi in home and mobile internet. I don't understant this 😕
hen will be that upgrade?

Regards.

Edited by Przemek
Link to comment
Share on other sites

Hi, please try again with the next update to the android app. Thanks.

Link to comment
Share on other sites

Przemek
On 6/4/2021 at 6:33 PM, Luke said:

Hi, please try again with the next update to the android app. Thanks.

Hi, last Monday when I drive my car and listen to audiobook [Emby in chrome browser on Android] for about 3h playback stops when some chapter ends. Then I cannot play another chapter. I must turn off bluetooth, LTE and chrome browser and start Emby again. So maybe that is not Android app problem but on Android Emby App it occurs much more frequently.

regards.

Link to comment
Share on other sites

  • 2 weeks later...
On 6/9/2021 at 7:39 AM, Przemek said:

Hi, last Monday when I drive my car and listen to audiobook [Emby in chrome browser on Android] for about 3h playback stops when some chapter ends. Then I cannot play another chapter. I must turn off bluetooth, LTE and chrome browser and start Emby again. So maybe that is not Android app problem but on Android Emby App it occurs much more frequently.

regards.

HI, the web app is different, and web apps do not get permission to stay running in the background for long periods of time, so that's completely different.

Anyway we should have the next Emby android app update really soon. Thanks.

Link to comment
Share on other sites

Przemek

Hi, @Luke I try Plex server on the same device and also have that issue with my music. Today I listen in car with bluetooth and after few tracks it stop and I see notification in my car screen to click Play on my smartphone. Clicking don't start track. I must shutdown Plex app, reconnect bluetooth and start again. I think that is something wrong with my smartphone. You can delete that topic. Sorry for that.

regards,
Przemek

Link to comment
Share on other sites

6 hours ago, Przemek said:

Hi, @Luke I try Plex server on the same device and also have that issue with my music. Today I listen in car with bluetooth and after few tracks it stop and I see notification in my car screen to click Play on my smartphone. Clicking don't start track. I must shutdown Plex app, reconnect bluetooth and start again. I think that is something wrong with my smartphone. You can delete that topic. Sorry for that.

regards,
Przemek

That's interesting, thanks for the info.

Link to comment
Share on other sites

Przemek
Posted (edited)

Hi, @Luke, I don't know what to think now. Today after Emby for Android upgrade my app stop playing during first song. I try many times in car and at home so that is not Bluetooth related because I try also without it. Maybe  something with my server? It stops but only on LTE mobile internet when I connect trough SSL. 

I also check on other smartphone One Plus and also stops.

Regards,

Przemek.

Edited by Przemek
Link to comment
Share on other sites

Are you using a reverse proxy?

Link to comment
Share on other sites

Przemek

Hi @Luke I don't use reverse proxy. I use myserwername.ddns.net from NO-IP and that how I use SSL certificate.

Regards.

Link to comment
Share on other sites

Have you tried with the remote connection on LTE, but with plain http?

Link to comment
Share on other sites

Przemek
13 hours ago, Luke said:

Have you tried with the remote connection on LTE, but with plain http?

That will not work because it redirect to https.

Link to comment
Share on other sites

2 hours ago, Przemek said:

That will not work because it redirect to https.

What is doing the redirect?

Link to comment
Share on other sites

Przemek
13 hours ago, Luke said:

What is doing the redirect?

Hmm, my server?

Link to comment
Share on other sites

On 7/2/2021 at 2:08 AM, Przemek said:

Hmm, my server?

But at what layer? Emby Server, or some other software?

Link to comment
Share on other sites

Przemek

Yes, @Luke I use Emby server. I try also Plex server and had the same issue for music. 

Link to comment
Share on other sites

Przemek

Today I use Emby app on different location. First on wifi and works OK. I can listen to many tracks. Next I switch to mobile internet and it stops playing during first song. So both try was on https. :(

Maybe my LTE mobile internet cause some issues with my server?

Regards.

Link to comment
Share on other sites

Przemek

Hi @Luke. Two days I test some other solution. I copy some of my music files to my Nextcloud. I have Nextcloud on the same MiniPC as Emby and I use the same letsencrypt certificte for both. I install Music addon for nextcloud wchich provide subsonic server instance and I install subsonic for android. Now I listen to my music and nothing stops for now.

Regards. 

Link to comment
Share on other sites

Can you try the new update that is currently rolling out? Thanks.

Link to comment
Share on other sites

Przemek

Hi @Luke last time I drive a cor and listen to some album for 2 hours without problem. I was very happy my problem is over. Then I stop and go to gas station, start to listen to my playlist and it stops during first song. 😕

regards.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...